aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-07-17 11:00:08 +0200
committerKoen Kooi <koen@openembedded.org>2009-07-17 11:00:08 +0200
commitdf32848d8e59cfcda5b12d7949236384a74545db (patch)
treedb6cef5521d57e3cafe070bf1723cbaa1545c421 /recipes
parent88290161c02e7dc418f43202ccd92334a42e70e7 (diff)
downloadopenembedded-df32848d8e59cfcda5b12d7949236384a74545db.tar.gz
gstreamer: sync with TI arago overlay a bit
Diffstat (limited to 'recipes')
-rw-r--r--recipes/gstreamer/gst-plugins-bad_0.10.12.bb11
-rw-r--r--recipes/gstreamer/gst-plugins-bad_0.10.9.bb14
-rw-r--r--recipes/gstreamer/gst-plugins-good/fix-unit-scale-asseration.patch33
-rw-r--r--recipes/gstreamer/gst-plugins-good_0.10.15.bb14
-rw-r--r--recipes/gstreamer/gstreamer_0.10.23.bb2
5 files changed, 74 insertions, 0 deletions
diff --git a/recipes/gstreamer/gst-plugins-bad_0.10.12.bb b/recipes/gstreamer/gst-plugins-bad_0.10.12.bb
new file mode 100644
index 0000000000..c7aa008d61
--- /dev/null
+++ b/recipes/gstreamer/gst-plugins-bad_0.10.12.bb
@@ -0,0 +1,11 @@
+require gst-plugins.inc
+
+SRC_URI += "file://vorbisenc.h file://vorbisdec.h \
+ file://ivorbis-thumb.patch;patch=1"
+
+DEPENDS += "gst-plugins-base openssl directfb"
+
+do_compile_prepend() {
+ # work around missing files in upstream tarball (upstream bug #454078)
+ install -m 0644 ${WORKDIR}/vorbis*.h ${S}/ext/ivorbis/
+}
diff --git a/recipes/gstreamer/gst-plugins-bad_0.10.9.bb b/recipes/gstreamer/gst-plugins-bad_0.10.9.bb
new file mode 100644
index 0000000000..fdcc240dd7
--- /dev/null
+++ b/recipes/gstreamer/gst-plugins-bad_0.10.9.bb
@@ -0,0 +1,14 @@
+require gst-plugins.inc
+PR = "r2"
+
+SRC_URI += "file://vorbisenc.h file://vorbisdec.h \
+ file://gst-plugins-directfb-fix.patch;patch=1;pnum=2 \
+ file://ivorbis-thumb.patch;patch=1"
+
+DEPENDS += "gst-plugins-base openssl"
+EXTRA_OECONF += " ac_cv_openssldir=no"
+
+do_compile_prepend() {
+ # work around missing files in upstream tarball (upstream bug #454078)
+ install -m 0644 ${WORKDIR}/vorbis*.h ${S}/ext/ivorbis/
+}
diff --git a/recipes/gstreamer/gst-plugins-good/fix-unit-scale-asseration.patch b/recipes/gstreamer/gst-plugins-good/fix-unit-scale-asseration.patch
new file mode 100644
index 0000000000..749c4918a9
--- /dev/null
+++ b/recipes/gstreamer/gst-plugins-good/fix-unit-scale-asseration.patch
@@ -0,0 +1,33 @@
+diff -uNr gst-plugins-good-0.10.15/sys/v4l2/gstv4l2src.c gst-plugins-good-0.10.15.new/sys/v4l2/gstv4l2src.c
+--- gst-plugins-good-0.10.15/sys/v4l2/gstv4l2src.c 2009-05-11 19:00:07.000000000 -0500
++++ gst-plugins-good-0.10.15.new/sys/v4l2/gstv4l2src.c 2009-06-22 09:51:50.000000000 -0500
+@@ -1377,14 +1377,22 @@
+ timestamp = gst_clock_get_time (clock) - timestamp;
+ gst_object_unref (clock);
+
+- latency =
+- gst_util_uint64_scale_int (GST_SECOND, v4l2src->fps_d,
+- v4l2src->fps_n);
++ /* we must have a framerate */
++ if (v4l2src->fps_n <= 0 || v4l2src->fps_d <= 0) {
++ GST_WARNING_OBJECT (src,
++ "Can't give latency since framerate isn't fixated !");
++ timestamp = GST_CLOCK_TIME_NONE;
++ }
++ else {
++ latency =
++ gst_util_uint64_scale_int (GST_SECOND, v4l2src->fps_d,
++ v4l2src->fps_n);
+
+- if (timestamp > latency)
+- timestamp -= latency;
+- else
+- timestamp = 0;
++ if (timestamp > latency)
++ timestamp -= latency;
++ else
++ timestamp = 0;
++ }
+ }
+
+ /* FIXME: use the timestamp from the buffer itself! */
diff --git a/recipes/gstreamer/gst-plugins-good_0.10.15.bb b/recipes/gstreamer/gst-plugins-good_0.10.15.bb
new file mode 100644
index 0000000000..ff4d11bc08
--- /dev/null
+++ b/recipes/gstreamer/gst-plugins-good_0.10.15.bb
@@ -0,0 +1,14 @@
+require gst-plugins.inc
+
+PR = "r3"
+
+SRC_URI += "file://fix-unit-scale-asseration.patch;patch=1"
+
+OE_ALLOW_INSECURE_DOWNLOADS = "1"
+inherit gconf
+
+DEPENDS += "gst-plugins-base openssl popt"
+
+PACKAGES =+ "gst-plugin-gconfelements"
+FILES_gst-plugin-gconfelements += "${sysconfdir}/gconf"
+
diff --git a/recipes/gstreamer/gstreamer_0.10.23.bb b/recipes/gstreamer/gstreamer_0.10.23.bb
index 906aa239ac..22bc2172ed 100644
--- a/recipes/gstreamer/gstreamer_0.10.23.bb
+++ b/recipes/gstreamer/gstreamer_0.10.23.bb
@@ -1,5 +1,7 @@
require gstreamer.inc
+EXTRA_OECONF += "ac_cv_func_register_printf_function=no"
+
do_configure_prepend() {
sed -i -e s:docs::g Makefile.am
}