aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorHenning Heinold <heinold@inf.fu-berlin.de>2011-02-11 09:38:06 +0100
committerHenning Heinold <heinold@inf.fu-berlin.de>2011-02-11 10:02:00 +0100
commiteae7de3042a099edc762d01ba62a161af6a1a934 (patch)
tree84d5b520911a041bf029fad19744f8915158d07d /recipes
parentaf8541c1ba14f5b075f5fdf93fc7f0689656432c (diff)
downloadopenembedded-eae7de3042a099edc762d01ba62a161af6a1a934.tar.gz
libsdl-mixer: fix it the same way as the libsdl recipe and bump PR
Diffstat (limited to 'recipes')
-rw-r--r--recipes/libsdl/libsdl-mixer_1.2.11.bb20
1 files changed, 11 insertions, 9 deletions
diff --git a/recipes/libsdl/libsdl-mixer_1.2.11.bb b/recipes/libsdl/libsdl-mixer_1.2.11.bb
index 498f3591c5..d495503b65 100644
--- a/recipes/libsdl/libsdl-mixer_1.2.11.bb
+++ b/recipes/libsdl/libsdl-mixer_1.2.11.bb
@@ -4,15 +4,13 @@ PRIORITY = "optional"
DEPENDS = "virtual/libsdl flac libmikmod libvorbis ${@base_conditional('ENTERPRISE_DISTRO', '1', '', 'libmad', d)}"
LICENSE = "LGPL"
-PR = "r5"
+PR = "r6"
SRC_URI = "http://www.libsdl.org/projects/SDL_mixer/release/SDL_mixer-${PV}.tar.gz \
file://fix-flac-madness.diff"
S = "${WORKDIR}/SDL_mixer-${PV}"
-export SDL_CONFIG = "${STAGING_BINDIR_CROSS}/sdl-config"
-
inherit autotools
# Although we build SMPEG lets not use it as it is pointless in the embedded space.
@@ -20,14 +18,18 @@ inherit autotools
# Add support for runtime linking with libmad so we can use that for fixed point MP3 decoding.
# Add support for runtime linking with libtremor so we can use that for fixed point OGG Vorbis decoding.
-EXTRA_OECONF = "--disable-music-mp3 --enable-music-ogg --enable-music-ogg-tremor ${@base_conditional('ENTERPRISE_DISTRO', '1', '', '--enable-music-mp3-mad-gpl', d)} LIBS=-L${STAGING_LIBDIR}"
+EXTRA_AUTORECONF += "--include=acinclude --exclude=autoheader"
-do_compile() {
- # Override SDL_LIBS to include a linker rpath so the linker
- # can find the correct libdl.so when it links playwave to
- # libSDL_mixer.so.
- oe_runmake SDL_LIBS="$(pkg-config sdl --libs) -Wl,-rpath-link,${STAGING_LIBDIR}"
+do_configure_prepend () {
+ # Remove old libtool macros.
+ MACROS="libtool.m4 lt~obsolete.m4 ltoptions.m4 ltsugar.m4 ltversion.m4"
+ for i in ${MACROS}; do
+ rm -f acinclude/$i
+ done
+ export SYSROOT=$PKG_CONFIG_SYSROOT_DIR
}
+EXTRA_OECONF = "--disable-music-mp3 --enable-music-ogg --enable-music-ogg-tremor ${@base_conditional('ENTERPRISE_DISTRO', '1', '', '--enable-music-mp3-mad-gpl', d)} LIBS=-L${STAGING_LIBDIR}"
+
SRC_URI[md5sum] = "65ada3d997fe85109191a5fb083f248c"
SRC_URI[sha256sum] = "86145ac39cac6d2c6169c226f937648dca5e89dcd828751763dd174fa9af9cf9"