aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorDenis Carikli <GNUtoo@no-log.org>2010-12-07 22:32:51 +0000
committerDenis 'GNUtoo' Carikli <GNUtoo@no-log.org>2010-12-13 21:53:12 +0100
commitfbc3a2e8adb363b8c33610a9606dbf6f6cc2e01e (patch)
tree4b6075f2c215da8d5004f5225d014d622f76f643 /recipes
parent1ac08d1b21ce99aa266379d62d52c3e3609aa72b (diff)
downloadopenembedded-fbc3a2e8adb363b8c33610a9606dbf6f6cc2e01e.tar.gz
netbase: add iphone3g support
Without that patch, the user can't ssh into his device, because usb0 is not up on the device side Signed-off-by: Chris 'Lopi' Spehn <chris.spehn@gmail.com> Signed-off-by: Denis 'GNUtoo' Carikli <GNUtoo@no-log.org> Acked-by: Stefan Schmidt <stefan@datenfreihafen.org>
Diffstat (limited to 'recipes')
-rw-r--r--recipes/netbase/netbase/iphone3g/interfaces20
-rw-r--r--recipes/netbase/netbase_4.21.bb2
2 files changed, 21 insertions, 1 deletions
diff --git a/recipes/netbase/netbase/iphone3g/interfaces b/recipes/netbase/netbase/iphone3g/interfaces
new file mode 100644
index 0000000000..e0c5f21f7c
--- /dev/null
+++ b/recipes/netbase/netbase/iphone3g/interfaces
@@ -0,0 +1,20 @@
+# /etc/network/interfaces -- configuration file for ifup(8), ifdown(8)
+
+# The loopback interface
+auto lo
+iface lo inet loopback
+
+# Ethernet/RNDIS gadget (g_ether)
+# ... or on host side, usbnet and random hwaddr
+auto usb0
+iface usb0 inet static
+ address 192.168.0.202
+ netmask 255.255.255.0
+ network 192.168.0.0
+ up route add default gw 192.168.0.200 metric 8
+ up echo nameserver 208.67.222.222 > /etc/resolv.conf
+ up echo nameserver 208.67.220.220 >> /etc/resolv.conf
+ down route del default gw 192.168.0.200 metric 8
+
+auto wlan0
+iface wlan0 inet dhcp
diff --git a/recipes/netbase/netbase_4.21.bb b/recipes/netbase/netbase_4.21.bb
index 68b8637153..f3ae6e9383 100644
--- a/recipes/netbase/netbase_4.21.bb
+++ b/recipes/netbase/netbase_4.21.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "This package provides the necessary \
infrastructure for basic TCP/IP based networking."
SECTION = "base"
LICENSE = "GPLv2"
-PR = "r49"
+PR = "r50"
inherit update-rc.d