aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-01-11 16:21:09 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2010-01-11 16:55:01 +0100
commit0450653a9e28a36421f17935e6616ae40cb10daa (patch)
treee75688dd9bab732028060a79a0c73ad379a65400 /recipes
parent8f58eb85cda95f96db4a3e8b2f0ba5830430182f (diff)
downloadopenembedded-0450653a9e28a36421f17935e6616ae40cb10daa.tar.gz
fso: add .conf files to CONFFILES, remove .service file for fsogsmd for SHR
* fsogsmd is installed in SHR images only for testing purposes, but .service file makes dbus trying to autostart it, which conflicts with ogsmd running by default from frameworkd. Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes')
-rw-r--r--recipes/freesmartphone/fsodatad_git.bb3
-rw-r--r--recipes/freesmartphone/fsodeviced_git.bb3
-rw-r--r--recipes/freesmartphone/fsogsmd_git.bb8
-rw-r--r--recipes/freesmartphone/fsonetworkd_git.bb3
-rw-r--r--recipes/freesmartphone/fsotdld_git.bb3
-rw-r--r--recipes/freesmartphone/fsousaged_git.bb3
6 files changed, 17 insertions, 6 deletions
diff --git a/recipes/freesmartphone/fsodatad_git.bb b/recipes/freesmartphone/fsodatad_git.bb
index c2933ed4da..95f50ee5da 100644
--- a/recipes/freesmartphone/fsodatad_git.bb
+++ b/recipes/freesmartphone/fsodatad_git.bb
@@ -1,6 +1,6 @@
require cornucopia.inc
inherit fso-plugin
-PR = "${INC_PR}.1"
+PR = "${INC_PR}.2"
PV = "0.0.0+gitr${SRCREV}"
DEPENDS += "libxml2 mobile-broadband-provider-info"
@@ -13,3 +13,4 @@ do_install_append() {
}
FILES_${PN} += "${sysconfdir}/freesmartphone/fsodatad.conf"
+CONFFILES_${PN} += "${sysconfdir}/freesmartphone/fsodatad.conf"
diff --git a/recipes/freesmartphone/fsodeviced_git.bb b/recipes/freesmartphone/fsodeviced_git.bb
index 640f9d9835..67e0f771af 100644
--- a/recipes/freesmartphone/fsodeviced_git.bb
+++ b/recipes/freesmartphone/fsodeviced_git.bb
@@ -6,7 +6,7 @@ RDEPENDS += "libcanberra-alsa"
RRECOMMENDS += "fso-alsa-data"
PV = "0.9.0+gitr${SRCREV}"
PE = "1"
-PR = "${INC_PR}.7"
+PR = "${INC_PR}.8"
EXTRA_OECONF = "\
--enable-kernel26-rfkill \
@@ -28,3 +28,4 @@ do_install_append() {
}
FILES_${PN} += "${sysconfdir}/init.d/fsodeviced ${sysconfdir}/freesmartphone/fsodeviced.conf"
+CONFFILES_${PN} += "${sysconfdir}/freesmartphone/fsodeviced.conf"
diff --git a/recipes/freesmartphone/fsogsmd_git.bb b/recipes/freesmartphone/fsogsmd_git.bb
index ec46d62ff3..f6adeeb2c3 100644
--- a/recipes/freesmartphone/fsogsmd_git.bb
+++ b/recipes/freesmartphone/fsogsmd_git.bb
@@ -1,6 +1,6 @@
require cornucopia.inc
inherit fso-plugin
-PR = "${INC_PR}.1"
+PR = "${INC_PR}.2"
PV = "0.2.0+gitr${SRCREV}"
DEPENDS += "libfsoresource libgsm0710mux"
@@ -12,4 +12,10 @@ do_install_append() {
install -m 0644 ${WORKDIR}/fsogsmd.conf ${D}${sysconfdir}/freesmartphone/
}
+do_install_append_shr() {
+ # remove .service file to disable fsogsmd autostart
+ rm -f ${D}${datadir}/dbus-1/system-services/org.freesmartphone.ogsmd.service
+}
+
FILES_${PN} += "${sysconfdir}/freesmartphone/fsogsmd.conf"
+CONFFILES_${PN} += "${sysconfdir}/freesmartphone/fsogsmd.conf"
diff --git a/recipes/freesmartphone/fsonetworkd_git.bb b/recipes/freesmartphone/fsonetworkd_git.bb
index 50adeb86da..2faf0a5323 100644
--- a/recipes/freesmartphone/fsonetworkd_git.bb
+++ b/recipes/freesmartphone/fsonetworkd_git.bb
@@ -2,7 +2,7 @@ require cornucopia.inc
inherit fso-plugin
DEPENDS += "libnl2"
PV = "0.1.0.0+gitr${SRCREV}"
-PR = "${INC_PR}.1"
+PR = "${INC_PR}.2"
SRC_URI += "file://fsonetworkd.conf"
@@ -12,3 +12,4 @@ do_install_append() {
}
FILES_${PN} += "${sysconfdir}/freesmartphone/fsonetworkd.conf"
+CONFFILES_${PN} += "${sysconfdir}/freesmartphone/fsonetworkd.conf"
diff --git a/recipes/freesmartphone/fsotdld_git.bb b/recipes/freesmartphone/fsotdld_git.bb
index 14659bdeff..e6b64c312e 100644
--- a/recipes/freesmartphone/fsotdld_git.bb
+++ b/recipes/freesmartphone/fsotdld_git.bb
@@ -1,6 +1,6 @@
require cornucopia.inc
inherit fso-plugin
-PR = "${INC_PR}.1"
+PR = "${INC_PR}.2"
PV = "0.0.0+gitr${SRCREV}"
DEPENDS += "libfsotransport libfsoresource"
@@ -13,3 +13,4 @@ do_install_append() {
}
FILES_${PN} += "${sysconfdir}/freesmartphone/fsotdld.conf"
+CONFFILES_${PN} += "${sysconfdir}/freesmartphone/fsotdld.conf"
diff --git a/recipes/freesmartphone/fsousaged_git.bb b/recipes/freesmartphone/fsousaged_git.bb
index 0157df5b77..649b9e44a8 100644
--- a/recipes/freesmartphone/fsousaged_git.bb
+++ b/recipes/freesmartphone/fsousaged_git.bb
@@ -1,7 +1,7 @@
require cornucopia.inc
inherit fso-plugin
PV = "0.9.0.1+gitr${SRCREV}"
-PR = "${INC_PR}.1"
+PR = "${INC_PR}.2"
SRC_URI += "file://fsousaged.conf"
@@ -11,3 +11,4 @@ do_install_append() {
}
FILES_${PN} += "${sysconfdir}/freesmartphone/fsousaged.conf"
+CONFFILES_${PN} += "${sysconfdir}/freesmartphone/fsousaged.conf"