aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorHenning Heinold <heinold@inf.fu-berlin.de>2009-11-13 02:31:22 +0100
committerHenning Heinold <heinold@inf.fu-berlin.de>2009-11-13 02:31:22 +0100
commit14a73529b5d431f148c441e6a32c7ad52713db19 (patch)
tree0c2d80ecb0a0128c032a354fa293e43ae05811e8 /recipes
parent2c3bb2bf4504b194cf3c606e1d016cf0f98a5201 (diff)
downloadopenembedded-14a73529b5d431f148c441e6a32c7ad52713db19.tar.gz
pingus: make it buildable again
* add patches for finding right boost lib and fixing c-headers * pingus has no install target so make do_stage empty * bump PR
Diffstat (limited to 'recipes')
-rw-r--r--recipes/pingus/files/boost.patch13
-rw-r--r--recipes/pingus/files/cheader.patch27
-rw-r--r--recipes/pingus/pingus_0.7.2.bb10
3 files changed, 48 insertions, 2 deletions
diff --git a/recipes/pingus/files/boost.patch b/recipes/pingus/files/boost.patch
new file mode 100644
index 0000000000..cdf2425575
--- /dev/null
+++ b/recipes/pingus/files/boost.patch
@@ -0,0 +1,13 @@
+Index: pingus-0.7.2/SConstruct
+===================================================================
+--- pingus-0.7.2.orig/SConstruct 2009-11-13 01:58:16.445278586 +0100
++++ pingus-0.7.2/SConstruct 2009-11-13 01:58:25.944023225 +0100
+@@ -476,7 +476,7 @@
+ env['optional_sources'] += ['src/input/xinput_driver.cpp',
+ 'src/input/xinput_device.cpp']
+
+- if not config.CheckLibWithHeader('boost_signals', 'boost/signals.hpp', 'c++'):
++ if not config.CheckLibWithHeader('boost_signals-mt', 'boost/signals.hpp', 'c++'):
+ fatal_error += " * library 'boost_signals' not found\n"
+
+ if not config.CheckLibWithHeader('png', 'png.h', 'c++'):
diff --git a/recipes/pingus/files/cheader.patch b/recipes/pingus/files/cheader.patch
new file mode 100644
index 0000000000..dee22409a7
--- /dev/null
+++ b/recipes/pingus/files/cheader.patch
@@ -0,0 +1,27 @@
+Index: pingus-0.7.2/src/input/evdev_device.cpp
+===================================================================
+--- pingus-0.7.2.orig/src/input/evdev_device.cpp 2009-11-13 02:02:22.730671880 +0100
++++ pingus-0.7.2/src/input/evdev_device.cpp 2009-11-13 02:05:02.494404553 +0100
+@@ -25,6 +25,8 @@
+ #include <stdexcept>
+ #include <iostream>
+ #include <errno.h>
++#include <cstring>
++#include <cstdio>
+
+ #include "evdev_device.hpp"
+
+Index: pingus-0.7.2/src/tinygettext/po_file_reader.cpp
+===================================================================
+--- pingus-0.7.2.orig/src/tinygettext/po_file_reader.cpp 2009-11-13 01:59:35.807355200 +0100
++++ pingus-0.7.2/src/tinygettext/po_file_reader.cpp 2009-11-13 02:02:13.407754735 +0100
+@@ -23,7 +23,8 @@
+ #include <errno.h>
+ #include <sstream>
+ #include <stdexcept>
+-#include <string.h>
++#include <cstring>
++#include <cstdio>
+ #include "iconv.hpp"
+ #include "po_file_reader.hpp"
+
diff --git a/recipes/pingus/pingus_0.7.2.bb b/recipes/pingus/pingus_0.7.2.bb
index a10131fa51..10f99bae0e 100644
--- a/recipes/pingus/pingus_0.7.2.bb
+++ b/recipes/pingus/pingus_0.7.2.bb
@@ -1,9 +1,9 @@
DESCRIPTION = "Pingus is a free Lemmings clone."
-DEPENDS = "virtual/libsdl libsdl-image libsdl-mixer boost libpng"
+DEPENDS = "virtual/libiconv virtual/libsdl libsdl-image libsdl-mixer boost libpng"
LICENSE = "GPL"
HOMEPAGE = "http://pingus.seul.org/"
SECTION = "x11/games"
-PR = "r1"
+PR = "r2"
ARM_INSTRUCTION_SET = "arm"
@@ -12,6 +12,8 @@ inherit scons
SRC_URI = "\
http://pingus.seul.org/files/pingus-0.7.2.tar.bz2 \
file://sconstruct.diff;patch=1 \
+ file://boost.patch;patch=1 \
+ file://cheader.patch;patch=1 \
file://pingus.desktop \
file://pingus.png \
file://pingus-gta012.sh \
@@ -36,6 +38,10 @@ do_install() {
fi
}
+do_stage() {
+ :
+}
+
# Account for 1337 script in do_install
PACKAGE_ARCH_om-gta01 = "${MACHINE_ARCH}"
PACKAGE_ARCH_om-gta02 = "${MACHINE_ARCH}"