aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-05-10 13:55:31 +0200
committerKoen Kooi <koen@openembedded.org>2009-05-10 13:55:31 +0200
commit1f9093d95cb44179d171d337b63f2c5ecaf94086 (patch)
tree0b8b8349b5304e565cc28d69e23623333316f85a /recipes
parent28bac40e6c1bde11de63deda391624ed6dfff3f1 (diff)
downloadopenembedded-1f9093d95cb44179d171d337b63f2c5ecaf94086.tar.gz
telepathy: update empathy and telepathy bits
Diffstat (limited to 'recipes')
-rw-r--r--recipes/dbus/dbus-glib-0.78/no-examples.patch8
-rw-r--r--recipes/dbus/dbus-glib-0.78/no-introspect.patch14
-rw-r--r--recipes/dbus/dbus-glib_0.78.bb22
-rw-r--r--recipes/farsight/farsight2_0.0.9.bb22
-rw-r--r--recipes/farsight/libnice_0.0.6.bb23
-rw-r--r--recipes/telepathy/empathy_2.26.1.bb22
-rw-r--r--recipes/telepathy/telepathy-farsight_0.0.7.bb16
-rw-r--r--recipes/telepathy/telepathy-gabble-0.7.27/gabble.manager38
-rw-r--r--recipes/telepathy/telepathy-gabble_0.7.27.bb18
-rw-r--r--recipes/telepathy/telepathy-glib_0.7.29.bb14
-rw-r--r--recipes/telepathy/telepathy-mission-control_4.67.bb5
11 files changed, 198 insertions, 4 deletions
diff --git a/recipes/dbus/dbus-glib-0.78/no-examples.patch b/recipes/dbus/dbus-glib-0.78/no-examples.patch
new file mode 100644
index 0000000000..483153db74
--- /dev/null
+++ b/recipes/dbus/dbus-glib-0.78/no-examples.patch
@@ -0,0 +1,8 @@
+--- dbus-glib-0.70/dbus/Makefile.am.orig 2006-07-23 16:04:43.000000000 +0200
++++ dbus-glib-0.70/dbus/Makefile.am 2006-07-23 16:04:52.000000000 +0200
+@@ -1,4 +1,4 @@
+-SUBDIRS = . examples
++SUBDIRS = .
+
+ INCLUDES=-I$(top_srcdir) $(DBUS_CFLAGS) $(DBUS_GLIB_CFLAGS) $(DBUS_GLIB_TOOL_CFLAGS) -DDBUS_COMPILATION=1 -DDBUS_LOCALEDIR=\"$(prefix)/@DATADIRNAME@/locale\"
+
diff --git a/recipes/dbus/dbus-glib-0.78/no-introspect.patch b/recipes/dbus/dbus-glib-0.78/no-introspect.patch
new file mode 100644
index 0000000000..9115801f71
--- /dev/null
+++ b/recipes/dbus/dbus-glib-0.78/no-introspect.patch
@@ -0,0 +1,14 @@
+Index: dbus-glib-0.73/tools/Makefile.am
+===================================================================
+--- dbus-glib-0.73.orig/tools/Makefile.am 2006-10-25 21:10:36.000000000 +0200
++++ dbus-glib-0.73/tools/Makefile.am 2006-10-27 10:07:35.000000000 +0200
+@@ -3,9 +3,6 @@
+ nodist_libdbus_glib_HEADERS = dbus-glib-bindings.h
+ libdbus_glibdir = $(includedir)/dbus-1.0/dbus
+
+-dbus-glib-bindings.h: dbus-bus-introspect.xml $(top_builddir)/dbus/dbus-binding-tool$(EXEEXT)
+- $(top_builddir)/dbus/dbus-binding-tool --mode=glib-client --prefix=dbus_bus --output=dbus-glib-bindings.h dbus-bus-introspect.xml
+-
+ BUILT_SOURCES = dbus-glib-bindings.h dbus-bus-introspect.xml
+
+ if USE_INTROSPECT_XML
diff --git a/recipes/dbus/dbus-glib_0.78.bb b/recipes/dbus/dbus-glib_0.78.bb
new file mode 100644
index 0000000000..398314bdff
--- /dev/null
+++ b/recipes/dbus/dbus-glib_0.78.bb
@@ -0,0 +1,22 @@
+SECTION = "base"
+HOMEPAGE = "http://www.freedesktop.org/Software/dbus"
+DESCRIPTION = "message bus system for applications to talk to one another"
+LICENSE = "GPL"
+DEPENDS = "expat glib-2.0 virtual/libintl dbus-glib-native dbus"
+
+SRC_URI = "http://dbus.freedesktop.org/releases/dbus-glib/dbus-glib-${PV}.tar.gz \
+ file://no-examples.patch;patch=1 \
+ file://no-introspect.patch;patch=1"
+
+inherit autotools_stage gettext
+AUTOTOOLS_STAGE_PKGCONFIG = "1"
+
+FILES_${PN} = "${libdir}/lib*.so.* ${libexecdir}/dbus* ${sysconfdir}/profile.d"
+FILES_${PN}-dev += "${libdir}/dbus-1.0/include ${bindir}/dbus-glib-tool"
+
+do_configure_prepend() {
+ install -m 0644 ${STAGING_DATADIR_NATIVE}/dbus/dbus-bus-introspect.xml ${S}/tools/
+ install -m 0644 ${STAGING_DATADIR_NATIVE}/dbus/dbus-glib-bindings.h ${S}/tools/
+}
+
+FILES_${PN}-dev += "${bindir}/dbus-binding-tool"
diff --git a/recipes/farsight/farsight2_0.0.9.bb b/recipes/farsight/farsight2_0.0.9.bb
new file mode 100644
index 0000000000..19e081c33a
--- /dev/null
+++ b/recipes/farsight/farsight2_0.0.9.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "FarSight is an audio/video conferencing framework specifically designed for Instant Messengers."
+HOMEPAGE = "http://farsight.sf.net"
+SRC_URI = "http://farsight.freedesktop.org/releases/farsight2/${P}.tar.gz"
+
+DEPENDS = "libnice glib-2.0 libxml2 zlib dbus gstreamer gst-plugins-base"
+
+inherit autotools_stage
+AUTOTOOLS_STAGE_PKGCONFIG = "1"
+
+EXTRA_OECONF = " \
+ --disable-debug \
+ --disable-gtk-doc \
+ --disable-python \
+"
+
+FILES_${PN} += "${libdir}/*/*.so"
+FILES_${PN}-dev += "${libdir}/*/*a"
+FILES_${PN}-dbg += "${libdir}/*/.debug"
+
+
+
+
diff --git a/recipes/farsight/libnice_0.0.6.bb b/recipes/farsight/libnice_0.0.6.bb
new file mode 100644
index 0000000000..fa478dc0e3
--- /dev/null
+++ b/recipes/farsight/libnice_0.0.6.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "Libnice is an implementation of the IETF's draft Interactice Connectivity Establishment standard (ICE)."
+HOMEPAGE = "http://nice.freedesktop.org/wiki/"
+SRC_URI = "http://nice.freedesktop.org/releases/libnice-${PV}.tar.gz"
+
+LICENSE = "LGPL/MPL"
+DEPENDS = "glib-2.0 gstreamer"
+
+inherit autotools_stage
+AUTOTOOLS_STAGE_PKGCONFIG = "1"
+
+FILES_${PN} += "${libdir}/gstreamer-0.10/*.so"
+FILES_${PN}-dev += "${libdir}/gstreamer-0.10/*a"
+FILES_${PN}-dbg += "${libdir}/gstreamer-0.10/.debug"
+
+do_compile_append() {
+ for i in $(find ${S} -name "*.pc") ; do
+ sed -i -e s:${STAGING_DIR_TARGET}::g \
+ -e s:/${TARGET_SYS}::g \
+ $i
+ done
+}
+
+
diff --git a/recipes/telepathy/empathy_2.26.1.bb b/recipes/telepathy/empathy_2.26.1.bb
new file mode 100644
index 0000000000..3c11913e40
--- /dev/null
+++ b/recipes/telepathy/empathy_2.26.1.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "Empathy: a Telepathy based IM client"
+HOMEPAGE = "http://blogs.gnome.org/view/xclaesse/2007/04/26/0"
+LICENSE = "GPL"
+DEPENDS = "libcanberra telepathy-farsight gnome-doc-utils python-native telepathy-python telepathy-mission-control libtelepathy telepathy-glib gtk+ gconf libglade eds-dbus"
+RDEPENDS = "telepathy-mission-control"
+RRECOMMENDS = "telepathy-gabble"
+
+inherit gnome
+
+PARALLEL_MAKE = ""
+
+PACKAGES =+ "empathy-scrollkeeper-junk"
+FILES_empathy-scrollkeeper-junk = "/var/lib/scrollkeeper"
+
+FILES_${PN} += "${datadir}/mission-control/profiles/*.profile \
+ ${datadir}/dbus-1/services/*.service \
+ ${datadir}/telepathy/managers/*.chandler \
+ ${datadir}/icons \
+ ${libdir}/python*"
+
+FILES_${PN}-dbg += "${libdir}/python*/*/.debug"
+
diff --git a/recipes/telepathy/telepathy-farsight_0.0.7.bb b/recipes/telepathy/telepathy-farsight_0.0.7.bb
new file mode 100644
index 0000000000..ee1966b9d3
--- /dev/null
+++ b/recipes/telepathy/telepathy-farsight_0.0.7.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "Telepathy fasrsight"
+HOMEPAGE = "http://telepathy.freedesktop.org/wiki/"
+DEPENDS = "glib-2.0 dbus telepathy-glib farsight2"
+LICENSE = "LGPLv2"
+
+SRC_URI = "http://telepathy.freedesktop.org/releases/telepathy-farsight/${P}.tar.gz \
+"
+
+inherit autotools_stage
+
+EXTRA_OECONF = "--disable-python"
+
+AUTOTOOLS_STAGE_PKGCONFIG = "1"
+
+FILES_${PN} += "${datadir}/telepathy \
+ ${datadir}/dbus-1"
diff --git a/recipes/telepathy/telepathy-gabble-0.7.27/gabble.manager b/recipes/telepathy/telepathy-gabble-0.7.27/gabble.manager
new file mode 100644
index 0000000000..5bb107b1c9
--- /dev/null
+++ b/recipes/telepathy/telepathy-gabble-0.7.27/gabble.manager
@@ -0,0 +1,38 @@
+
+[ConnectionManager]
+BusName=org.freedesktop.Telepathy.ConnectionManager.gabble
+ObjectPath=/org/freedesktop/Telepathy/ConnectionManager/gabble
+
+[Protocol jabber]
+param-account=s required register
+param-password=s required register
+param-server=s
+param-resource=s
+param-priority=n
+param-port=q
+param-old-ssl=b
+param-require-encryption=b
+param-register=b
+param-low-bandwidth=b
+param-https-proxy-server=s
+param-https-proxy-port=q
+param-fallback-conference-server=s
+param-stun-server=s
+param-stun-port=q
+param-fallback-stun-server=s
+param-fallback-stun-port=q
+param-ignore-ssl-errors=b
+param-alias=s
+param-fallback-socks5-proxies=as
+default-resource=Telepathy
+default-priority=0
+default-old-ssl=false
+default-require-encryption=false
+default-register=false
+default-low-bandwidth=false
+default-https-proxy-port=443
+default-stun-port=3478
+default-fallback-stun-server=stun.collabora.co.uk
+default-fallback-stun-port=3478
+default-ignore-ssl-errors=false
+default-fallback-socks5-proxies=proxy.jabber.org;proxy.jabberfr.org;proxy.isgeek.info;proxy2.isgeek.info;proxy65.rooyee.biz;proxy.jabbim.cz;proxy.911910.cn;proxy.aszlig.net;proxy.brauchen.info;proxy.core.im;proxy.deshalbfrei.org;proxy.downtempo.de;proxy.draugr.de;proxy.egbers.info;proxy.headcounter.org;proxy.im.flosoft.biz;proxy.jabber-hispano.org;proxy.jabber.bluendo.com;proxy.jabber.dk;proxy.jabber.freenet.de;proxy.fsinf.at;proxy.jabber.kg;proxy.jabber.minus273.org;proxy.jabber.planetteamspeak.com;proxy.jabber.tf-network.de;proxy.jabjab.de;proxy.jabster.pl;proxy.noicq.org;proxy.schokokeks.org;proxy.silper.cz;proxy.ubuntu-jabber.de;proxy.ubuntu-jabber.net;proxy65.unstable.nl;proxy.verdammung.org;proxy.vke.ru;proxy.vodka-pomme.net;proxy.xabber.de;proxy.jabbernet.eu;
diff --git a/recipes/telepathy/telepathy-gabble_0.7.27.bb b/recipes/telepathy/telepathy-gabble_0.7.27.bb
new file mode 100644
index 0000000000..ce16509800
--- /dev/null
+++ b/recipes/telepathy/telepathy-gabble_0.7.27.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "Gabble: a Jabber/XMPP connection manager"
+HOMEPAGE = "http://telepathy.freedesktop.org/wiki/"
+DEPENDS = "glib-2.0 dbus loudmouth telepathy-glib"
+LICENSE = "LGPL"
+
+# gabble.manager needs to get regenerated every release, so please don't copy it over blindly
+SRC_URI = "http://telepathy.freedesktop.org/releases/telepathy-gabble/${P}.tar.gz \
+ file://gabble.manager"
+
+inherit autotools_stage
+AUTOTOOLS_STAGE_PKGCONFIG = "1"
+
+do_compile_prepend() {
+ cp ${WORKDIR}/gabble.manager ${S}/data/
+}
+
+FILES_${PN} += "${datadir}/telepathy \
+ ${datadir}/dbus-1"
diff --git a/recipes/telepathy/telepathy-glib_0.7.29.bb b/recipes/telepathy/telepathy-glib_0.7.29.bb
new file mode 100644
index 0000000000..aaed2b7053
--- /dev/null
+++ b/recipes/telepathy/telepathy-glib_0.7.29.bb
@@ -0,0 +1,14 @@
+DESCRIPTION = "Telepathy framework - GLib library"
+HOMEPAGE = "http://telepathy.freedesktop.org/wiki/"
+DEPENDS = "glib-2.0 dbus libxslt-native python-native dbus-native"
+LICENSE = "LGPL"
+
+SRC_URI = "http://telepathy.freedesktop.org/releases/telepathy-glib/${P}.tar.gz "
+
+inherit autotools_stage
+
+AUTOTOOLS_STAGE_PKGCONFIG = "1"
+
+FILES_${PN} += "${datadir}/telepathy \
+ ${datadir}/dbus-1"
+
diff --git a/recipes/telepathy/telepathy-mission-control_4.67.bb b/recipes/telepathy/telepathy-mission-control_4.67.bb
index 418a265512..0bdb20b5cf 100644
--- a/recipes/telepathy/telepathy-mission-control_4.67.bb
+++ b/recipes/telepathy/telepathy-mission-control_4.67.bb
@@ -7,7 +7,7 @@ PR = "r0"
SRC_URI = "${SOURCEFORGE_MIRROR}/mission-control/telepathy-mission-control-${PV}.tar.gz"
-inherit autotools
+inherit autotools_stage
PACKAGES =+ " \
libmissioncontrol \
@@ -47,6 +47,3 @@ do_compile_append() {
done
}
-do_stage() {
- autotools_stage_all
-}