aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorRoman I Khimov <khimov@altell.ru>2010-10-25 16:26:41 +0400
committerRoman I Khimov <khimov@altell.ru>2010-10-30 11:09:25 +0400
commit237d418d6409fff608cb7acdcfefe8bbd6c150ad (patch)
tree33b28b8be775c16778a2c0a4987c2800d7ec1662 /recipes
parent349668f16645693059af84dcf8e128d8ff10bae9 (diff)
downloadopenembedded-237d418d6409fff608cb7acdcfefe8bbd6c150ad.tar.gz
paxtest: new recipe, version 0.9.9
PaX is a Linux kernel patch which adds much stricter control on how memory is being used by applications. A normal Linux kernel leaves the control to the application and does not implement any enforcement. Especially buffer overflow attacks benefit from the absence of kernel enforced memory control. PaX tries to do its best to enforce this control of memory used by applications, thereby making it harder to successfully exploit buffer overflows. Paxtest provides a regression test suite that covers most (but not all) of PaX functionality. It can also be used to test other memory protection patches. Signed-off-by: Roman I Khimov <khimov@altell.ru>
Diffstat (limited to 'recipes')
-rw-r--r--recipes/paxtest/paxtest_0.9.9.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes/paxtest/paxtest_0.9.9.bb b/recipes/paxtest/paxtest_0.9.9.bb
new file mode 100644
index 0000000000..c840ace945
--- /dev/null
+++ b/recipes/paxtest/paxtest_0.9.9.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "Test suite for the PaX kernel patch"
+HOMEPAGE = "http://www.grsecurity.net/~spender/"
+LICENSE = "GPLv2+"
+
+SRC_URI = "http://www.grsecurity.net/~spender/paxtest-${PV}.tgz"
+SRC_URI[md5sum] = "7599f41823c73174d056d01b12ae5662"
+SRC_URI[sha256sum] = "caca340492dedeee588d47683efde9797cba4fce5adca5d5f9b0b73b2120e1ab"
+
+COMPATIBLE_HOST = "(x86_64|i.86)*"
+
+PARALLEL_MAKE = ""
+
+EXTRA_OEMAKE = "-e -f Makefile.psm"
+
+CFLAGS += "-D_FORTIFY_SOURCE=0 -DRUNDIR=\\"${RUNDIR}\\""
+
+export RUNDIR="${libexecdir}/paxtest"
+export SHLDFLAGS="${LDFLAGS}"
+
+do_install() {
+ oe_runmake DESTDIR=${D} BINDIR=${bindir} install
+}
+
+FILES_${PN}-dbg += "${libexecdir}/paxtest/.debug" \ No newline at end of file