aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorElena Grandi <elena.valhalla@gmail.com>2009-05-14 07:14:55 +0000
committerKhem Raj <raj.khem@gmail.com>2009-08-08 13:06:05 -0700
commit272c915e842baa46354c699816b33fd4a9c8f687 (patch)
tree31838f9e5c644cc62679f1aac2dbef489cce4acf /recipes
parent5a728f256a542d0105a17778e428c704b6bddb54 (diff)
downloadopenembedded-272c915e842baa46354c699816b33fd4a9c8f687.tar.gz
gtksourceview: renamed the 1.x tree to gtksourceview1
GtkSourceView 1.x is an older stable version that is still required by some packages and is currently used in 2 recipes. Signed-off-by: Elena Grandi <elena.valhalla@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes')
-rw-r--r--recipes/gobby/gobby_0.4.1.bb3
-rw-r--r--recipes/gobby/gtksourceview_1.7.2.bb9
-rw-r--r--recipes/gtksourceview/gtksourceview1_1.7.2.bb16
-rw-r--r--recipes/tea/tea_17.3.5.bb4
4 files changed, 20 insertions, 12 deletions
diff --git a/recipes/gobby/gobby_0.4.1.bb b/recipes/gobby/gobby_0.4.1.bb
index f9474c8fe3..87f0fb9c5e 100644
--- a/recipes/gobby/gobby_0.4.1.bb
+++ b/recipes/gobby/gobby_0.4.1.bb
@@ -1,7 +1,8 @@
LICENSE = "LGPL"
HOMEPAGE = "http://darcs.0x539.de/trac/obby/cgi-bin/trac.cgi/wiki/"
+PR = "r1"
-DEPENDS = "net6 gtkmm obby gtksourceview libxml++"
+DEPENDS = "net6 gtkmm obby gtksourceview1 libxml++"
inherit autotools pkgconfig
SRC_URI = "http://releases.0x539.de/gobby/gobby-${PV}.tar.gz"
diff --git a/recipes/gobby/gtksourceview_1.7.2.bb b/recipes/gobby/gtksourceview_1.7.2.bb
deleted file mode 100644
index 6b4c8e686c..0000000000
--- a/recipes/gobby/gtksourceview_1.7.2.bb
+++ /dev/null
@@ -1,9 +0,0 @@
-LICENSE = "GPL"
-
-DEPENDS = "gtk+ libgnomeprint"
-
-inherit gnome pkgconfig
-
-do_stage() {
-autotools_stage_all
-}
diff --git a/recipes/gtksourceview/gtksourceview1_1.7.2.bb b/recipes/gtksourceview/gtksourceview1_1.7.2.bb
new file mode 100644
index 0000000000..44d88fb80d
--- /dev/null
+++ b/recipes/gtksourceview/gtksourceview1_1.7.2.bb
@@ -0,0 +1,16 @@
+LICENSE = "GPL"
+
+PNAME = "gtksourceview"
+
+DEPENDS = "gtk+ libgnomeprint"
+
+S = "${WORKDIR}/${PNAME}-${PV}"
+
+inherit gnome pkgconfig
+
+# overrule SRC_URI from gnome.conf
+SRC_URI = "${GNOME_MIRROR}/${PNAME}/${@gnome_verdir("${PV}")}/${PNAME}-${PV}.tar.bz2"
+
+do_stage() {
+autotools_stage_all
+}
diff --git a/recipes/tea/tea_17.3.5.bb b/recipes/tea/tea_17.3.5.bb
index c8dac8c94f..6412db0466 100644
--- a/recipes/tea/tea_17.3.5.bb
+++ b/recipes/tea/tea_17.3.5.bb
@@ -1,8 +1,8 @@
DESCRIPTION = "Tea - a GTK based text editor with highlighting and a lot of processing features"
SECTION = "gpe"
LICENSE = "GPL"
-DEPENDS = "gtk+ gtksourceview"
-PR = "r1"
+DEPENDS = "gtk+ gtksourceview1"
+PR = "r2"
inherit autotools