aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorSebastian Spaeth <Sebastian@SSpaeth.de>2009-12-04 09:07:33 +0100
committerSebastian Spaeth <Sebastian@SSpaeth.de>2009-12-04 11:59:02 +0100
commit3943c0dac3e134e55a478cc575a005d57ed4e860 (patch)
tree9c7d43a6def5dff400a35493d5a7cd1831999cbb /recipes
parent3512b7de2daae13ecad6dbe4475bd58ab053cb29 (diff)
downloadopenembedded-3943c0dac3e134e55a478cc575a005d57ed4e860.tar.gz
task-base: Introduce DISTRO_APM and convert recipes to use that
Signed-off-by: Sebastian Spaeth <Sebastian@SSpaeth.de>
Diffstat (limited to 'recipes')
-rw-r--r--recipes/ipaq-sleep/ipaq-sleep_0.9.bb5
-rw-r--r--recipes/openmoko2/neod_svn.bb6
-rw-r--r--recipes/suspend-desktop/suspend-desktop_1.0.bb5
-rw-r--r--recipes/tasks/task-base.bb7
4 files changed, 15 insertions, 8 deletions
diff --git a/recipes/ipaq-sleep/ipaq-sleep_0.9.bb b/recipes/ipaq-sleep/ipaq-sleep_0.9.bb
index 24d881dd05..158de80bf1 100644
--- a/recipes/ipaq-sleep/ipaq-sleep_0.9.bb
+++ b/recipes/ipaq-sleep/ipaq-sleep_0.9.bb
@@ -2,8 +2,9 @@ DESCRIPTION = "Automatic sleep/suspend control daemon"
SECTION = "x11/base"
LICENSE = "GPL"
DEPENDS = "apmd virtual/xserver libxext virtual/libx11 libxau xscrnsaverh libxss"
-RDEPENDS = "apm"
-PR = "r6"
+DISTRO_APM ?= "apm"
+RDEPENDS = "${DISTRO_APM}"
+PR = "r7"
inherit gpe pkgconfig
diff --git a/recipes/openmoko2/neod_svn.bb b/recipes/openmoko2/neod_svn.bb
index aeeee871b3..e57bf08068 100644
--- a/recipes/openmoko2/neod_svn.bb
+++ b/recipes/openmoko2/neod_svn.bb
@@ -1,9 +1,11 @@
DESCRIPTION = "Simple Neo1973 Daemon for Button Handling and Power Management"
SECTION = "openmoko/daemons"
+
+DISTRO_APM ?= "apm"
DEPENDS = "gtk+ pulseaudio apmd"
-RDEPENDS = "gpe-scap xrandr alsa-utils-amixer apm dbus"
+RDEPENDS = "gpe-scap xrandr alsa-utils-amixer ${DISTRO_APM} dbus"
PV = "0.1.0+svnr${SRCPV}"
-PR = "r6"
+PR = "r7"
inherit openmoko2 gconf
diff --git a/recipes/suspend-desktop/suspend-desktop_1.0.bb b/recipes/suspend-desktop/suspend-desktop_1.0.bb
index fa9efba84b..085d686aa1 100644
--- a/recipes/suspend-desktop/suspend-desktop_1.0.bb
+++ b/recipes/suspend-desktop/suspend-desktop_1.0.bb
@@ -3,10 +3,11 @@ PRIORITY = "optional"
DESCRIPTION = "Suspend feature for the application launcher menu."
LICENSE = "GPL"
-PR = "r1"
+PR = "r2"
+DISTRO_APM ?= "apm"
RDEPENDS = "gpe-conf"
-RRECOMMENDS = "apm"
+RRECOMMENDS = "${DISTRO_APM}"
PACKAGES = "${PN}"
PACKAGE_ARCH = "all"
diff --git a/recipes/tasks/task-base.bb b/recipes/tasks/task-base.bb
index ed561b802e..b540c80bda 100644
--- a/recipes/tasks/task-base.bb
+++ b/recipes/tasks/task-base.bb
@@ -1,5 +1,5 @@
DESCRIPTION = "Merge machine and distro options to create a basic machine task/package"
-PR = "r86"
+PR = "r87"
inherit task
@@ -60,6 +60,9 @@ HOTPLUG ?= "${@base_contains("MACHINE_FEATURES", "kernel24", "linux-hotplug",""
#
DISTRO_SSH_DAEMON ?= "dropbear"
+# Distro can override apm provider
+DISTRO_APM ?= "apm"
+
#
# bluetooth manager
#
@@ -190,7 +193,7 @@ RDEPENDS_task-base-acpi = "\
acpid"
RDEPENDS_task-base-apm = "\
- apm \
+ "${DISTRO_APM}" \
apmd \
${@base_contains('MACHINE_FEATURES', 'kernel24', 'network-suspend-scripts', '',d)}"