aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorDenis 'GNUtoo' Carikli <GNUtoo@no-log.org>2010-06-09 16:38:42 +0200
committerDenis 'GNUtoo' Carikli <GNUtoo@no-log.org>2010-06-10 23:33:17 +0200
commit3e7f28bd305aeccc1022ecfb63d3f9bb25680067 (patch)
tree4296777d3740f13ee3a02a75fc147f74ec4efd08 /recipes
parent5a67c1d1daeb9016270cd514bb3eab179cd298b8 (diff)
downloadopenembedded-3e7f28bd305aeccc1022ecfb63d3f9bb25680067.tar.gz
linux-leviathan: permit booting directly with fastboot
if we don't gzip the empty ramdisk,the bootloader will refuse to boot our kenrnel when in fastboot mode and will display this message: booting... FAILED (remote: reproduce boot image with on-flash ramdisk error)
Diffstat (limited to 'recipes')
-rw-r--r--recipes/linux/linux-leviathan_git.bb5
1 files changed, 3 insertions, 2 deletions
diff --git a/recipes/linux/linux-leviathan_git.bb b/recipes/linux/linux-leviathan_git.bb
index 7ee49a6b56..bc8a477410 100644
--- a/recipes/linux/linux-leviathan_git.bb
+++ b/recipes/linux/linux-leviathan_git.bb
@@ -2,7 +2,7 @@ require linux.inc
DEPENDS += "android-image-utils-native"
PV = "2.6.32+${PR}+gitr${SRCREV}"
-PR = "r17"
+PR = "r18"
COMPATIBLE_MACHINE = "htcdream"
CMDLINE = "console=tty1 root=/dev/mmcblk0p1 rootdelay=8 fbcon=rotate:1 panic=30 mem=110M"
@@ -18,8 +18,9 @@ S = "${WORKDIR}/git"
do_deploy_append() {
touch -f empty
+ gzip empty
mkbootimg --kernel ${DEPLOY_DIR_IMAGE}/${KERNEL_IMAGE_BASE_NAME}.bin \
- --ramdisk empty \
+ --ramdisk empty.gz \
--cmdline "${CMDLINE}" \
--output ${DEPLOY_DIR_IMAGE}/${KERNEL_IMAGE_BASE_NAME}.fastboot
}