aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorAndrea Adami <andrea.adami@gmail.com>2010-10-09 15:18:13 +0200
committerAndrea Adami <andrea.adami@gmail.com>2010-10-21 00:48:38 +0200
commit455a48017a2c23a845110bbedbbe404daea01eed (patch)
tree419cdc93358f3014a869f2f53d0d6fe212770046 /recipes
parent4c0ffd9aaab88a55b5417c64329b253b77d0ba0c (diff)
downloadopenembedded-455a48017a2c23a845110bbedbbe404daea01eed.tar.gz
zaurus-utils: apply oe-stylize
Diffstat (limited to 'recipes')
-rw-r--r--recipes/zaurus-utils/encdec-updater.bb20
-rw-r--r--recipes/zaurus-utils/nandlogical-klibc_1.0.0.bb4
-rw-r--r--recipes/zaurus-utils/nandlogical_1.0.0.bb4
-rw-r--r--recipes/zaurus-utils/zaurus-installer.bb23
-rw-r--r--recipes/zaurus-utils/zaurus-legacy-tar.bb15
-rw-r--r--recipes/zaurus-utils/zaurus-updater.bb26
6 files changed, 42 insertions, 50 deletions
diff --git a/recipes/zaurus-utils/encdec-updater.bb b/recipes/zaurus-utils/encdec-updater.bb
index 7bd85c5a60..1fa7693c44 100644
--- a/recipes/zaurus-utils/encdec-updater.bb
+++ b/recipes/zaurus-utils/encdec-updater.bb
@@ -1,19 +1,19 @@
+DESCRIPTION = "A tool to encode and decode the Sharp Zaurus updater.sh script"
SECTION = "console/utils"
LICENSE = "GPL"
-DESCRIPTION = "A tool to encode and decode the Sharp Zaurus updater.sh script"
SRC_URI = "file://encdec-updater.c"
-COMPATIBLE_MACHINE = '(poodle|c7x0|spitz|akita|tosa)'
-
-BBCLASSEXTEND = "native"
-NATIVE_INSTALL_WORKS = "1"
-
do_compile() {
- ${CC} ${LDFLAGS} -o encdec-updater ${WORKDIR}/encdec-updater.c
+ ${CC} ${LDFLAGS} -o encdec-updater ${WORKDIR}/encdec-updater.c
}
-
do_install() {
- install -d ${D}${bindir}
- install -m 0755 encdec-updater ${D}${bindir}/
+ install -d ${D}${bindir}
+ install -m 0755 encdec-updater ${D}${bindir}/
}
+
+BBCLASSEXTEND = "native"
+
+COMPATIBLE_MACHINE = "(poodle|c7x0|spitz|akita|tosa)"
+
+NATIVE_INSTALL_WORKS = "1"
diff --git a/recipes/zaurus-utils/nandlogical-klibc_1.0.0.bb b/recipes/zaurus-utils/nandlogical-klibc_1.0.0.bb
index 0f5e4925e2..3f28589682 100644
--- a/recipes/zaurus-utils/nandlogical-klibc_1.0.0.bb
+++ b/recipes/zaurus-utils/nandlogical-klibc_1.0.0.bb
@@ -1,9 +1,9 @@
require nandlogical_${PV}.bb
-FILESPATHPKG =. "nandlogical:"
-
inherit klibc
do_compile() {
${CC} ${CFLAGS} ${LDFLAGS} -static -I${STAGING_INCDIR} nandlogical.c -o nandlogical
}
+
+FILESPATHPKG =. "nandlogical:"
diff --git a/recipes/zaurus-utils/nandlogical_1.0.0.bb b/recipes/zaurus-utils/nandlogical_1.0.0.bb
index 9a6312c562..0da2d23356 100644
--- a/recipes/zaurus-utils/nandlogical_1.0.0.bb
+++ b/recipes/zaurus-utils/nandlogical_1.0.0.bb
@@ -1,6 +1,5 @@
DESCRIPTION = "Nandlogical for Sharp mtd1"
LICENSE = "GPL"
-COMPATIBLE_MACHINE = "(poodle|c7x0|akita|spitz|tosa)"
PR = "r4"
SRC_URI = "file://nandlogical.c"
@@ -10,8 +9,9 @@ S = "${WORKDIR}"
do_compile () {
${CC} ${CFLAGS} ${LDFLAGS} nandlogical.c -o nandlogical
}
-
do_install () {
install -d ${D}${bindir}/
install -m 0755 nandlogical ${D}${bindir}/
}
+
+COMPATIBLE_MACHINE = "(poodle|c7x0|akita|spitz|tosa)"
diff --git a/recipes/zaurus-utils/zaurus-installer.bb b/recipes/zaurus-utils/zaurus-installer.bb
index d4fcddef3b..bc345c2e56 100644
--- a/recipes/zaurus-utils/zaurus-installer.bb
+++ b/recipes/zaurus-utils/zaurus-installer.bb
@@ -1,39 +1,34 @@
DESCRIPTION = "Installkit for kexecboot-kernel"
+LICENSE = "zaurus-installer"
DEPENDS = "${@base_conditional('MACHINE', 'collie', 'linux-kexecboot', 'zaurus-updater linux-kexecboot', d)}"
DEPENDS += "${@base_conditional('MACHINE', 'spitz', 'zaurus-legacy-tar', '', d)}"
-LICENSE = "zaurus-installer"
PR = "r4"
-PACKAGES = ""
-PACKAGE_ARCH = "${MACHINE_ARCH}"
-COMPATIBLE_MACHINE = '(collie|poodle|c7x0|spitz|akita|tosa)'
-
do_compile() {
}
-do_deploy() {
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+PACKAGES = ""
+
+# package_stagefile_shell need to run before populate_sysroot for packaged-staging
+addtask deploy before do_populate_sysroot after do_compile
+COMPATIBLE_MACHINE = "(collie|poodle|c7x0|spitz|akita|tosa)"
+
+do_deploy() {
cd ${DEPLOY_DIR_IMAGE}
rm -rf ${DEPLOY_DIR_IMAGE}/installkit-${MACHINE}/
mkdir installkit-${MACHINE}/
-
[ -f "${KERNEL_IMAGETYPE}-kexecboot-${MACHINE}.bin" ] && cp ${KERNEL_IMAGETYPE}-kexecboot-${MACHINE}.bin installkit-${MACHINE}/${KERNEL_IMAGETYPE}
-
if [ ! "${MACHINE}" = "collie" ]; then
cp updater.sh installkit-${MACHINE}/updater.sh
fi
-
if [ "${MACHINE}" = "spitz" ]; then
cp ${DEPLOY_DIR_IMAGE}/gnu-tar installkit-${MACHINE}/gnu-tar
fi
-
tar czf ${DEPLOY_DIR_IMAGE}/installkit-${MACHINE}.tar.gz installkit-${MACHINE}/
md5sum ${DEPLOY_DIR_IMAGE}/installkit-${MACHINE}.tar.gz > ${DEPLOY_DIR_IMAGE}/installkit-${MACHINE}.tar.gz.md5
rm -rf ${DEPLOY_DIR_IMAGE}/installkit-${MACHINE}/
-
package_stagefile_shell ${DEPLOY_DIR_IMAGE}/installkit-${MACHINE}.tar.gz
package_stagefile_shell ${DEPLOY_DIR_IMAGE}/installkit-${MACHINE}.tar.gz.md5
}
-
-# package_stagefile_shell need to run before populate_sysroot for packaged-staging
-addtask deploy before do_populate_sysroot after do_compile
diff --git a/recipes/zaurus-utils/zaurus-legacy-tar.bb b/recipes/zaurus-utils/zaurus-legacy-tar.bb
index 00d6cce2f0..87d4f98b68 100644
--- a/recipes/zaurus-utils/zaurus-legacy-tar.bb
+++ b/recipes/zaurus-utils/zaurus-legacy-tar.bb
@@ -2,10 +2,6 @@ DESCRIPTION = "Legacy GNU-tar to unpack hd images on install for Zaurus spitz"
LICENSE = "GPL"
PR = "r0"
-PACKAGE_ARCH = "${MACHINE_ARCH}"
-PACKAGES = ""
-COMPATIBLE_MACHINE = "spitz"
-
SRC_URI = "file://gnu-tar.gz"
S = "${WORKDIR}"
@@ -13,11 +9,16 @@ S = "${WORKDIR}"
do_compile() {
}
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+PACKAGES = ""
+
+# package_stagefile_shell needs to run before populate_staging for packaged-staging
+addtask deploy before do_populate_sysroot after do_compile
+
+COMPATIBLE_MACHINE = "spitz"
+
do_deploy() {
install -d ${DEPLOY_DIR_IMAGE}
install -m 0755 gnu-tar ${DEPLOY_DIR_IMAGE}/gnu-tar
package_stagefile_shell ${DEPLOY_DIR_IMAGE}/gnu-tar
}
-
-# package_stagefile_shell needs to run before populate_staging for packaged-staging
-addtask deploy before do_populate_sysroot after do_compile
diff --git a/recipes/zaurus-utils/zaurus-updater.bb b/recipes/zaurus-utils/zaurus-updater.bb
index ee41182cdb..b13e2a36ca 100644
--- a/recipes/zaurus-utils/zaurus-updater.bb
+++ b/recipes/zaurus-utils/zaurus-updater.bb
@@ -1,17 +1,8 @@
DESCRIPTION = "Encrypted shellscript for the Zaurus ROM update"
-DEPENDS = "encdec-updater-native"
LICENSE = "zaurus-updater"
+DEPENDS = "encdec-updater-native"
PR = "r25"
-# even though the package is not machine-specific
-# we have to force it there to allow multimachine builds
-# because DEPLOY_DIR_IMAGE = "${DEPLOY_DIR}/images/${MACHINE}"
-# and without this only the first machine built get the right staging ipk
-PACKAGE_ARCH = "${MACHINE_ARCH}"
-
-PACKAGES = ""
-COMPATIBLE_MACHINE = '(poodle|c7x0|spitz|akita|tosa)'
-
SRC_URI = "file://updater.sh"
S = "${WORKDIR}"
@@ -19,17 +10,22 @@ S = "${WORKDIR}"
do_configure() {
sed -i "s/ZAURUS_UPDATER_VERSION/${PR}/" "${S}/updater.sh"
}
-
do_compile() {
encdec-updater -e updater.sh
}
+# even though the package is not machine-specific
+# we have to force it there to allow multimachine builds
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+PACKAGES = ""
+
+# package_stagefile_shell need to run before populate_sysroot for packaged-staging
+addtask deploy before do_populate_sysroot after do_compile
+
+COMPATIBLE_MACHINE = "(poodle|c7x0|spitz|akita|tosa)"
+
do_deploy() {
install -d ${DEPLOY_DIR_IMAGE}
install -m 0755 updater.sh ${DEPLOY_DIR_IMAGE}/updater.sh
package_stagefile_shell ${DEPLOY_DIR_IMAGE}/updater.sh
}
-
-# package_stagefile_shell need to run before populate_sysroot for packaged-staging
-addtask deploy before do_populate_sysroot after do_compile
-