aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorTom Rini <tom_rini@mentor.com>2010-08-20 15:59:09 -0700
committerTom Rini <tom_rini@mentor.com>2010-08-20 15:59:09 -0700
commit4bbc0df43bc27e51aa5f4410693389003aec9ae1 (patch)
treecc70fd041711162cfc162db20a93f5d73a5bb044 /recipes
parentf554f67dfddb4093b9084c75f7910430d2f19b36 (diff)
downloadopenembedded-4bbc0df43bc27e51aa5f4410693389003aec9ae1.tar.gz
udev 141/151/154: Move rm'ing /tmp/uname, etc, to udev-cache
Otherwise we'll remove these files before udev-cache is run. Signed-off-by: Tom Rini <tom_rini@mentor.com>
Diffstat (limited to 'recipes')
-rw-r--r--recipes/udev/udev-141/cache20
-rw-r--r--recipes/udev/udev-141/init5
-rw-r--r--recipes/udev/udev-151/cache20
-rw-r--r--recipes/udev/udev-151/init5
-rw-r--r--recipes/udev/udev-154/cache20
-rw-r--r--recipes/udev/udev-154/init5
-rw-r--r--recipes/udev/udev_141.bb2
-rw-r--r--recipes/udev/udev_151.bb2
-rw-r--r--recipes/udev/udev_154.bb2
9 files changed, 39 insertions, 42 deletions
diff --git a/recipes/udev/udev-141/cache b/recipes/udev/udev-141/cache
index 4db1466817..c0d400b448 100644
--- a/recipes/udev/udev-141/cache
+++ b/recipes/udev/udev-141/cache
@@ -6,13 +6,17 @@ export TZ=/etc/localtime
echo "Caching udev devnodes"
- if [ "$DEVCACHE" != "" ]; then
- echo -n "Populating dev cache"
- (cd /; tar cf $DEVCACHE dev)
- mv /tmp/uname /etc/udev/saved.uname
- mv /tmp/cmdline /etc/udev/saved.cmdline
- mv /tmp/atags /etc/udev/saved.atags
- echo
- fi
+if [ "$DEVCACHE" != "" ]; then
+ echo -n "Populating dev cache"
+ (cd /; tar cf $DEVCACHE dev)
+ mv /tmp/uname /etc/udev/saved.uname
+ mv /tmp/cmdline /etc/udev/saved.cmdline
+ mv /tmp/atags /etc/udev/saved.atags
+ echo
+else
+ rm -f /tmp/uname
+ rm -f /tmp/cmdline
+ rm -f /tmp/atags
+fi
exit 0
diff --git a/recipes/udev/udev-141/init b/recipes/udev/udev-141/init
index efd9c23a0e..9f7b2c4a7f 100644
--- a/recipes/udev/udev-141/init
+++ b/recipes/udev/udev-141/init
@@ -60,11 +60,6 @@ kill_udevd > "/dev/null" 2>&1
if [ "$not_first_boot" != "" ];then
/sbin/udevadm trigger --subsystem-nomatch=tty --subsystem-nomatch=mem --subsystem-nomatch=vc --subsystem-nomatch=vtconsole --subsystem-nomatch=misc --subsystem-nomatch=dcon --subsystem-nomatch=pci_bus --subsystem-nomatch=graphics --subsystem-nomatch=backlight --subsystem-nomatch=video4linux --subsystem-nomatch=platform
(/sbin/udevadm settle --timeout=3; /sbin/udevadm control --env STARTUP=)&
- if [ "$DEVCACHE" != "" ]; then
- rm -f /tmp/uname
- rm -f /tmp/cmdline
- rm -f /tmp/atags
- fi
else
/sbin/udevadm trigger
/sbin/udevadm settle
diff --git a/recipes/udev/udev-151/cache b/recipes/udev/udev-151/cache
index 4db1466817..c0d400b448 100644
--- a/recipes/udev/udev-151/cache
+++ b/recipes/udev/udev-151/cache
@@ -6,13 +6,17 @@ export TZ=/etc/localtime
echo "Caching udev devnodes"
- if [ "$DEVCACHE" != "" ]; then
- echo -n "Populating dev cache"
- (cd /; tar cf $DEVCACHE dev)
- mv /tmp/uname /etc/udev/saved.uname
- mv /tmp/cmdline /etc/udev/saved.cmdline
- mv /tmp/atags /etc/udev/saved.atags
- echo
- fi
+if [ "$DEVCACHE" != "" ]; then
+ echo -n "Populating dev cache"
+ (cd /; tar cf $DEVCACHE dev)
+ mv /tmp/uname /etc/udev/saved.uname
+ mv /tmp/cmdline /etc/udev/saved.cmdline
+ mv /tmp/atags /etc/udev/saved.atags
+ echo
+else
+ rm -f /tmp/uname
+ rm -f /tmp/cmdline
+ rm -f /tmp/atags
+fi
exit 0
diff --git a/recipes/udev/udev-151/init b/recipes/udev/udev-151/init
index c282372b4e..4dcb241a28 100644
--- a/recipes/udev/udev-151/init
+++ b/recipes/udev/udev-151/init
@@ -65,11 +65,6 @@ kill_udevd > "/dev/null" 2>&1
if [ "$not_first_boot" != "" ];then
/sbin/udevadm trigger --subsystem-nomatch=tty --subsystem-nomatch=mem --subsystem-nomatch=vc --subsystem-nomatch=vtconsole --subsystem-nomatch=misc --subsystem-nomatch=dcon --subsystem-nomatch=pci_bus --subsystem-nomatch=graphics --subsystem-nomatch=backlight --subsystem-nomatch=video4linux --subsystem-nomatch=platform
(/sbin/udevadm settle --timeout=8; /sbin/udevadm control --env STARTUP=)&
- if [ "$DEVCACHE" != "" ]; then
- rm -f /tmp/uname
- rm -f /tmp/cmdline
- rm -f /tmp/atags
- fi
else
/sbin/udevadm trigger
/sbin/udevadm settle
diff --git a/recipes/udev/udev-154/cache b/recipes/udev/udev-154/cache
index 4db1466817..c0d400b448 100644
--- a/recipes/udev/udev-154/cache
+++ b/recipes/udev/udev-154/cache
@@ -6,13 +6,17 @@ export TZ=/etc/localtime
echo "Caching udev devnodes"
- if [ "$DEVCACHE" != "" ]; then
- echo -n "Populating dev cache"
- (cd /; tar cf $DEVCACHE dev)
- mv /tmp/uname /etc/udev/saved.uname
- mv /tmp/cmdline /etc/udev/saved.cmdline
- mv /tmp/atags /etc/udev/saved.atags
- echo
- fi
+if [ "$DEVCACHE" != "" ]; then
+ echo -n "Populating dev cache"
+ (cd /; tar cf $DEVCACHE dev)
+ mv /tmp/uname /etc/udev/saved.uname
+ mv /tmp/cmdline /etc/udev/saved.cmdline
+ mv /tmp/atags /etc/udev/saved.atags
+ echo
+else
+ rm -f /tmp/uname
+ rm -f /tmp/cmdline
+ rm -f /tmp/atags
+fi
exit 0
diff --git a/recipes/udev/udev-154/init b/recipes/udev/udev-154/init
index fea2ca66ee..e9ecf970b3 100644
--- a/recipes/udev/udev-154/init
+++ b/recipes/udev/udev-154/init
@@ -65,11 +65,6 @@ kill_udevd > "/dev/null" 2>&1
if [ "$not_first_boot" != "" ];then
/sbin/udevadm trigger --subsystem-nomatch=tty --subsystem-nomatch=mem --subsystem-nomatch=vc --subsystem-nomatch=vtconsole --subsystem-nomatch=misc --subsystem-nomatch=dcon --subsystem-nomatch=pci_bus --subsystem-nomatch=graphics --subsystem-nomatch=backlight --subsystem-nomatch=video4linux --subsystem-nomatch=platform
(/sbin/udevadm settle --timeout=3; /sbin/udevadm control --env STARTUP=)&
- if [ "$DEVCACHE" != "" ]; then
- rm -f /tmp/uname
- rm -f /tmp/cmdline
- rm -f /tmp/atags
- fi
else
/sbin/udevadm trigger
/sbin/udevadm settle
diff --git a/recipes/udev/udev_141.bb b/recipes/udev/udev_141.bb
index 3ef9f7d660..798590c3b7 100644
--- a/recipes/udev/udev_141.bb
+++ b/recipes/udev/udev_141.bb
@@ -7,7 +7,7 @@ DEFAULT_PREFERENCE = "-1"
require udev.inc
-PR = "${INC_PR}.0"
+PR = "${INC_PR}.1"
SRC_URI += "file://mount.blacklist \
file://run.rules \
diff --git a/recipes/udev/udev_151.bb b/recipes/udev/udev_151.bb
index 8760946671..038fec7055 100644
--- a/recipes/udev/udev_151.bb
+++ b/recipes/udev/udev_151.bb
@@ -3,7 +3,7 @@ DESCRIPTION = "udev is a daemon which dynamically creates and removes device nod
the hotplug package and requires a kernel not older than 2.6.12."
LICENSE = "GPLv2+"
-PR = "r14"
+PR = "r15"
# Untested
DEFAULT_PREFERENCE = "-1"
diff --git a/recipes/udev/udev_154.bb b/recipes/udev/udev_154.bb
index a02a369d9f..6698566583 100644
--- a/recipes/udev/udev_154.bb
+++ b/recipes/udev/udev_154.bb
@@ -3,7 +3,7 @@ DESCRIPTION = "udev is a daemon which dynamically creates and removes device nod
the hotplug package and requires a kernel not older than 2.6.12."
LICENSE = "GPLv2+"
-PR = "r1"
+PR = "r2"
# Untested
DEFAULT_PREFERENCE = "-1"