aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorRolf Leggewie <oe-devel@rolf.leggewie.biz>2009-05-23 02:09:40 +0200
committerRolf Leggewie <oe-devel@rolf.leggewie.biz>2009-06-11 15:27:26 +0200
commit53dadd8f62f7ef19d11f33b860006cd02248fbc0 (patch)
treed009c46fdf884648b843c748f685ef6bd4315849 /recipes
parente2918017ec1e8e750263345c5bad359d3e46416a (diff)
downloadopenembedded-53dadd8f62f7ef19d11f33b860006cd02248fbc0.tar.gz
psplash: fix runtime dependencies. (Partly Closes: #2412)
* virtual/psplash should be virtual-psplash to not confuse dpkg * make corresponding changes in initramfs-module-psplash_1.0.bb and exquisite_svn.bb as well
Diffstat (limited to 'recipes')
-rw-r--r--recipes/e17/exquisite_svn.bb4
-rw-r--r--recipes/initrdscripts/initramfs-module-psplash_1.0.bb4
-rw-r--r--recipes/psplash/psplash-zap_1.0.bb3
-rw-r--r--recipes/psplash/psplash.inc4
4 files changed, 7 insertions, 8 deletions
diff --git a/recipes/e17/exquisite_svn.bb b/recipes/e17/exquisite_svn.bb
index ac4c6b57d4..b6b6441107 100644
--- a/recipes/e17/exquisite_svn.bb
+++ b/recipes/e17/exquisite_svn.bb
@@ -2,10 +2,10 @@ DESCRIPTION = "A psplash replacement for display"
LICENSE = "MIT BSD"
DEPENDS = "eet evas ecore embryo edje"
PV = "0.0.1+svnr${SRCREV}"
-PR = "r8"
+PR = "r9"
RDEPENDS = "initscripts"
RRECOMMENDS_${PN} = "exquisite-themes"
-RCONFLICTS_${PN} = "psplash virtual/psplash"
+RCONFLICTS_${PN} = "psplash virtual-psplash"
SRCNAME = "exquisite"
diff --git a/recipes/initrdscripts/initramfs-module-psplash_1.0.bb b/recipes/initrdscripts/initramfs-module-psplash_1.0.bb
index 8d61257220..08d1cc69c4 100644
--- a/recipes/initrdscripts/initramfs-module-psplash_1.0.bb
+++ b/recipes/initrdscripts/initramfs-module-psplash_1.0.bb
@@ -1,6 +1,6 @@
SRC_URI = "file://00-psplash.sh file://99-psplash.sh"
-PR = "r4"
-RDEPENDS = "initramfs-uniboot virtual/psplash"
+PR = "r5"
+RDEPENDS = "initramfs-uniboot virtual-psplash"
DESCRIPTION = "An initramfs module to enable psplash."
do_install() {
diff --git a/recipes/psplash/psplash-zap_1.0.bb b/recipes/psplash/psplash-zap_1.0.bb
index d6b281094e..0268b2015a 100644
--- a/recipes/psplash/psplash-zap_1.0.bb
+++ b/recipes/psplash/psplash-zap_1.0.bb
@@ -1,6 +1,5 @@
-
SRC_URI = "file://zzapsplash-init"
-PR = "r1"
+PR = "r2"
do_install_prepend() {
install -d "${D}${sysconfdir}/init.d/"
diff --git a/recipes/psplash/psplash.inc b/recipes/psplash/psplash.inc
index 3477229d82..515c830ce1 100644
--- a/recipes/psplash/psplash.inc
+++ b/recipes/psplash/psplash.inc
@@ -4,11 +4,11 @@ SECTION = "base"
LICENSE = "GPL"
RDEPENDS = "initscripts"
PROVIDES = "virtual/psplash"
-RPROVIDES_${PN} = "virtual/psplash"
+RPROVIDES_${PN} = "virtual-psplash"
RCONFLICTS_${PN} = "exquisite"
PV = "0.0+svnr${SRCREV}"
-PR = "r22"
+PR = "r23"
# You can create your own pslash-hand-img.h by doing
# ./make-image-header.sh <file>.png HAND