aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2010-08-04 22:21:09 +0200
committerFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2010-08-04 22:21:09 +0200
commit5edfb2709108ff53dc6ee36df0c43724b3074af0 (patch)
tree20cb189644edb8de4a3ffa76ed6e721a5e19e4f7 /recipes
parent82ead3bfec1b30a8ed04748cc8edf0fb2c0e512c (diff)
downloadopenembedded-5edfb2709108ff53dc6ee36df0c43724b3074af0.tar.gz
divmod.inc: added INC_PR
and used it in the recipes Signed-off-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes')
-rw-r--r--recipes/python/divmod.inc2
-rw-r--r--recipes/python/python-divmodaxiom_0.5.30.bb2
-rw-r--r--recipes/python/python-nevow_0.9.32.bb2
3 files changed, 6 insertions, 0 deletions
diff --git a/recipes/python/divmod.inc b/recipes/python/divmod.inc
index 20be1b2e38..37b99c1967 100644
--- a/recipes/python/divmod.inc
+++ b/recipes/python/divmod.inc
@@ -1,5 +1,7 @@
SRC_URI = "http://divmod.org/trac/attachment/wiki/SoftwareReleases/${REALPN}-${PV}.tar.gz?format=raw"
+INC_PR = "r0"
+
DEPENDS += "python-twisted-native"
do_unpack2() {
diff --git a/recipes/python/python-divmodaxiom_0.5.30.bb b/recipes/python/python-divmodaxiom_0.5.30.bb
index bee0cab475..fb7990b685 100644
--- a/recipes/python/python-divmodaxiom_0.5.30.bb
+++ b/recipes/python/python-divmodaxiom_0.5.30.bb
@@ -7,5 +7,7 @@ DEPENDS += "python-divmodepsilon-native"
require divmod.inc
+PR = "${INC_PR}.1"
+
SRC_URI[md5sum] = "8f0b3a27770e487ad08f4fafdccc4495"
SRC_URI[sha256sum] = "4a4217e70e01e11d357c2c2c23bc72d244a78fa40a401cca48cd5f0a619c7060"
diff --git a/recipes/python/python-nevow_0.9.32.bb b/recipes/python/python-nevow_0.9.32.bb
index b360f3156c..c36c60ee10 100644
--- a/recipes/python/python-nevow_0.9.32.bb
+++ b/recipes/python/python-nevow_0.9.32.bb
@@ -5,6 +5,8 @@ REALPN = "Nevow"
require divmod.inc
+PR = "${INC_PR}.1"
+
FILES_${PN} += "${datadir}"
DEPENDS += "python-twisted-native"