aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorTom Rini <tom_rini@mentor.com>2010-08-21 10:37:46 -0700
committerTom Rini <tom_rini@mentor.com>2010-08-21 10:37:46 -0700
commit86b84f8efe8de2f0f27286b0121e277789715e37 (patch)
treeaa414f6e031156da94d4510b4f062e2f7b16e250 /recipes
parentd994b813dea7773febc080bda7d8a50a7d714199 (diff)
downloadopenembedded-86b84f8efe8de2f0f27286b0121e277789715e37.tar.gz
flex: Move BBCLASSEXTEND to the .inc, disable PSTAGING on 2.5.35
Inspired by a patch from Jason Kridner <jkridner@beagleboard.org> Signed-off-by: Tom Rini <tom_rini@mentor.com>
Diffstat (limited to 'recipes')
-rw-r--r--recipes/flex/flex.inc2
-rw-r--r--recipes/flex/flex_2.5.31.bb3
-rw-r--r--recipes/flex/flex_2.5.35.bb10
3 files changed, 8 insertions, 7 deletions
diff --git a/recipes/flex/flex.inc b/recipes/flex/flex.inc
index 49b26e8b61..3b0a5d5b00 100644
--- a/recipes/flex/flex.inc
+++ b/recipes/flex/flex.inc
@@ -6,6 +6,8 @@ DEPENDS = "gettext"
INC_PR = "r5"
+BBCLASSEXTEND = "native"
+
S = "${WORKDIR}/flex-${PV}"
inherit autotools gettext
diff --git a/recipes/flex/flex_2.5.31.bb b/recipes/flex/flex_2.5.31.bb
index 87a0b8d801..9ee9e1351a 100644
--- a/recipes/flex/flex_2.5.31.bb
+++ b/recipes/flex/flex_2.5.31.bb
@@ -6,8 +6,5 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/flex/flex-${PV}.tar.bz2 \
file://fix-gen.patch \
file://include.patch"
-
-BBCLASSEXTEND = "native"
-
SRC_URI[md5sum] = "363dcc4afc917dc51306eb9d3de0152f"
SRC_URI[sha256sum] = "701353279a17655d78e3b3678ad78d0375f5bf45877ad8b3507d589c42427f26"
diff --git a/recipes/flex/flex_2.5.35.bb b/recipes/flex/flex_2.5.35.bb
index 82e2417758..af9f5e5927 100644
--- a/recipes/flex/flex_2.5.35.bb
+++ b/recipes/flex/flex_2.5.35.bb
@@ -1,6 +1,6 @@
require flex.inc
-PR = "${INC_PR}.0"
+PR = "${INC_PR}.1"
SRC_URI = "${SOURCEFORGE_MIRROR}/flex/flex-${PV}.tar.bz2;name=flex \
"
@@ -8,11 +8,13 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/flex/flex-${PV}.tar.bz2;name=flex \
SRC_URI[flex.md5sum] = "10714e50cea54dc7a227e3eddcd44d57"
SRC_URI[flex.sha256sum] = "0becbd4b2b36b99c67f8c22ab98f7f80c9860aec70f0350a0018f29a88704e7b"
-NATIVE_INSTALL_WORKS = "1"
-BBCLASSEXTEND = "native"
-
do_install_append () {
ln -sf flex ${D}${bindir}/lex
ln -sf flex ${D}${bindir}/lex++
}
+NATIVE_INSTALL_WORKS = "1"
+
+# flex-2.5.35 adds a hard-coded path that causes failures when using packaged
+# staging
+PSTAGING_DISABLED_virtclass-native = "1"