aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2010-06-09 19:04:02 -0700
committerKhem Raj <raj.khem@gmail.com>2010-06-09 19:04:02 -0700
commit8b17bc55a9191ff36a0788aac87da522286714d8 (patch)
tree55c2429042fa5787ecb1ce954afa619f5ef4fdb0 /recipes
parentbfe9198ddabf08f84c744dcbf82d4a52c295508d (diff)
downloadopenembedded-8b17bc55a9191ff36a0788aac87da522286714d8.tar.gz
gdb_7.1: Add patch to shut a warning when we boot into shell.
* [tcsetpgrp failed in terminal_inferior: Inappropriate ioctl for * device] this warning is pretty annoying when debugging on a shell which does not have a proper console device allocated and no job control. Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes')
-rw-r--r--recipes/gdb/gdb-7.1/gdb-tcsetpgrp.patch43
-rw-r--r--recipes/gdb/gdb_7.1.bb7
2 files changed, 48 insertions, 2 deletions
diff --git a/recipes/gdb/gdb-7.1/gdb-tcsetpgrp.patch b/recipes/gdb/gdb-7.1/gdb-tcsetpgrp.patch
new file mode 100644
index 0000000000..d642721127
--- /dev/null
+++ b/recipes/gdb/gdb-7.1/gdb-tcsetpgrp.patch
@@ -0,0 +1,43 @@
+Stuart Hughes, stuarth@freescale.com 8th April 05
+
+Extracted from:
+
+From: Davin Milun (milun@cs.buffalo.edu)
+Subject: Re: xxgdb for Solaris
+View: Complete Thread (4 articles)
+Original Format
+Newsgroups: comp.unix.solaris
+Date: 1995/05/05
+
+Geraldo Veiga <ggv@research.att.com> wrote:
+>Now, how do I avoid those
+>
+>[tcsetpgrp failed in terminal_inferior: Inappropriate ioctl for device]
+>
+>messages at every step the program takes under mxgdb (and xxgdb)?. I am
+>running GDB4.13 under Solaris 2.4.
+
+You need to patch inflow.c.
+
+
+ diff --exclude CVS -uNr gdb-6.0/gdb/inflow.c gdb-6.0.modified/gdb/inflow.c
+Index: gdb-7.1/gdb/inflow.c
+===================================================================
+--- gdb-7.1.orig/gdb/inflow.c 2010-01-21 06:26:12.000000000 -0800
++++ gdb-7.1/gdb/inflow.c 2010-06-09 13:59:33.761358724 -0700
+@@ -308,13 +308,13 @@ terminal_inferior (void)
+ {
+ #ifdef HAVE_TERMIOS
+ result = tcsetpgrp (0, tinfo->process_group);
+- if (!inf->attach_flag)
++ if (!inf->attach_flag && errno != ENOTTY)
+ OOPSY ("tcsetpgrp");
+ #endif
+
+ #ifdef HAVE_SGTTY
+ result = ioctl (0, TIOCSPGRP, &tinfo->process_group);
+- if (!inf->attach_flag)
++ if (!inf->attach_flag && errno != ENOTTY)
+ OOPSY ("TIOCSPGRP");
+ #endif
+ }
diff --git a/recipes/gdb/gdb_7.1.bb b/recipes/gdb/gdb_7.1.bb
index 5489c80b61..a73eb72a7d 100644
--- a/recipes/gdb/gdb_7.1.bb
+++ b/recipes/gdb/gdb_7.1.bb
@@ -1,8 +1,11 @@
require gdb.inc
LICENSE = "GPLv3"
-SRC_URI += "\
- file://gdb-6.8-fix-compile-karmic.patch"
+PR = "r1"
+
+SRC_URI += "file://gdb-6.8-fix-compile-karmic.patch \
+ file://gdb-tcsetpgrp.patch \
+ "
# Work-around problems while creating libbfd.a
EXTRA_OECONF += "--enable-static"