aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2009-04-22 21:57:19 +0200
committerFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2009-04-22 21:57:19 +0200
commit8fc533bcb9d24c8951a86a4af4c52c0a229c242d (patch)
tree09305a965e35a490761c8db1fc310fd988d2c79f /recipes
parent934ef803ea8eb626888e88a9aa6d900f2edb3e7c (diff)
downloadopenembedded-8fc533bcb9d24c8951a86a4af4c52c0a229c242d.tar.gz
flickcurl: created recipe
flickcurl is a C interface to retrieve flickr data
Diffstat (limited to 'recipes')
-rw-r--r--recipes/flickcurl/flickcurl_1.9.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes/flickcurl/flickcurl_1.9.bb b/recipes/flickcurl/flickcurl_1.9.bb
new file mode 100644
index 0000000000..ea1cdb1974
--- /dev/null
+++ b/recipes/flickcurl/flickcurl_1.9.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "flickcurl is a C libarry for the Flick API"
+SECTION = "libs"
+HOMEPAGE = "http://librdf.org/flickcurl/"
+LICENSE = "LGPL 2.1/GPL 2/Apache 2.0"
+PR = "r0"
+SRC_URI = "http://download.dajobe.org/${PN}/${PN}-${PV}.tar.gz"
+
+DEPENDS = "curl libxml2"
+
+EXTRA_OECONF = "ac_cv_func_vsnprintf=no"
+
+inherit autotools
+
+do_stage() {
+ install -d ${STAGING_INCDIR}
+ install -m 0644 ${D}/usr/include/*.h ${STAGING_INCDIR}
+ oe_libinstall -so libflickcurl ${STAGING_LIBDIR}
+}
+
+LEAD_SONAME = "libflickcurl.so.1"
+
+FILES_${PN} += "${libdir}/libflickcurl.so.*"