aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2010-10-27 19:08:54 -0700
committerKhem Raj <raj.khem@gmail.com>2010-10-27 19:10:16 -0700
commit9ccba6c9c0212abc2e9414c09932d6daab29fd8c (patch)
tree648043d4007b74635805442f660b786739112aa7 /recipes
parent107cb75421dbff51be0f1b5ac433d6d872926bbf (diff)
downloadopenembedded-9ccba6c9c0212abc2e9414c09932d6daab29fd8c.tar.gz
scim_1.4.9.bb: Fix infinite loop when compiling po/ subdir
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes')
-rw-r--r--recipes/scim/scim_1.4.9.bb15
1 files changed, 11 insertions, 4 deletions
diff --git a/recipes/scim/scim_1.4.9.bb b/recipes/scim/scim_1.4.9.bb
index 153a1aa20f..21110b2a45 100644
--- a/recipes/scim/scim_1.4.9.bb
+++ b/recipes/scim/scim_1.4.9.bb
@@ -1,9 +1,9 @@
DESCRIPTION = "Smart Common Input Method (SCIM) platform"
HOMEPAGE = "http://www.scim-im.org"
SECTION = "libs/inputmethod"
-LICENSE = "LGPL"
-DEPENDS = "gtk+"
-PR = "r1"
+LICENSE = "LGPLv2.1+"
+DEPENDS = "gtk+ cairo"
+PR = "r2"
SRC_URI = "${SOURCEFORGE_MIRROR}/${PN}/${PN}-${PV}.tar.gz \
file://gcc-4.4-const-char.dpatch;apply=yes \
@@ -19,7 +19,6 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/${PN}/${PN}-${PV}.tar.gz \
"
inherit autotools pkgconfig
-
EXTRA_OECONF = " --without-doxygen "
LEAD_SONAME = "libscim-1.0.so"
@@ -35,7 +34,15 @@ do_configure_append () {
sed -i "s/${SEDL}.*/${SEDR}/" Makefile.in.in
sed -i "s/${SEDL}.*/${SEDR}/" Makefile.in
sed -i "s/${SEDL}.*/${SEDR}/" Makefile
+ # the below sed is done to prevent an infinite loop when make enters po/
+ # since intltoolize is not a knobbable operation in autotools do_configure
+ # good old sed comes to our rescue
+ # this is equivalent of a patch to Makefile.in.in which would be
+ #- $(SHELL) ./config.status
+ #+ $(SHELL) ./config.status
+ #+ touch stamp-it
+ sed -i 's/^[ \t]*\$(SHELL).*$/\t\$(SHELL) .\/config.status\n\ttouch stamp-it/g' Makefile.in.in
# Fix unset @INTLTOOL_LIBDIR@
# Only needed for a check to see if charmap.alias is present,
# not really needed, so we fail that test by having it look