aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorChris Larson <chris_larson@mentor.com>2010-10-16 23:14:20 -0700
committerChris Larson <chris_larson@mentor.com>2010-10-20 10:01:38 -0700
commitac0b7d1cf703fed7930e2adf6309ded86a887d1b (patch)
treeb69c053f7267d62524ad390335edbe0f80f1e94d /recipes
parent1c24a488b8949ff4c2f073db2c2098bdbdd13508 (diff)
downloadopenembedded-ac0b7d1cf703fed7930e2adf6309ded86a887d1b.tar.gz
coreutils-6.0: apply patch for USE_STATVFS
Fixes compile error on platforms where statvfs does not have an f_type member (e.g. OSX). See http://www.mail-archive.com/bug-coreutils@gnu.org/msg06552.html for details. Signed-off-by: Chris Larson <chris_larson@mentor.com>
Diffstat (limited to 'recipes')
-rw-r--r--recipes/coreutils/coreutils-6.0.inc1
-rw-r--r--recipes/coreutils/coreutils-6.0/USE_STATVFS.patch26
-rw-r--r--recipes/coreutils/coreutils_6.0.bb2
3 files changed, 28 insertions, 1 deletions
diff --git a/recipes/coreutils/coreutils-6.0.inc b/recipes/coreutils/coreutils-6.0.inc
index fb5abbcaf5..05a2ef1549 100644
--- a/recipes/coreutils/coreutils-6.0.inc
+++ b/recipes/coreutils/coreutils-6.0.inc
@@ -6,4 +6,5 @@ SRC_URI = "\
ftp://alpha.gnu.org/gnu/coreutils/coreutils-${PV}.tar.bz2 \
file://futimens.patch \
file://coreutils-install-use-STRIP.patch \
+ file://USE_STATVFS.patch \
"
diff --git a/recipes/coreutils/coreutils-6.0/USE_STATVFS.patch b/recipes/coreutils/coreutils-6.0/USE_STATVFS.patch
new file mode 100644
index 0000000000..b96ad99caa
--- /dev/null
+++ b/recipes/coreutils/coreutils-6.0/USE_STATVFS.patch
@@ -0,0 +1,26 @@
+From 5ce0b45a43fc2de8862a439b6e6281fdd55e27ed Mon Sep 17 00:00:00 2001
+From: Paul Eggert <eggert@cs.ucla.edu>
+Date: Tue, 15 Aug 2006 23:23:28 +0000
+Subject: [PATCH] (USE_STATVFS): Define to 0 if f_type is needed, but
+ statvfs.f_type not present.
+
+---
+ src/stat.c | 3 ++-
+ 1 files changed, 2 insertions(+), 1 deletions(-)
+
+diff --git a/src/stat.c b/src/stat.c
+index 4c6047c..481096d 100644
+--- a/src/stat.c
++++ b/src/stat.c
+@@ -20,7 +20,8 @@
+ #include <config.h>
+
+ #if (STAT_STATVFS \
+- && (HAVE_STRUCT_STATVFS_F_BASETYPE || ! HAVE_STRUCT_STATFS_F_FSTYPENAME))
++ && (HAVE_STRUCT_STATVFS_F_BASETYPE \
++ || (! HAVE_STRUCT_STATFS_F_FSTYPENAME && HAVE_STRUCT_STATVFS_F_TYPE)))
+ # define USE_STATVFS 1
+ #else
+ # define USE_STATVFS 0
+--
+1.7.2.3
diff --git a/recipes/coreutils/coreutils_6.0.bb b/recipes/coreutils/coreutils_6.0.bb
index 32f0f1f702..afa2cd7868 100644
--- a/recipes/coreutils/coreutils_6.0.bb
+++ b/recipes/coreutils/coreutils_6.0.bb
@@ -1,7 +1,7 @@
require coreutils-${PV}.inc
require coreutils-target.inc
-PR = "r3"
+PR = "r4"
SRC_URI += "\
file://man.patch \