aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorAndrea Adami <andrea.adami@gmail.com>2010-08-22 19:29:38 +0200
committerAndrea Adami <andrea.adami@gmail.com>2010-08-22 19:29:38 +0200
commitf50a28e4e3b2f310d11e914c8a16cb86ee9f97d6 (patch)
tree88d1e7387c3a4915c0aa0ddb83bd985b3af614c4 /recipes
parent41a480ab2c55179f2eead9bb2929eca9df24d4ca (diff)
downloadopenembedded-f50a28e4e3b2f310d11e914c8a16cb86ee9f97d6.tar.gz
zaurus-installer: fix it for packaged-staging. Bump PR.
Diffstat (limited to 'recipes')
-rw-r--r--recipes/zaurus-utils/zaurus-installer.bb8
1 files changed, 6 insertions, 2 deletions
diff --git a/recipes/zaurus-utils/zaurus-installer.bb b/recipes/zaurus-utils/zaurus-installer.bb
index 16fa43a982..d4fcddef3b 100644
--- a/recipes/zaurus-utils/zaurus-installer.bb
+++ b/recipes/zaurus-utils/zaurus-installer.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "Installkit for kexecboot-kernel"
DEPENDS = "${@base_conditional('MACHINE', 'collie', 'linux-kexecboot', 'zaurus-updater linux-kexecboot', d)}"
DEPENDS += "${@base_conditional('MACHINE', 'spitz', 'zaurus-legacy-tar', '', d)}"
LICENSE = "zaurus-installer"
-PR = "r3"
+PR = "r4"
PACKAGES = ""
PACKAGE_ARCH = "${MACHINE_ARCH}"
@@ -30,6 +30,10 @@ do_deploy() {
tar czf ${DEPLOY_DIR_IMAGE}/installkit-${MACHINE}.tar.gz installkit-${MACHINE}/
md5sum ${DEPLOY_DIR_IMAGE}/installkit-${MACHINE}.tar.gz > ${DEPLOY_DIR_IMAGE}/installkit-${MACHINE}.tar.gz.md5
rm -rf ${DEPLOY_DIR_IMAGE}/installkit-${MACHINE}/
+
+ package_stagefile_shell ${DEPLOY_DIR_IMAGE}/installkit-${MACHINE}.tar.gz
+ package_stagefile_shell ${DEPLOY_DIR_IMAGE}/installkit-${MACHINE}.tar.gz.md5
}
-addtask deploy before do_build after do_compile
+# package_stagefile_shell need to run before populate_sysroot for packaged-staging
+addtask deploy before do_populate_sysroot after do_compile