aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorRoman Khimov <khimov@altell.ru>2010-04-18 22:41:40 +0000
committerRoman I Khimov <khimov@altell.ru>2010-04-25 17:13:15 +0400
commit23e874a12711ee156bba5f1bbcd9fa8dd3f2ef83 (patch)
tree54e0523244d3710850111f6c95b1a1c62923ad14 /recipes
parentdd7c2be839a8db7d4afaab6e700b4f81c24fb489 (diff)
downloadopenembedded-23e874a12711ee156bba5f1bbcd9fa8dd3f2ef83.tar.gz
change INHIBIT_PACKAGE_STRIP to PACKAGE_STRIP with more options
Originally approached with "package.bbclass: introduce KEEP_GNU_DEBUGLINK": http://patchwork.openembedded.org/patch/886/ Redone with a change from INHIBIT_PACKAGE_STRIP to PACKAGE_STRIP which allows more options. By default it does exactly the same thing as is done today, strips the binary, but keeps the gnu.debuglink section. When set to "no", stripping is not done at all, when set to "full" the gnu.debuglink section is not re-added to the binary. Signed-off-by: Roman I Khimov <khimov@altell.ru> Acked-by: Chris Larson <chris_larson@mentor.com>
Diffstat (limited to 'recipes')
-rw-r--r--recipes/gcc/gcc-package-cross.inc8
-rw-r--r--recipes/gcc/gcc-package-sdk.inc8
-rw-r--r--recipes/madwifi/madwifi-ng_r2826-20071105.bb2
-rw-r--r--recipes/madwifi/madwifi-ng_r3314-20080131.bb2
-rw-r--r--recipes/madwifi/madwifi-ng_r3837-20080802.bb2
-rw-r--r--recipes/madwifi/madwifi-ng_r3878-20081204.bb2
-rw-r--r--recipes/madwifi/madwifi-ng_r4029-20090525.bb2
-rw-r--r--recipes/mii-diag/mii-diag_2.11.bb2
-rw-r--r--recipes/misc-binary-only/prism2-firmware-update_1.7.4.bb2
-rw-r--r--recipes/mtd/mtd-utils-tests_1.2.0+git.bb2
-rw-r--r--recipes/nvidia-drivers/nvidia-drivers.inc2
-rw-r--r--recipes/nylon/nylon-scripts_cvs.bb2
-rw-r--r--recipes/nylon/nylon-statistics.bb2
-rw-r--r--recipes/powervr-drivers/omap3-sgx-modules_1.4.14.2514.bb2
-rw-r--r--recipes/powervr-drivers/omap3-sgx-modules_1.4.14.2616.bb2
-rw-r--r--recipes/snes232/snes232_cvs.bb2
-rw-r--r--recipes/ti/README2
-rw-r--r--recipes/ti/ti-codecs-dm6467_1.0.0.bb2
-rw-r--r--recipes/ti/ti-dm355mm-module_1.13.bb2
-rw-r--r--recipes/ti/ti-dm365mm-module.inc2
-rw-r--r--recipes/ti/ti-dvsdk-demos.inc2
-rw-r--r--recipes/ti/ti-linuxutils.inc2
-rw-r--r--recipes/ti/ti-staging.inc2
23 files changed, 29 insertions, 29 deletions
diff --git a/recipes/gcc/gcc-package-cross.inc b/recipes/gcc/gcc-package-cross.inc
index 0f918611cf..f23d7fd848 100644
--- a/recipes/gcc/gcc-package-cross.inc
+++ b/recipes/gcc/gcc-package-cross.inc
@@ -1,6 +1,6 @@
-INHIBIT_PACKAGE_STRIP ?= ""
-OLD_INHIBIT_PACKAGE_STRIP := "${INHIBIT_PACKAGE_STRIP}"
-INHIBIT_PACKAGE_STRIP = "1"
+PACKAGE_STRIP ?= ""
+OLD_PACKAGE_STRIP := "${PACKAGE_STRIP}"
+PACKAGE_STRIP = "no"
PACKAGES = "libgcc libssp libstdc++ libg2c libgfortran"
@@ -58,7 +58,7 @@ do_install () {
# Manually run the target stripper since we won't get it run by
# the packaging.
- if [ "x${OLD_INHIBIT_PACKAGE_STRIP}" != "x1" ]; then
+ if [ "x${OLD_PACKAGE_STRIP}" != "xno" ]; then
${TARGET_PREFIX}strip ${D}${target_libdir}/libstdc++.so.* || true
${TARGET_PREFIX}strip ${D}${target_libdir}/libg2c.so.* || true
${TARGET_PREFIX}strip ${D}${target_base_libdir}/libgcc_s.so.* || true
diff --git a/recipes/gcc/gcc-package-sdk.inc b/recipes/gcc/gcc-package-sdk.inc
index dcf2c890e4..dd32ec7561 100644
--- a/recipes/gcc/gcc-package-sdk.inc
+++ b/recipes/gcc/gcc-package-sdk.inc
@@ -1,6 +1,6 @@
-INHIBIT_PACKAGE_STRIP ?= ""
-OLD_INHIBIT_PACKAGE_STRIP := "${INHIBIT_PACKAGE_STRIP}"
-INHIBIT_PACKAGE_STRIP = "1"
+PACKAGE_STRIP ?= ""
+OLD_PACKAGE_STRIP := "${PACKAGE_STRIP}"
+PACKAGE_STRIP = "no"
# Having anything auto depending on gcc-cross-sdk is a really bad idea...
EXCLUDE_FROM_SHLIBS = "1"
@@ -54,7 +54,7 @@ do_install () {
# Manually run the target stripper since we won't get it run by
# the packaging.
- if [ "x${OLD_INHIBIT_PACKAGE_STRIP}" != "x1" ]; then
+ if [ "x${OLD_PACKAGE_STRIP}" != "xno" ]; then
${TARGET_PREFIX}strip ${D}${prefix}/${TARGET_SYS}/lib/libstdc++.so.*
${TARGET_PREFIX}strip ${D}${prefix}/${TARGET_SYS}/lib/libg2c.so.* || true
${TARGET_PREFIX}strip ${D}${prefix}/${TARGET_SYS}/lib/libgcc_s.so.*
diff --git a/recipes/madwifi/madwifi-ng_r2826-20071105.bb b/recipes/madwifi/madwifi-ng_r2826-20071105.bb
index 899be22ba2..515458a02a 100644
--- a/recipes/madwifi/madwifi-ng_r2826-20071105.bb
+++ b/recipes/madwifi/madwifi-ng_r2826-20071105.bb
@@ -6,7 +6,7 @@ DEFAULT_PREFERENCE_mpc8323e-rdb = "1"
# Disable stripping of kernel modules, since this action strips too
# much out, and the resulting module won't load.
-INHIBIT_PACKAGE_STRIP = "1"
+PACKAGE_STRIP = "no"
require madwifi-ng_r.inc
diff --git a/recipes/madwifi/madwifi-ng_r3314-20080131.bb b/recipes/madwifi/madwifi-ng_r3314-20080131.bb
index 1648c2e2a0..f97ed1aa17 100644
--- a/recipes/madwifi/madwifi-ng_r3314-20080131.bb
+++ b/recipes/madwifi/madwifi-ng_r3314-20080131.bb
@@ -2,7 +2,7 @@
# Disable stripping of kernel modules, since this action strips too
# much out, and the resulting module won't load.
-INHIBIT_PACKAGE_STRIP = "1"
+PACKAGE_STRIP = "no"
require madwifi-ng_r.inc
diff --git a/recipes/madwifi/madwifi-ng_r3837-20080802.bb b/recipes/madwifi/madwifi-ng_r3837-20080802.bb
index f702720fb6..19309e7041 100644
--- a/recipes/madwifi/madwifi-ng_r3837-20080802.bb
+++ b/recipes/madwifi/madwifi-ng_r3837-20080802.bb
@@ -2,7 +2,7 @@
# Disable stripping of kernel modules, since this action strips too
# much out, and the resulting module won't load.
-INHIBIT_PACKAGE_STRIP = "1"
+PACKAGE_STRIP = "no"
require madwifi-ng_r.inc
diff --git a/recipes/madwifi/madwifi-ng_r3878-20081204.bb b/recipes/madwifi/madwifi-ng_r3878-20081204.bb
index 289a59b8d3..379a6998d7 100644
--- a/recipes/madwifi/madwifi-ng_r3878-20081204.bb
+++ b/recipes/madwifi/madwifi-ng_r3878-20081204.bb
@@ -7,7 +7,7 @@ DEFAULT_PREFERENCE_slugos = "1"
# Disable stripping of kernel modules, since this action strips too
# much out, and the resulting module won't load.
-INHIBIT_PACKAGE_STRIP = "1"
+PACKAGE_STRIP = "no"
require madwifi-ng_r.inc
diff --git a/recipes/madwifi/madwifi-ng_r4029-20090525.bb b/recipes/madwifi/madwifi-ng_r4029-20090525.bb
index dc288d8e37..ab4deea996 100644
--- a/recipes/madwifi/madwifi-ng_r4029-20090525.bb
+++ b/recipes/madwifi/madwifi-ng_r4029-20090525.bb
@@ -2,7 +2,7 @@
# Disable stripping of kernel modules, since this action strips too
# much out, and the resulting module won't load.
-INHIBIT_PACKAGE_STRIP = "1"
+PACKAGE_STRIP = "no"
require madwifi-ng_r.inc
diff --git a/recipes/mii-diag/mii-diag_2.11.bb b/recipes/mii-diag/mii-diag_2.11.bb
index e49a990b77..fc87a00e04 100644
--- a/recipes/mii-diag/mii-diag_2.11.bb
+++ b/recipes/mii-diag/mii-diag_2.11.bb
@@ -6,7 +6,7 @@ PR = "r4"
S = "${WORKDIR}/"
-#INHIBIT_PACKAGE_STRIP = "1"
+#PACKAGE_STRIP = "no"
SRC_URI = "file://mii-diag.c \
file://libmii.c"
diff --git a/recipes/misc-binary-only/prism2-firmware-update_1.7.4.bb b/recipes/misc-binary-only/prism2-firmware-update_1.7.4.bb
index dae62aebed..501fa8ad84 100644
--- a/recipes/misc-binary-only/prism2-firmware-update_1.7.4.bb
+++ b/recipes/misc-binary-only/prism2-firmware-update_1.7.4.bb
@@ -6,7 +6,7 @@ LICENSE = "unknown"
SRC_URI = "http://www.red-bean.com/~proski/firmware/${PV}.tar.bz2"
-INHIBIT_PACKAGE_STRIP = "1"
+PACKAGE_STRIP = "no"
do_install() {
install -d ${D}tmp
diff --git a/recipes/mtd/mtd-utils-tests_1.2.0+git.bb b/recipes/mtd/mtd-utils-tests_1.2.0+git.bb
index 7787c51f89..fa90696e21 100644
--- a/recipes/mtd/mtd-utils-tests_1.2.0+git.bb
+++ b/recipes/mtd/mtd-utils-tests_1.2.0+git.bb
@@ -19,7 +19,7 @@ do_compile () {
do_stage () {
}
-INHIBIT_PACKAGE_STRIP = "1"
+PACKAGE_STRIP = "no"
mtd_utils_tests = " \
help_all.sh \
diff --git a/recipes/nvidia-drivers/nvidia-drivers.inc b/recipes/nvidia-drivers/nvidia-drivers.inc
index 32f16a43b9..ef65ae4c91 100644
--- a/recipes/nvidia-drivers/nvidia-drivers.inc
+++ b/recipes/nvidia-drivers/nvidia-drivers.inc
@@ -7,7 +7,7 @@ DESCRIPTION="NVidia Graphics Driver Binary"
LICENSE = "NVIDIA"
inherit module
-INHIBIT_PACKAGE_STRIP="1"
+PACKAGE_STRIP = "no"
def nvidia_pkgrun(d):
import bb, re
diff --git a/recipes/nylon/nylon-scripts_cvs.bb b/recipes/nylon/nylon-scripts_cvs.bb
index 602f1c2352..c4deca6f83 100644
--- a/recipes/nylon/nylon-scripts_cvs.bb
+++ b/recipes/nylon/nylon-scripts_cvs.bb
@@ -13,7 +13,7 @@ RDEPENDS = "bash"
SRC_URI = "http://download.berlin.freifunk.net/meshcube.org/nylon/stable/sources/${PN}_gruen.4g__${SRCDATE}.tar.gz \
file://firewall-bash.diff;patch=1"
S = "${WORKDIR}/${PN}"
-INHIBIT_PACKAGE_STRIP = "1"
+PACKAGE_STRIP = "no"
do_install() {
install -d -m 755 ${D}
diff --git a/recipes/nylon/nylon-statistics.bb b/recipes/nylon/nylon-statistics.bb
index 91527ac297..abed00596d 100644
--- a/recipes/nylon/nylon-statistics.bb
+++ b/recipes/nylon/nylon-statistics.bb
@@ -10,7 +10,7 @@ PR = "r1"
SRC_URI = "http://download.berlin.freifunk.net/meshcube.org/nylon/stable/sources/${PN}_gruen.4g__${SRCDATE}.tar.gz"
S = "${WORKDIR}/${PN}"
-INHIBIT_PACKAGE_STRIP = "1"
+PACKAGE_STRIP = "no"
do_install() {
install -d ${D}/srv/www/cgi-bin
diff --git a/recipes/powervr-drivers/omap3-sgx-modules_1.4.14.2514.bb b/recipes/powervr-drivers/omap3-sgx-modules_1.4.14.2514.bb
index efb453137f..c0532c0a9b 100644
--- a/recipes/powervr-drivers/omap3-sgx-modules_1.4.14.2514.bb
+++ b/recipes/powervr-drivers/omap3-sgx-modules_1.4.14.2514.bb
@@ -22,7 +22,7 @@ inherit module
PVRBUILD = "release"
-INHIBIT_PACKAGE_STRIP = "1"
+PACKAGE_STRIP = "no"
MAKE_TARGETS = " BUILD=${PVRBUILD}"
diff --git a/recipes/powervr-drivers/omap3-sgx-modules_1.4.14.2616.bb b/recipes/powervr-drivers/omap3-sgx-modules_1.4.14.2616.bb
index 4863ff116e..d5eaf97c8c 100644
--- a/recipes/powervr-drivers/omap3-sgx-modules_1.4.14.2616.bb
+++ b/recipes/powervr-drivers/omap3-sgx-modules_1.4.14.2616.bb
@@ -21,7 +21,7 @@ inherit module
PVRBUILD = "release"
-INHIBIT_PACKAGE_STRIP = "1"
+PACKAGE_STRIP = "no"
MAKE_TARGETS = " BUILD=${PVRBUILD} TI_PLATFORM=omap3630"
diff --git a/recipes/snes232/snes232_cvs.bb b/recipes/snes232/snes232_cvs.bb
index 1424f86dfe..5482c011a4 100644
--- a/recipes/snes232/snes232_cvs.bb
+++ b/recipes/snes232/snes232_cvs.bb
@@ -1,7 +1,7 @@
SECTION = "unknown"
PR = "r4"
LICENSE = "GPL"
-INHIBIT_PACKAGE_STRIP = "1"
+PACKAGE_STRIP = "no"
RRECOMMENDS = "kernel-module-serport"
diff --git a/recipes/ti/README b/recipes/ti/README
index eed00f0253..2fbb9f1bbc 100644
--- a/recipes/ti/README
+++ b/recipes/ti/README
@@ -30,7 +30,7 @@ The complete unpacked trees are staged to staging/machine/usr/share/ti/${PN}(-tr
PACKAGE_ARCH = "${MACHINE_ARCH}"
BASEPKG_HOST_SYS = "${MULTIMACH_HOST_SYS}"
-INHIBIT_PACKAGE_STRIP = "1"
+PACKAGE_STRIP = "no"
The 'BASEPKG_HOST_SYS' bit is what makes it work, but cause trouble is you want to read from it, so ti-paths.inc does:
diff --git a/recipes/ti/ti-codecs-dm6467_1.0.0.bb b/recipes/ti/ti-codecs-dm6467_1.0.0.bb
index 9454b94ee4..709b21f0a3 100644
--- a/recipes/ti/ti-codecs-dm6467_1.0.0.bb
+++ b/recipes/ti/ti-codecs-dm6467_1.0.0.bb
@@ -38,4 +38,4 @@ do_install () {
}
PACKAGE_ARCH = "${MACHINE_ARCH}"
-INHIBIT_PACKAGE_STRIP = "1"
+PACKAGE_STRIP = "no"
diff --git a/recipes/ti/ti-dm355mm-module_1.13.bb b/recipes/ti/ti-dm355mm-module_1.13.bb
index f7bd83123a..0308ab164a 100644
--- a/recipes/ti/ti-dm355mm-module_1.13.bb
+++ b/recipes/ti/ti-dm355mm-module_1.13.bb
@@ -39,7 +39,7 @@ do_install () {
install -m 0755 ${S}/dm355mm/module/dm350mmap.ko ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/dsp
}
-INHIBIT_PACKAGE_STRIP = "1"
+PACKAGE_STRIP = "no"
SRC_URI[md5sum] = "f6221188bea76b7aaf0c45e9bcf26329"
SRC_URI[sha256sum] = "f1a6dea51be9798903a0543fb50f463b0594b1f11b897bc50e40825fb7527c61"
diff --git a/recipes/ti/ti-dm365mm-module.inc b/recipes/ti/ti-dm365mm-module.inc
index 6b0497bc9e..caf0441a99 100644
--- a/recipes/ti/ti-dm365mm-module.inc
+++ b/recipes/ti/ti-dm365mm-module.inc
@@ -25,5 +25,5 @@ do_install () {
install -m 0755 ${S}/module/dm365mmap.ko ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/dsp
}
-INHIBIT_PACKAGE_STRIP = "1"
+PACKAGE_STRIP = "no"
INSANE_SKIP_${PN} = True
diff --git a/recipes/ti/ti-dvsdk-demos.inc b/recipes/ti/ti-dvsdk-demos.inc
index 99e9875dd1..af1ecd8b97 100644
--- a/recipes/ti/ti-dvsdk-demos.inc
+++ b/recipes/ti/ti-dvsdk-demos.inc
@@ -64,5 +64,5 @@ FILES_${PN} = "${installdir}/dvsdk-demos/*"
BASE_SRC_URI ?= "http://install.source.dir.local"
-INHIBIT_PACKAGE_STRIP = "1"
+PACKAGE_STRIP = "no"
INSANE_SKIP_${PN} = "True"
diff --git a/recipes/ti/ti-linuxutils.inc b/recipes/ti/ti-linuxutils.inc
index 3482d707ab..209299deea 100644
--- a/recipes/ti/ti-linuxutils.inc
+++ b/recipes/ti/ti-linuxutils.inc
@@ -83,4 +83,4 @@ FILES_ti-irq-module = "/lib/modules/${KERNEL_VERSION}/kernel/drivers/dsp/irq*.ko
FILES_ti-linuxutils-app = "${installdir}/ti-linuxutils-app/*/*"
INSANE_SKIP_ti-linuxutils-app = "True"
-INHIBIT_PACKAGE_STRIP = "1"
+PACKAGE_STRIP = "no"
diff --git a/recipes/ti/ti-staging.inc b/recipes/ti/ti-staging.inc
index faa24616cd..593f094969 100644
--- a/recipes/ti/ti-staging.inc
+++ b/recipes/ti/ti-staging.inc
@@ -6,7 +6,7 @@ BASEPKG_HOST_SYS = "${MULTIMACH_HOST_SYS}"
# Search archdir for shlibs instead of machine dir due to above BASEPKG_HOST_SYS
SHLIBSDIR = "${STAGING_DIR}/${BASE_PACKAGE_ARCH}${HOST_VENDOR}-${HOST_OS}/shlibs"
-INHIBIT_PACKAGE_STRIP = "1"
+PACKAGE_STRIP = "no"
ALLOW_EMPTY_${PN} = "1"
ALLOW_EMPTY_${PN}-dev = "1"