aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-10-28 21:03:04 +0100
committerKoen Kooi <koen@openembedded.org>2009-10-28 21:03:04 +0100
commit7767c7c6d21cb731b15c3a8277f2fa316d24308f (patch)
tree1429f8475b694097cbe11f450b4f4a69f3021564 /recipes
parentbea7f9fd85aa0e3ad90215f745d96f30b72a54cd (diff)
downloadopenembedded-7767c7c6d21cb731b15c3a8277f2fa316d24308f.tar.gz
gnumeric: add 1.9.14
libgsf: add 1.14.16 goffice: add 0.7.14
Diffstat (limited to 'recipes')
-rw-r--r--recipes/gnome/gnumeric/remove-docs.patch (renamed from recipes/gnumeric/files/remove-docs.patch)0
-rw-r--r--recipes/gnome/gnumeric_1.8.4.bb (renamed from recipes/gnumeric/gnumeric_1.8.4.bb)0
-rw-r--r--recipes/gnome/gnumeric_1.9.14.bb30
-rw-r--r--recipes/gnome/goffice_0.7.14.bb21
-rw-r--r--recipes/gnome/libgsf_1.10.0.bb (renamed from recipes/libgsf/libgsf_1.10.0.bb)0
-rw-r--r--recipes/gnome/libgsf_1.12.0.bb (renamed from recipes/libgsf/libgsf_1.12.0.bb)0
-rw-r--r--recipes/gnome/libgsf_1.12.1.bb (renamed from recipes/libgsf/libgsf_1.12.1.bb)0
-rw-r--r--recipes/gnome/libgsf_1.12.2.bb (renamed from recipes/libgsf/libgsf_1.12.2.bb)0
-rw-r--r--recipes/gnome/libgsf_1.13.2.bb (renamed from recipes/libgsf/libgsf_1.13.2.bb)0
-rw-r--r--recipes/gnome/libgsf_1.13.3.bb (renamed from recipes/libgsf/libgsf_1.13.3.bb)0
-rw-r--r--recipes/gnome/libgsf_1.14.16.bb21
-rw-r--r--recipes/gnome/libgsf_1.14.8.bb (renamed from recipes/libgsf/libgsf_1.14.8.bb)0
12 files changed, 72 insertions, 0 deletions
diff --git a/recipes/gnumeric/files/remove-docs.patch b/recipes/gnome/gnumeric/remove-docs.patch
index 650ad6f4fa..650ad6f4fa 100644
--- a/recipes/gnumeric/files/remove-docs.patch
+++ b/recipes/gnome/gnumeric/remove-docs.patch
diff --git a/recipes/gnumeric/gnumeric_1.8.4.bb b/recipes/gnome/gnumeric_1.8.4.bb
index e375f278f2..e375f278f2 100644
--- a/recipes/gnumeric/gnumeric_1.8.4.bb
+++ b/recipes/gnome/gnumeric_1.8.4.bb
diff --git a/recipes/gnome/gnumeric_1.9.14.bb b/recipes/gnome/gnumeric_1.9.14.bb
new file mode 100644
index 0000000000..8c7023ee37
--- /dev/null
+++ b/recipes/gnome/gnumeric_1.9.14.bb
@@ -0,0 +1,30 @@
+LICENSE = "GPL"
+SECTION = "x11/utils"
+DEPENDS = "gdk-pixbuf-csource-native libgsf gtk+ libxml2 goffice libglade libart-lgpl intltool-native libgnomecanvas libgnomeprint libgnomeprintui libbonoboui orbit2-native"
+DESCRIPTION = "Gnumeric spreadsheet for GNOME"
+
+PARALLEL_MAKE = ""
+
+inherit gnome flow-lossage
+
+EXTRA_OECONF=" --without-perl "
+
+PACKAGES_DYNAMIC += "gnumeric-plugin-*"
+
+FILES_${PN}-dbg += "${libdir}/gnumeric/${PV}/plugins/*/.debug"
+FILES_${PN} += "${libdir}/libspreadsheet-${PV}.so "
+
+do_configure_prepend() {
+ sed -i -e s:doc\ tools:tools: ${S}/Makefile.am
+}
+
+# We need native orbit-idl with target idl files. No way to say it in a clean way:
+do_configure_append () {
+ find -name Makefile -exec sed -i '/\/usr\/bin\/orbit-idl-2/{s:/usr/bin:${STAGING_BINDIR_NATIVE}:;s:/usr/share:${STAGING_DATADIR}:g}' {} \;
+}
+
+python populate_packages_prepend () {
+ gnumeric_libdir = bb.data.expand('${libdir}/gnumeric/${PV}/plugins', d)
+
+ do_split_packages(d, gnumeric_libdir, '(.*)', 'gnumeric-plugin-%s', 'Gnumeric plugin for %s', allow_dirs=True)
+}
diff --git a/recipes/gnome/goffice_0.7.14.bb b/recipes/gnome/goffice_0.7.14.bb
new file mode 100644
index 0000000000..9fff0b4cfe
--- /dev/null
+++ b/recipes/gnome/goffice_0.7.14.bb
@@ -0,0 +1,21 @@
+DESCRIPTION="Gnome Office Library"
+LICENSE="GPLv2"
+
+DEPENDS="glib-2.0 gtk+ pango cairo libgnomeprint libgsf libglade libpcre libxml2 libart-lgpl"
+
+FILES_${PN}-dbg += "${libdir}/goffice/${PV}/plugins/*/.debug"
+
+inherit gnome pkgconfig
+
+do_stage() {
+ autotools_stage_all
+}
+
+PACKAGES_DYNAMIC = "goffice-plugin-*"
+
+python populate_packages_prepend () {
+ goffice_libdir = bb.data.expand('${libdir}/goffice/${PV}/plugins', d)
+
+ do_split_packages(d, goffice_libdir, '(.*)', 'goffice-plugin-%s', 'Goffice plugin for %s', allow_dirs=True)
+}
+
diff --git a/recipes/libgsf/libgsf_1.10.0.bb b/recipes/gnome/libgsf_1.10.0.bb
index ce464feba9..ce464feba9 100644
--- a/recipes/libgsf/libgsf_1.10.0.bb
+++ b/recipes/gnome/libgsf_1.10.0.bb
diff --git a/recipes/libgsf/libgsf_1.12.0.bb b/recipes/gnome/libgsf_1.12.0.bb
index 2698639873..2698639873 100644
--- a/recipes/libgsf/libgsf_1.12.0.bb
+++ b/recipes/gnome/libgsf_1.12.0.bb
diff --git a/recipes/libgsf/libgsf_1.12.1.bb b/recipes/gnome/libgsf_1.12.1.bb
index 310d922d6e..310d922d6e 100644
--- a/recipes/libgsf/libgsf_1.12.1.bb
+++ b/recipes/gnome/libgsf_1.12.1.bb
diff --git a/recipes/libgsf/libgsf_1.12.2.bb b/recipes/gnome/libgsf_1.12.2.bb
index 02e95718dd..02e95718dd 100644
--- a/recipes/libgsf/libgsf_1.12.2.bb
+++ b/recipes/gnome/libgsf_1.12.2.bb
diff --git a/recipes/libgsf/libgsf_1.13.2.bb b/recipes/gnome/libgsf_1.13.2.bb
index caeb4e4dc9..caeb4e4dc9 100644
--- a/recipes/libgsf/libgsf_1.13.2.bb
+++ b/recipes/gnome/libgsf_1.13.2.bb
diff --git a/recipes/libgsf/libgsf_1.13.3.bb b/recipes/gnome/libgsf_1.13.3.bb
index 1f793b1143..1f793b1143 100644
--- a/recipes/libgsf/libgsf_1.13.3.bb
+++ b/recipes/gnome/libgsf_1.13.3.bb
diff --git a/recipes/gnome/libgsf_1.14.16.bb b/recipes/gnome/libgsf_1.14.16.bb
new file mode 100644
index 0000000000..5697275f7a
--- /dev/null
+++ b/recipes/gnome/libgsf_1.14.16.bb
@@ -0,0 +1,21 @@
+LICENSE = "GPL"
+SECTION = "libs"
+
+DEPENDS= "libxml2 bzip2 glib-2.0 zlib gtk-doc libbonobo gnome-vfs"
+RDEPENDS = "gconf gnome-vfs"
+
+PACKAGES =+ "${PN}-gnome ${PN}-gnome-dev "
+
+FILES_${PN}-gnome = "${libdir}/libgsf-gnome-1.so.*"
+FILES_${PN}-gnome-dev = "${libdir}/libgsf-gnome-1.* ${includedir}/libgsf-1/gsf-gnome"
+
+inherit gnome
+
+EXTRA_OECONF = "\
+ --without-python \
+ --with-gnome \
+ --with-bz2"
+
+do_stage() {
+ autotools_stage_all
+}
diff --git a/recipes/libgsf/libgsf_1.14.8.bb b/recipes/gnome/libgsf_1.14.8.bb
index 43fd3ab9c7..43fd3ab9c7 100644
--- a/recipes/libgsf/libgsf_1.14.8.bb
+++ b/recipes/gnome/libgsf_1.14.8.bb