aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorCliff Brake <cbrake@bec-systems.com>2010-09-22 16:59:31 -0400
committerCliff Brake <cbrake@bec-systems.com>2010-09-22 16:59:31 -0400
commite5649ec28337483ed664f7d2d6bba2e96e649d41 (patch)
tree19de51055f916122cbfa430d406e129a328b7dc6 /recipes
parent8909f409e4fa38a8cf09d31c680ea233d30f6d50 (diff)
downloadopenembedded-e5649ec28337483ed664f7d2d6bba2e96e649d41.tar.gz
qt4: add 4.7.0 released version
Diffstat (limited to 'recipes')
-rw-r--r--recipes/qt4/files/hack-out-pg2-4.7.0.patch19
-rw-r--r--recipes/qt4/qt-4.7.0.inc74
-rw-r--r--recipes/qt4/qt-4.7.0/0001-Added-Openembedded-crossarch-option.patch44
-rw-r--r--recipes/qt4/qt-4.7.0/0002-Disable-tools-assistant.patch25
-rw-r--r--recipes/qt4/qt-4.7.0/0003-Disable-examples-designer.patch24
-rw-r--r--recipes/qt4/qt-4.7.0/0004-Disable-exaqmples-dbus-remotecontrolledcar.patch26
-rw-r--r--recipes/qt4/qt-4.7.0/0005-Disable-examples-help.patch25
-rw-r--r--recipes/qt4/qt-4.7.0/0006-Disable-demos-browser.patch24
-rw-r--r--recipes/qt4/qt-4.7.0/0007-Disable-demos-qtdemos.patch25
-rw-r--r--recipes/qt4/qt-4.7.0/0008-Disable-examples-declarative.patch24
-rw-r--r--recipes/qt4/qt-4.7.0/add.xmlpatterns.lib.patch22
-rw-r--r--recipes/qt4/qt-4.7.0/demos.browser.add.mediaservices.lib.patch12
-rw-r--r--recipes/qt4/qt4-embedded_4.7.0.bb14
-rw-r--r--recipes/qt4/qt4-tools-native-4.7.0/fix.xlib-test.libs.patch9
-rw-r--r--recipes/qt4/qt4-tools-native_4.7.0.bb23
-rw-r--r--recipes/qt4/qt4-x11-free_4.7.0.bb15
16 files changed, 405 insertions, 0 deletions
diff --git a/recipes/qt4/files/hack-out-pg2-4.7.0.patch b/recipes/qt4/files/hack-out-pg2-4.7.0.patch
new file mode 100644
index 0000000000..5c588ff0f7
--- /dev/null
+++ b/recipes/qt4/files/hack-out-pg2-4.7.0.patch
@@ -0,0 +1,19 @@
+Index: qt-everywhere-opensource-src-4.7.0/configure
+===================================================================
+--- qt-everywhere-opensource-src-4.7.0.orig/configure 2010-09-22 15:43:51.191162141 -0400
++++ qt-everywhere-opensource-src-4.7.0/configure 2010-09-22 15:44:35.179981232 -0400
+@@ -4921,10 +4921,10 @@
+ psql)
+ if [ "$CFG_SQL_psql" != "no" ]; then
+ # Be careful not to use native pg_config when cross building.
+- if [ "$XPLATFORM_MINGW" != "yes" ] && "$WHICH" pg_config >/dev/null 2>&1; then
+- QT_CFLAGS_PSQL=`pg_config --includedir 2>/dev/null`
+- QT_LFLAGS_PSQL=`pg_config --libdir 2>/dev/null`
+- fi
++# if [ "$XPLATFORM_MINGW" != "yes" ] && "$WHICH" pg_config >/dev/null 2>&1; then
++# QT_CFLAGS_PSQL=`pg_config --includedir 2>/dev/null`
++# QT_LFLAGS_PSQL=`pg_config --libdir 2>/dev/null`
++# fi
+ [ -z "$QT_CFLAGS_PSQL" ] || QT_CFLAGS_PSQL="-I$QT_CFLAGS_PSQL"
+ [ -z "$QT_LFLAGS_PSQL" ] || QT_LFLAGS_PSQL="-L$QT_LFLAGS_PSQL"
+ # But, respect PSQL_LIBS if set
diff --git a/recipes/qt4/qt-4.7.0.inc b/recipes/qt4/qt-4.7.0.inc
new file mode 100644
index 0000000000..9562109edd
--- /dev/null
+++ b/recipes/qt4/qt-4.7.0.inc
@@ -0,0 +1,74 @@
+DEFAULT_PREFERENCE = "-1"
+LICENSE = "LGPLv2.1 GPLv3"
+
+FILESPATHPKG .= ":qt-${PV}"
+
+SRC_URI = "\
+ ftp://ftp.trolltech.com/qt/source/qt-everywhere-opensource-src-${PV}.tar.gz \
+ file://0004-no-qmake.patch \
+ file://hack-out-pg2-4.7.0.patch \
+ file://0006-freetype-host-includes.patch \
+ file://0001-Added-Openembedded-crossarch-option.patch \
+ file://0002-Disable-tools-assistant.patch \
+ file://0003-Disable-examples-designer.patch \
+ file://0004-Disable-exaqmples-dbus-remotecontrolledcar.patch \
+ file://0005-Disable-examples-help.patch \
+ file://0007-Disable-demos-qtdemos.patch \
+ file://0008-Disable-examples-declarative.patch \
+ file://demos.browser.add.mediaservices.lib.patch \
+ file://add.xmlpatterns.lib.patch \
+ file://g++.conf \
+ file://linux.conf \
+ "
+
+S = "${WORKDIR}/qt-everywhere-opensource-src-${PV}"
+
+QT_LIB_NAMES += "QtDeclarative"
+FILES_${QT_BASE_NAME}-tools += "${bindir}/qml"
+
+do_configure_prepend() {
+ for pro in $(find ${S} -name "*.pro") ; do
+ sed -i 's:$$QT_BUILD_TREE/bin/lrelease:${OE_QMAKE_LRELEASE}:g' $pro
+ done
+
+ sed -i s:SEDME:${S}: ${WORKDIR}/linux.conf
+ sed -i \
+ -e /QMAKE_MOC\ /d \
+ -e /QMAKE_UIC\ /d \
+ -e /QMAKE_UIC3\ /d \
+ -e /QMAKE_RCC\ /d \
+ ${S}/configure
+}
+
+do_configure_append() {
+ sed -e '/QMAKE_TARGET /d' -e '/TARGET /d' -i ${S}/translations/Makefile
+}
+
+QT_GLFLAGS ?= ""
+QT_CONFIG_FLAGS += " -xmlpatterns -no-rpath -qt3support -reduce-relocations -silent ${QT_GLFLAGS}"
+
+do_compile() {
+ # Fixup missing wsegl header in some SGX SDKs
+ if ! [ -e ${STAGING_INCDIR}/wsegl.h ] ; then
+ cp src/3rdparty/powervr/wsegl.h src/plugins/gfxdrivers/powervr/QWSWSEGL/
+ fi
+
+ unset CFLAGS CXXFLAGS
+ install -m 0755 ${STAGING_BINDIR_NATIVE}/rcc4 ${S}/bin/rcc
+ install -m 0755 ${STAGING_BINDIR_NATIVE}/moc4 ${S}/bin/moc
+ install -m 0755 ${STAGING_BINDIR_NATIVE}/uic4 ${S}/bin/uic
+ install -m 0755 ${STAGING_BINDIR_NATIVE}/lrelease4 ${S}/bin/lrelease
+
+ oe_runmake ${EXTRA_ENV}
+}
+
+do_install_append() {
+ install -d ${D}${bindir}
+ for i in rcc uic moc ; do
+ install -m 0755 ${S}/bin/$i ${D}${bindir}/
+ done
+}
+
+SRC_URI[md5sum] = "3a2f25b9b115037277f4fb759194a7a5"
+SRC_URI[sha256sum] = "e05256d560ca7d674cd4310bb791748900ad14ad662cbfe22b6d72ada43e7955"
+
diff --git a/recipes/qt4/qt-4.7.0/0001-Added-Openembedded-crossarch-option.patch b/recipes/qt4/qt-4.7.0/0001-Added-Openembedded-crossarch-option.patch
new file mode 100644
index 0000000000..71a04a59d2
--- /dev/null
+++ b/recipes/qt4/qt-4.7.0/0001-Added-Openembedded-crossarch-option.patch
@@ -0,0 +1,44 @@
+From b1ba119f6a824dc01bd42ee00dba4a1653867b72 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Matthias=20G=C3=BCnther?= <matgnt@gmail.com>
+Date: Wed, 12 May 2010 16:52:45 +0200
+Subject: [PATCH 1/9] Added Openembedded "-crossarch" option
+
+---
+ configure | 7 ++++++-
+ 1 files changed, 6 insertions(+), 1 deletions(-)
+
+diff --git a/configure b/configure
+index facd192..9d15136 100755
+--- a/configure
++++ b/configure
+@@ -954,7 +954,7 @@ while [ "$#" -gt 0 ]; do
+ shift
+ VAL=$1
+ ;;
+- -prefix|-docdir|-headerdir|-plugindir|-importdir|-datadir|-libdir|-bindir|-translationdir|-sysconfdir|-examplesdir|-demosdir|-depths|-make|-nomake|-platform|-xplatform|-buildkey|-sdk|-arch|-host-arch|-mysql_config)
++ -prefix|-docdir|-headerdir|-plugindir|-importdir|-datadir|-libdir|-bindir|-translationdir|-sysconfdir|-examplesdir|-demosdir|-depths|-make|-nomake|-platform|-xplatform|-buildkey|-sdk|-arch|-host-arch|-mysql_config|-crossarch)
+ VAR=`echo $1 | sed "s,^-\(.*\),\1,"`
+ shift
+ VAL="$1"
+@@ -1443,6 +1443,9 @@ while [ "$#" -gt 0 ]; do
+ xplatform)
+ XPLATFORM="$VAL"
+ ;;
++ crossarch)
++ CROSSARCH="$VAL"
++ ;;
+ debug-and-release)
+ if [ "$VAL" = "yes" ] || [ "$VAL" = "no" ]; then
+ CFG_DEBUG_RELEASE="$VAL"
+@@ -2918,6 +2921,8 @@ elif [ "$PLATFORM_MAC" = "yes" ] || [ -z "$CFG_ARCH" ]; then
+ CFG_ARCH=$CFG_HOST_ARCH
+ fi
+
++CFG_ARCH="$CROSSARCH"
++
+ if [ -d "$relpath/src/corelib/arch/$CFG_ARCH" ]; then
+ if [ "$OPT_VERBOSE" = "yes" ]; then
+ echo " '$CFG_ARCH' is supported"
+--
+1.7.0.4
+
diff --git a/recipes/qt4/qt-4.7.0/0002-Disable-tools-assistant.patch b/recipes/qt4/qt-4.7.0/0002-Disable-tools-assistant.patch
new file mode 100644
index 0000000000..1a5da6793b
--- /dev/null
+++ b/recipes/qt4/qt-4.7.0/0002-Disable-tools-assistant.patch
@@ -0,0 +1,25 @@
+From f107d9957f8382dfc2c7b28248eee2d628342a93 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Matthias=20G=C3=BCnther?= <matgnt@gmail.com>
+Date: Wed, 12 May 2010 19:41:13 +0200
+Subject: [PATCH 2/9] Disable tools/assistant
+
+---
+ tools/tools.pro | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/tools/tools.pro b/tools/tools.pro
+index 7598962..1d35a3f 100644
+--- a/tools/tools.pro
++++ b/tools/tools.pro
+@@ -9,7 +9,7 @@ TEMPLATE = subdirs
+ } else:wince* {
+ SUBDIRS = qtestlib designer
+ } else {
+- SUBDIRS = assistant \
++ SUBDIRS = \
+ pixeltool \
+ porting \
+ qtestlib \
+--
+1.7.0.4
+
diff --git a/recipes/qt4/qt-4.7.0/0003-Disable-examples-designer.patch b/recipes/qt4/qt-4.7.0/0003-Disable-examples-designer.patch
new file mode 100644
index 0000000000..51fa4a6d6e
--- /dev/null
+++ b/recipes/qt4/qt-4.7.0/0003-Disable-examples-designer.patch
@@ -0,0 +1,24 @@
+From 82aaf21a465d0d693916c4b82932371a090482a7 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Matthias=20G=C3=BCnther?= <matgnt@gmail.com>
+Date: Wed, 12 May 2010 20:33:11 +0200
+Subject: [PATCH 3/9] Disable examples/designer
+
+---
+ examples/examples.pro | 1 -
+ 1 files changed, 0 insertions(+), 1 deletions(-)
+
+diff --git a/examples/examples.pro b/examples/examples.pro
+index 43cad55..785c35c 100644
+--- a/examples/examples.pro
++++ b/examples/examples.pro
+@@ -53,7 +53,6 @@ contains(QT_CONFIG, script): SUBDIRS += script
+ contains(QT_CONFIG, phonon):!static: SUBDIRS += phonon
+ embedded:SUBDIRS += qws
+ !wince*:!symbian: {
+- !contains(QT_EDITION, Console):!contains(QT_CONFIG, no-gui):contains(QT_BUILD_PARTS, tools):SUBDIRS += designer
+ contains(QT_BUILD_PARTS, tools):!contains(QT_CONFIG, no-gui):SUBDIRS += qtestlib help
+ } else {
+ contains(QT_BUILD_PARTS, tools):!contains(QT_CONFIG, no-gui):SUBDIRS += qtestlib
+--
+1.7.0.4
+
diff --git a/recipes/qt4/qt-4.7.0/0004-Disable-exaqmples-dbus-remotecontrolledcar.patch b/recipes/qt4/qt-4.7.0/0004-Disable-exaqmples-dbus-remotecontrolledcar.patch
new file mode 100644
index 0000000000..cef56ef29b
--- /dev/null
+++ b/recipes/qt4/qt-4.7.0/0004-Disable-exaqmples-dbus-remotecontrolledcar.patch
@@ -0,0 +1,26 @@
+From 753cc5766d51c5b7d599fada569d6b262f2a3b1a Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Matthias=20G=C3=BCnther?= <matgnt@gmail.com>
+Date: Wed, 12 May 2010 20:49:30 +0200
+Subject: [PATCH 4/9] Disable exaqmples/dbus/remotecontrolledcar
+
+---
+ examples/dbus/dbus.pro | 3 +--
+ 1 files changed, 1 insertions(+), 2 deletions(-)
+
+diff --git a/examples/dbus/dbus.pro b/examples/dbus/dbus.pro
+index e599334..daa89b0 100644
+--- a/examples/dbus/dbus.pro
++++ b/examples/dbus/dbus.pro
+@@ -4,8 +4,7 @@ SUBDIRS = listnames \
+ complexpingpong
+
+ !contains(QT_CONFIG, no-gui) {
+- SUBDIRS += dbus-chat \
+- remotecontrolledcar
++ SUBDIRS += dbus-chat
+ }
+
+ # install
+--
+1.7.0.4
+
diff --git a/recipes/qt4/qt-4.7.0/0005-Disable-examples-help.patch b/recipes/qt4/qt-4.7.0/0005-Disable-examples-help.patch
new file mode 100644
index 0000000000..026f2b08e9
--- /dev/null
+++ b/recipes/qt4/qt-4.7.0/0005-Disable-examples-help.patch
@@ -0,0 +1,25 @@
+From c7f749b564b473f0160a201c769153cfcaf3bc0b Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Matthias=20G=C3=BCnther?= <matgnt@gmail.com>
+Date: Thu, 13 May 2010 14:27:22 +0200
+Subject: [PATCH 5/9] Disable examples/help
+
+---
+ examples/examples.pro | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/examples/examples.pro b/examples/examples.pro
+index 785c35c..e37f580 100644
+--- a/examples/examples.pro
++++ b/examples/examples.pro
+@@ -53,7 +53,7 @@ contains(QT_CONFIG, script): SUBDIRS += script
+ contains(QT_CONFIG, phonon):!static: SUBDIRS += phonon
+ embedded:SUBDIRS += qws
+ !wince*:!symbian: {
+- contains(QT_BUILD_PARTS, tools):!contains(QT_CONFIG, no-gui):SUBDIRS += qtestlib help
++ contains(QT_BUILD_PARTS, tools):!contains(QT_CONFIG, no-gui):SUBDIRS += qtestlib
+ } else {
+ contains(QT_BUILD_PARTS, tools):!contains(QT_CONFIG, no-gui):SUBDIRS += qtestlib
+ }
+--
+1.7.0.4
+
diff --git a/recipes/qt4/qt-4.7.0/0006-Disable-demos-browser.patch b/recipes/qt4/qt-4.7.0/0006-Disable-demos-browser.patch
new file mode 100644
index 0000000000..e863f12749
--- /dev/null
+++ b/recipes/qt4/qt-4.7.0/0006-Disable-demos-browser.patch
@@ -0,0 +1,24 @@
+From 11657d8c4b964b7c16b1d216522a92d6280007e1 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Matthias=20G=C3=BCnther?= <matgnt@gmail.com>
+Date: Thu, 13 May 2010 15:53:29 +0200
+Subject: [PATCH 6/9] Disable /demos/browser
+
+---
+ demos/demos.pro | 1 -
+ 1 files changed, 0 insertions(+), 1 deletions(-)
+
+diff --git a/demos/demos.pro b/demos/demos.pro
+index 5e8a4ea..8008ccb 100644
+--- a/demos/demos.pro
++++ b/demos/demos.pro
+@@ -56,7 +56,6 @@ wince*:SUBDIRS += demos_sqlbrowser
+ }
+ }
+ contains(QT_CONFIG, phonon):!static:SUBDIRS += demos_mediaplayer
+-contains(QT_CONFIG, webkit):contains(QT_CONFIG, svg):!symbian:SUBDIRS += demos_browser
+ contains(QT_CONFIG, multimedia):SUBDIRS += demos_multimedia
+ contains(QT_CONFIG, declarative):SUBDIRS += demos_declarative
+
+--
+1.7.0.4
+
diff --git a/recipes/qt4/qt-4.7.0/0007-Disable-demos-qtdemos.patch b/recipes/qt4/qt-4.7.0/0007-Disable-demos-qtdemos.patch
new file mode 100644
index 0000000000..6bef4c2dba
--- /dev/null
+++ b/recipes/qt4/qt-4.7.0/0007-Disable-demos-qtdemos.patch
@@ -0,0 +1,25 @@
+From 6a4b829736399fef4a6f1d3223cf0d813caf7062 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Matthias=20G=C3=BCnther?= <matgnt@gmail.com>
+Date: Thu, 13 May 2010 16:00:06 +0200
+Subject: [PATCH 7/9] Disable demos/qtdemos
+
+---
+ demos/demos.pro | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/demos/demos.pro b/demos/demos.pro
+index 8008ccb..a0691bc 100644
+--- a/demos/demos.pro
++++ b/demos/demos.pro
+@@ -51,7 +51,7 @@ wince*|symbian|embedded|x11: SUBDIRS += demos_embedded
+
+ !cross_compile:{
+ contains(QT_BUILD_PARTS, tools):{
+-!wince*:SUBDIRS += demos_sqlbrowser demos_qtdemo
++!wince*:SUBDIRS += demos_sqlbrowser
+ wince*:SUBDIRS += demos_sqlbrowser
+ }
+ }
+--
+1.7.0.4
+
diff --git a/recipes/qt4/qt-4.7.0/0008-Disable-examples-declarative.patch b/recipes/qt4/qt-4.7.0/0008-Disable-examples-declarative.patch
new file mode 100644
index 0000000000..06e15623f7
--- /dev/null
+++ b/recipes/qt4/qt-4.7.0/0008-Disable-examples-declarative.patch
@@ -0,0 +1,24 @@
+From 1b855a946a1d060c52ddb04f308fb25f1d391b6a Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Matthias=20G=C3=BCnther?= <matgnt@gmail.com>
+Date: Thu, 13 May 2010 19:49:45 +0200
+Subject: [PATCH 8/9] Disable examples/declarative
+
+---
+ examples/examples.pro | 1 -
+ 1 files changed, 0 insertions(+), 1 deletions(-)
+
+diff --git a/examples/examples.pro b/examples/examples.pro
+index e37f580..8681a41 100644
+--- a/examples/examples.pro
++++ b/examples/examples.pro
+@@ -60,7 +60,6 @@ embedded:SUBDIRS += qws
+ contains(QT_CONFIG, opengl): SUBDIRS += opengl
+ contains(QT_CONFIG, openvg): SUBDIRS += openvg
+ contains(QT_CONFIG, dbus): SUBDIRS += dbus
+-contains(QT_CONFIG, declarative): SUBDIRS += declarative
+ win32: SUBDIRS += activeqt
+ contains(QT_CONFIG, xmlpatterns):!contains(QT_CONFIG, no-gui): SUBDIRS += xmlpatterns
+ contains(DEFINES, QT_NO_CURSOR): SUBDIRS -= mainwindows
+--
+1.7.0.4
+
diff --git a/recipes/qt4/qt-4.7.0/add.xmlpatterns.lib.patch b/recipes/qt4/qt-4.7.0/add.xmlpatterns.lib.patch
new file mode 100644
index 0000000000..1f73f8950f
--- /dev/null
+++ b/recipes/qt4/qt-4.7.0/add.xmlpatterns.lib.patch
@@ -0,0 +1,22 @@
+diff -uNr qt-everywhere-opensource-src-4.7.0-beta1.orig//demos/browser/browser.pro qt-everywhere-opensource-src-4.7.0-beta1/demos/browser/browser.pro
+--- qt-everywhere-opensource-src-4.7.0-beta1.orig//demos/browser/browser.pro 2010-06-26 13:15:06.000000000 +0200
++++ qt-everywhere-opensource-src-4.7.0-beta1/demos/browser/browser.pro 2010-06-26 13:18:17.000000000 +0200
+@@ -1,6 +1,6 @@
+ TEMPLATE = app
+ TARGET = browser
+-QT += webkit network mediaservices
++QT += webkit network mediaservices xmlpatterns phonon
+
+ CONFIG += qt warn_on
+ contains(QT_BUILD_PARTS, tools):!embedded: CONFIG += uitools
+diff -uNr qt-everywhere-opensource-src-4.7.0-beta1.orig//examples/xmlpatterns/qobjectxmlmodel/qobjectxmlmodel.pro qt-everywhere-opensource-src-4.7.0-beta1/examples/xmlpatterns/qobjectxmlmodel/qobjectxmlmodel.pro
+--- qt-everywhere-opensource-src-4.7.0-beta1.orig//examples/xmlpatterns/qobjectxmlmodel/qobjectxmlmodel.pro 2010-05-04 02:43:18.000000000 +0200
++++ qt-everywhere-opensource-src-4.7.0-beta1/examples/xmlpatterns/qobjectxmlmodel/qobjectxmlmodel.pro 2010-06-26 13:17:42.000000000 +0200
+@@ -1,6 +1,6 @@
+
+ FORMS += forms/mainwindow.ui
+-QT += xmlpatterns webkit
++QT += xmlpatterns webkit mediaservices phonon
+ SOURCES += qobjectxmlmodel.cpp main.cpp mainwindow.cpp ../shared/xmlsyntaxhighlighter.cpp
+ HEADERS += qobjectxmlmodel.h mainwindow.h ../shared/xmlsyntaxhighlighter.h
+ RESOURCES = queries.qrc
diff --git a/recipes/qt4/qt-4.7.0/demos.browser.add.mediaservices.lib.patch b/recipes/qt4/qt-4.7.0/demos.browser.add.mediaservices.lib.patch
new file mode 100644
index 0000000000..27c42dfcec
--- /dev/null
+++ b/recipes/qt4/qt-4.7.0/demos.browser.add.mediaservices.lib.patch
@@ -0,0 +1,12 @@
+Index: qt-everywhere-opensource-src-4.7.0-beta1/demos/browser/browser.pro
+===================================================================
+--- qt-everywhere-opensource-src-4.7.0-beta1.orig/demos/browser/browser.pro
++++ qt-everywhere-opensource-src-4.7.0-beta1/demos/browser/browser.pro
+@@ -1,6 +1,6 @@
+ TEMPLATE = app
+ TARGET = browser
+-QT += webkit network
++QT += webkit network mediaservices
+
+ CONFIG += qt warn_on
+ contains(QT_BUILD_PARTS, tools):!embedded: CONFIG += uitools
diff --git a/recipes/qt4/qt4-embedded_4.7.0.bb b/recipes/qt4/qt4-embedded_4.7.0.bb
new file mode 100644
index 0000000000..1cd43a664b
--- /dev/null
+++ b/recipes/qt4/qt4-embedded_4.7.0.bb
@@ -0,0 +1,14 @@
+DEFAULT_PREFERENCE = "-1"
+
+require qt4-embedded.inc
+
+PR = "${INC_PR}.0"
+
+QT_CONFIG_FLAGS_append_armv6 = " -no-neon "
+
+require qt-${PV}.inc
+
+QT_CONFIG_FLAGS += " \
+ -exceptions \
+"
+
diff --git a/recipes/qt4/qt4-tools-native-4.7.0/fix.xlib-test.libs.patch b/recipes/qt4/qt4-tools-native-4.7.0/fix.xlib-test.libs.patch
new file mode 100644
index 0000000000..d7613033df
--- /dev/null
+++ b/recipes/qt4/qt4-tools-native-4.7.0/fix.xlib-test.libs.patch
@@ -0,0 +1,9 @@
+Index: qt-everywhere-opensource-src-4.7.0-beta1/config.tests/x11/xlib/xlib.pro
+===================================================================
+--- qt-everywhere-opensource-src-4.7.0-beta1.orig/config.tests/x11/xlib/xlib.pro
++++ qt-everywhere-opensource-src-4.7.0-beta1/config.tests/x11/xlib/xlib.pro
+@@ -1,3 +1,4 @@
+ CONFIG += x11
+ CONFIG -= qt
+ SOURCES = xlib.cpp
++LIBS += -lXau -lXdmcp
diff --git a/recipes/qt4/qt4-tools-native_4.7.0.bb b/recipes/qt4/qt4-tools-native_4.7.0.bb
new file mode 100644
index 0000000000..95fbc24652
--- /dev/null
+++ b/recipes/qt4/qt4-tools-native_4.7.0.bb
@@ -0,0 +1,23 @@
+DEFAULT_PREFERENCE = "-1"
+
+require qt4-tools-native.inc
+LICENSE = "LGPLv2.1 GPLv3"
+
+DEPENDS += "libxau-native libxdmcp-native"
+
+PR = "${INC_PR}.0"
+
+SRC_URI = "ftp://ftp.trolltech.com/qt/source/qt-everywhere-opensource-src-${PV}.tar.gz \
+ file://fix.xlib-test.libs.patch \
+ file://qt-config.patch \
+ file://g++.conf \
+ file://linux.conf"
+S = "${WORKDIR}/qt-everywhere-opensource-src-${PV}"
+
+EXTRA_OECONF += " -no-fast -silent -no-rpath"
+
+TOBUILD := "src/tools/bootstrap ${TOBUILD}"
+
+SRC_URI[md5sum] = "3a2f25b9b115037277f4fb759194a7a5"
+SRC_URI[sha256sum] = "e05256d560ca7d674cd4310bb791748900ad14ad662cbfe22b6d72ada43e7955"
+
diff --git a/recipes/qt4/qt4-x11-free_4.7.0.bb b/recipes/qt4/qt4-x11-free_4.7.0.bb
new file mode 100644
index 0000000000..79a765ed74
--- /dev/null
+++ b/recipes/qt4/qt4-x11-free_4.7.0.bb
@@ -0,0 +1,15 @@
+DEFAULT_PREFERENCE = "-1"
+
+require qt4-x11-free.inc
+
+PR = "${INC_PR}.0"
+
+QT_CONFIG_FLAGS_append_armv6 = " -no-neon "
+
+require qt-${PV}.inc
+
+QT_CONFIG_FLAGS += " \
+ -no-embedded \
+ -xrandr \
+ -x11"
+