aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorRobert Schuster <robertschuster@fsfe.org>2009-09-18 14:42:18 +0200
committerRobert Schuster <robertschuster@fsfe.org>2009-09-18 14:42:18 +0200
commit3b6557acfeac7fdf55c5938ae1ecf9de597f0d8d (patch)
tree9cdf93808faefc8a51ee98a1bb73b5f300a198eb /recipes
parenta80a0cb84d7b898d4fd8d560136b28f526915327 (diff)
downloadopenembedded-3b6557acfeac7fdf55c5938ae1ecf9de597f0d8d.tar.gz
log4j 1.2.15: New recipe (from Jalimo SVN).
log4j-native 1.2.15: Dito.
Diffstat (limited to 'recipes')
-rw-r--r--recipes/jakarta-libs/log4j1.2-native_1.2.15.bb6
-rw-r--r--recipes/jakarta-libs/log4j1.2_1.2.15.bb27
2 files changed, 33 insertions, 0 deletions
diff --git a/recipes/jakarta-libs/log4j1.2-native_1.2.15.bb b/recipes/jakarta-libs/log4j1.2-native_1.2.15.bb
new file mode 100644
index 0000000000..49ccee1ff3
--- /dev/null
+++ b/recipes/jakarta-libs/log4j1.2-native_1.2.15.bb
@@ -0,0 +1,6 @@
+require log4j1.2_${PV}.bb
+
+inherit java-native
+
+DEPENDS = "fastjar-native gnumail-native gnujaf-native"
+
diff --git a/recipes/jakarta-libs/log4j1.2_1.2.15.bb b/recipes/jakarta-libs/log4j1.2_1.2.15.bb
new file mode 100644
index 0000000000..cb83afd514
--- /dev/null
+++ b/recipes/jakarta-libs/log4j1.2_1.2.15.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "Java library to help the programmer output log statements to a variety of output targets"
+LICENSE = "AL2.0"
+AUTHOR = "Apache Software Foundation"
+
+SRC_URI = "http://archive.apache.org/dist/logging/log4j/${PV}/apache-log4j-${PV}.tar.gz"
+
+inherit java-library
+
+S = "${WORKDIR}/apache-log4j-${PV}"
+
+DEPENDS = "fastjar-native gnumail gnujaf"
+
+JARFILENAME = "log4j-${PV}.jar"
+ALTJARFILENAMES = "log4j-1.2.jar log4j1.2.jar"
+
+do_compile() {
+ mkdir -p build
+
+ oe_makeclasspath cp -s activation gnumail
+
+ # Built everything but the JMS and JMX classes (like in Debian)
+ javac -sourcepath src/main/java -cp $cp -d build `find src/main/java -name "*.java" -and -not \( -iwholename "*jms*" -or -iwholename "*jmx*" \)`
+
+ cp -r src/main/resources/* build/
+
+ fastjar -C build -c -f ${JARFILENAME} .
+}