aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorRobert Schuster <robertschuster@fsfe.org>2009-09-18 14:32:58 +0200
committerRobert Schuster <robertschuster@fsfe.org>2009-09-18 14:32:58 +0200
commit41f689d2e82499b2cabd8808726335f80e38522f (patch)
treed5cb8057d1d6898a3848343812e0c9a5ba74af0e /recipes
parentf807b0604d74e14b46eb9b36ba317dd411639be5 (diff)
downloadopenembedded-41f689d2e82499b2cabd8808726335f80e38522f.tar.gz
icommand-bluez 0.7: New recipe (from Jalimo SVN).
Diffstat (limited to 'recipes')
-rw-r--r--recipes/icommand/files/makefile.patch42
-rw-r--r--recipes/icommand/icommand-bluez_0.7.bb34
2 files changed, 76 insertions, 0 deletions
diff --git a/recipes/icommand/files/makefile.patch b/recipes/icommand/files/makefile.patch
new file mode 100644
index 0000000000..3377f461f1
--- /dev/null
+++ b/recipes/icommand/files/makefile.patch
@@ -0,0 +1,42 @@
+Index: Release/makefile
+===================================================================
+--- Release.orig/makefile 2008-02-21 14:39:13.000000000 +0100
++++ Release/makefile 2008-02-21 15:31:48.000000000 +0100
+@@ -4,6 +4,8 @@
+
+ -include ../makefile.init
+
++CC?=gcc
++
+ RM := rm -rf
+
+ # All of the sources participating in the build are defined here
+@@ -28,7 +30,7 @@
+ libicmdbluez.so: $(OBJS) $(USER_OBJS)
+ @echo 'Building target: $@'
+ @echo 'Invoking: GCC C Linker'
+- gcc -shared -o"libicmdbluez.so" $(OBJS) $(USER_OBJS) $(LIBS)
++ $(CC) $(LDFLAGS) -shared -o"libicmdbluez.so" $(OBJS) $(USER_OBJS) $(LIBS)
+ @echo 'Finished building target: $@'
+ @echo ' '
+
+Index: Release/subdir.mk
+===================================================================
+--- Release.orig/subdir.mk 2008-02-21 14:39:13.000000000 +0100
++++ Release/subdir.mk 2008-02-21 15:30:36.000000000 +0100
+@@ -12,12 +12,14 @@
+ C_DEPS += \
+ ./icmdbluez.d
+
++CC?=gcc
++
+
+ # Each subdirectory must supply rules for building sources it contributes
+ %.o: ../%.c
+ @echo 'Building file: $<'
+ @echo 'Invoking: GCC C Compiler'
+- gcc -I/usr/include/bluetooth -I/usr/lib/jvm/java-6-sun/include -I/usr/lib/jvm/java-6-sun/include/linux -O3 -Wall -c -fmessage-length=0 -MMD -MP -MF"$(@:%.o=%.d)" -MT"$(@:%.o=%.d)" -o"$@" "$<"
++ $(CC) $(CFLAGS) $(INCLUDES) -c -fmessage-length=0 -MMD -MP -MF"$(@:%.o=%.d)" -MT"$(@:%.o=%.d)" -o"$@" "$<"
+ @echo 'Finished building: $<'
+ @echo ' '
+
diff --git a/recipes/icommand/icommand-bluez_0.7.bb b/recipes/icommand/icommand-bluez_0.7.bb
new file mode 100644
index 0000000000..70d78f02d0
--- /dev/null
+++ b/recipes/icommand/icommand-bluez_0.7.bb
@@ -0,0 +1,34 @@
+DESCRIPTION = "iCommand bluez binding"
+LICENSE = "LGPL"
+SECTION = "libs"
+HOMEPAGE = "http://sourceforge.net/projects/nxtcommand/"
+AUTHOR = "Brian Bagnall <bbagnall at users.sourceforge.net>"
+
+inherit java
+
+SRC_URI = "\
+ svn://nxtcommand.svn.sourceforge.net/svnroot/nxtcommand;module=icommand-projects/trunk/icommand-bluez;rev=134;proto=https \
+ file://makefile.patch;patch=1 \
+ "
+
+DEPENDS = "bluez-libs"
+
+S = "${WORKDIR}/icommand-projects/trunk/icommand-bluez/Release"
+
+do_compile() {
+ oe_runmake -f makefile clean
+ oe_runmake -f makefile all \
+ INCLUDES="-I${STAGING_INCDIR}/classpath " \
+ LIBS="-lbluetooth"
+}
+
+do_install() {
+ oe_libinstall -so libicmdbluez ${D}${libdir_jni}
+}
+
+PACKAGES = "${PN}-jni ${PN}-jni-dbg"
+
+RDEPENDS_${PN}-jni = "bluez-libs"
+
+FILES_${PN}-jni = "${libdir_jni}/lib*.so"
+FILES_${PN}-jni-dbg = "${libdir_jni}/.debug/lib*.so"