aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorRobert Schuster <robertschuster@fsfe.org>2009-09-18 14:24:59 +0200
committerRobert Schuster <robertschuster@fsfe.org>2009-09-18 14:24:59 +0200
commit544342567663c18e802dcfdbdcb12fc1d75bf803 (patch)
treedd8c6b24736aab2d7e405f9a66572d9be4cf96d1 /recipes
parent8987e7ad7ddb8175029361a993b816b9a7cc9fdb (diff)
downloadopenembedded-544342567663c18e802dcfdbdcb12fc1d75bf803.tar.gz
rhino 1.7r1: New recipe (from Jalimo SVN).
rhino-native 1.7r1: Dito.
Diffstat (limited to 'recipes')
-rw-r--r--recipes/mozilla/rhino-native_1.7r1.bb5
-rw-r--r--recipes/mozilla/rhino/rhino8
-rw-r--r--recipes/mozilla/rhino/rhino-jsc8
-rw-r--r--recipes/mozilla/rhino_1.7r1.bb42
4 files changed, 63 insertions, 0 deletions
diff --git a/recipes/mozilla/rhino-native_1.7r1.bb b/recipes/mozilla/rhino-native_1.7r1.bb
new file mode 100644
index 0000000000..1b563603f8
--- /dev/null
+++ b/recipes/mozilla/rhino-native_1.7r1.bb
@@ -0,0 +1,5 @@
+require rhino_${PV}.bb
+
+inherit java-native
+
+RDEPENDS_${PN} = ""
diff --git a/recipes/mozilla/rhino/rhino b/recipes/mozilla/rhino/rhino
new file mode 100644
index 0000000000..e2f87f690a
--- /dev/null
+++ b/recipes/mozilla/rhino/rhino
@@ -0,0 +1,8 @@
+#!/bin/sh
+
+if [ ! $JAVA ]; then
+ JAVA=java
+fi
+
+$JAVA -jar /usr/share/java/js.jar $@
+
diff --git a/recipes/mozilla/rhino/rhino-jsc b/recipes/mozilla/rhino/rhino-jsc
new file mode 100644
index 0000000000..d5f50e8451
--- /dev/null
+++ b/recipes/mozilla/rhino/rhino-jsc
@@ -0,0 +1,8 @@
+#!/bin/sh
+
+if [ ! $JAVA ]; then
+ JAVA=java
+fi
+
+$JAVA -cp .:/usr/share/java/js.jar org.mozilla.javascript.tools.jsc.Main $@
+
diff --git a/recipes/mozilla/rhino_1.7r1.bb b/recipes/mozilla/rhino_1.7r1.bb
new file mode 100644
index 0000000000..e9268704d9
--- /dev/null
+++ b/recipes/mozilla/rhino_1.7r1.bb
@@ -0,0 +1,42 @@
+DESCRIPTION = "Lexical analyzer generator for Java"
+
+LICENSE = "GPL MPL"
+
+DEPENDS = "fastjar-native"
+
+inherit java-library
+
+SRC_URI = "\
+ ftp://ftp.mozilla.org/pub/mozilla.org/js/rhino1_7R1.zip \
+ file://rhino \
+ file://rhino-jsc \
+ "
+
+S = "${WORKDIR}/rhino1_7R1"
+
+PACKAGES = "${JPN} rhino"
+
+FILES_${PN} = "${bindir}/rhino ${bindir}/rhino-jsc"
+RDEPENDS_${PN} = "java2-runtime ${JPN}"
+
+do_compile() {
+ mkdir -p build
+
+ # Compatibility fix for jamvm which has non-genericised
+ # java.lang classes. :(
+ bcp_arg="-bootclasspath ${STAGING_DATADIR_NATIVE}/classpath/glibj.zip"
+
+ javac $bcp_arg -source 1.5 -sourcepath src -d build `find src -name "*.java"`
+
+ mkdir -p build/org/mozilla/javascript/resources
+ cp src/org/mozilla/javascript/resources/*.properties build/org/mozilla/javascript/resources
+
+ fastjar -m ${S}/src/manifest -C build -c -f ${JARFILENAME} .
+}
+
+do_install_append() {
+ install -d ${D}${bindir}
+
+ install -m 0755 ${WORKDIR}/rhino ${D}${bindir}
+ install -m 0755 ${WORKDIR}/rhino-jsc ${D}${bindir}
+}