aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-09-21 08:36:21 +0200
committerKoen Kooi <koen@openembedded.org>2009-09-21 08:36:21 +0200
commit6bc94b62f423e91dd7f3ead4b61bb7ee9608c1f1 (patch)
tree2e26d6e402cc7033d27f7647604d180e55f3eef2 /recipes
parentb4926ef1add65f61626ccffe715f535dc97bff4f (diff)
downloadopenembedded-6bc94b62f423e91dd7f3ead4b61bb7ee9608c1f1.tar.gz
rt3070: add driver for the ralink 3070 sb wifi module, original recipe from omap3-touchbook overlay
* includes changes from http://bugzilla.alwaysinnovating.com/show_bug.cgi?id=8
Diffstat (limited to 'recipes')
-rw-r--r--recipes/ralink/files/config.patch20
-rw-r--r--recipes/ralink/files/makefile.patch11
-rw-r--r--recipes/ralink/rt3070_2.1.1.0.bb18
3 files changed, 49 insertions, 0 deletions
diff --git a/recipes/ralink/files/config.patch b/recipes/ralink/files/config.patch
new file mode 100644
index 0000000000..89a26caea0
--- /dev/null
+++ b/recipes/ralink/files/config.patch
@@ -0,0 +1,20 @@
+--- 2009_0525_RT3070_Linux_STA_v2.1.1.0/os/linux/config.mk 2009-05-20 20:33:56.000000000 -0700
++++ 2009_0525_RT3070_Linux_STA_v2.1.1.0/os/linux/config.mk 2009-08-22 19:42:55.000000000 -0700
+@@ -4,15 +4,11 @@
+ # Support 28xx QA ATE function
+ HAS_28xx_QA=n
+
+-#ifdef WPA_SUPPLICANT_SUPPORT
+ # Support Wpa_Supplicant
+-HAS_WPA_SUPPLICANT=n
+-#endif // WPA_SUPPLICANT_SUPPORT //
++HAS_WPA_SUPPLICANT=y
+
+-#ifdef NATIVE_WPA_SUPPLICANT_SUPPORT
+ # Support Native WpaSupplicant for Network Maganger
+-HAS_NATIVE_WPA_SUPPLICANT_SUPPORT=n
+-#endif // NATIVE_WPA_SUPPLICANT_SUPPORT //
++HAS_NATIVE_WPA_SUPPLICANT_SUPPORT=y
+
+ #Support Net interface block while Tx-Sw queue full
+ HAS_BLOCK_NET_IF=n
diff --git a/recipes/ralink/files/makefile.patch b/recipes/ralink/files/makefile.patch
new file mode 100644
index 0000000000..ca949023cf
--- /dev/null
+++ b/recipes/ralink/files/makefile.patch
@@ -0,0 +1,11 @@
+--- 2009_0525_RT3070_Linux_STA_v2.1.1.0/Makefile 2009-05-20 20:33:56.000000000 -0700
++++ 2009_0525_RT3070_Linux_STA_v2.1.1.0/Makefile 2009-06-23 19:57:21.000000000 -0700
+@@ -153,7 +153,7 @@
+ else
+ cp -f os/linux/Makefile.6 $(RT28xx_DIR)/os/linux/Makefile
+ make -C $(LINUX_SRC) SUBDIRS=$(RT28xx_DIR)/os/linux modules
+- cp -f $(RT28xx_DIR)/os/linux/rt$(CHIPSET)sta.ko /tftpboot
++# cp -f $(RT28xx_DIR)/os/linux/rt$(CHIPSET)sta.ko /tftpboot
+ endif
+
+ clean:
diff --git a/recipes/ralink/rt3070_2.1.1.0.bb b/recipes/ralink/rt3070_2.1.1.0.bb
new file mode 100644
index 0000000000..d7709fa91d
--- /dev/null
+++ b/recipes/ralink/rt3070_2.1.1.0.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "Ralink 3070"
+LICENSE = "GPLv2"
+
+inherit module
+
+SRC_URI = "http://www.ralinktech.com.tw/data/drivers/2009_0525_RT3070_Linux_STA_v${PV}.tar.bz2 \
+ file://makefile.patch;patch=1 \
+ file://config.patch;patch=1 \
+"
+
+EXTRA_OEMAKE = "LINUX_SRC=${STAGING_KERNEL_DIR}"
+
+S = "${WORKDIR}/2009_0525_RT3070_Linux_STA_v${PV}"
+
+do_install() {
+ mkdir -p ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/net/wireless
+ cp ${S}/os/linux/rt3070sta.ko ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/net/wireless
+}