aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorRobert Schuster <robertschuster@fsfe.org>2009-09-18 14:22:30 +0200
committerRobert Schuster <robertschuster@fsfe.org>2009-09-18 14:22:30 +0200
commit8987e7ad7ddb8175029361a993b816b9a7cc9fdb (patch)
tree3645d8df515dc02a49cc808f05cd945d43b37656 /recipes
parent7b686c7c52bd214593ed21f3715cb5656c74916b (diff)
downloadopenembedded-8987e7ad7ddb8175029361a993b816b9a7cc9fdb.tar.gz
junit 3.8.2: New recipe (from Jalimo SVN).
junit-native 3.8.2: Dito. junit4 4.3.1: Dito. junit4-native 4.3.1: Dito.
Diffstat (limited to 'recipes')
-rw-r--r--recipes/junit/junit-native_3.8.2.bb4
-rw-r--r--recipes/junit/junit4-native_4.3.1.bb4
-rw-r--r--recipes/junit/junit4_4.3.1.bb23
-rw-r--r--recipes/junit/junit_3.8.2.bb34
4 files changed, 65 insertions, 0 deletions
diff --git a/recipes/junit/junit-native_3.8.2.bb b/recipes/junit/junit-native_3.8.2.bb
new file mode 100644
index 0000000000..305351f058
--- /dev/null
+++ b/recipes/junit/junit-native_3.8.2.bb
@@ -0,0 +1,4 @@
+require junit_${PV}.bb
+
+inherit java-native
+
diff --git a/recipes/junit/junit4-native_4.3.1.bb b/recipes/junit/junit4-native_4.3.1.bb
new file mode 100644
index 0000000000..eb843a9ab5
--- /dev/null
+++ b/recipes/junit/junit4-native_4.3.1.bb
@@ -0,0 +1,4 @@
+require junit4_${PV}.bb
+
+inherit java-native
+
diff --git a/recipes/junit/junit4_4.3.1.bb b/recipes/junit/junit4_4.3.1.bb
new file mode 100644
index 0000000000..2733aff2e1
--- /dev/null
+++ b/recipes/junit/junit4_4.3.1.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "JUnit is a testing framework for Java"
+LICENSES = "CPL"
+AUTHOR = "junit.org"
+HOMEPAGE = "http://www.junit.org"
+
+SRC_URI = "http://downloads.sourceforge.net/junit/junit-${PV}-src.jar"
+
+S = "${WORKDIR}"
+
+inherit java-library
+
+DEPENDS = "fastjar-native"
+
+do_compile() {
+ mkdir -p build
+
+ # Workaround for jamvm.
+ bcp=${STAGING_DATADIR_NATIVE}/classpath/glibj.zip
+
+ javac -source 5.0 -bootclasspath $bcp -sourcepath . -d build `find . -name "*.java"`
+
+ fastjar -C build -c -f ${JARFILENAME} .
+}
diff --git a/recipes/junit/junit_3.8.2.bb b/recipes/junit/junit_3.8.2.bb
new file mode 100644
index 0000000000..2ba54b63a7
--- /dev/null
+++ b/recipes/junit/junit_3.8.2.bb
@@ -0,0 +1,34 @@
+DESCRIPTION = "JUnit is a testing framework for Java"
+LICENSES = "CPL"
+AUTHOR = "junit.org"
+HOMEPAGE = "http://www.junit.org"
+
+SRC_URI = "http://downloads.sourceforge.net/junit/junit${PV}.zip"
+
+S = "${WORKDIR}/junit${PV}"
+
+inherit java-library
+
+DEPENDS = "fastjar-native"
+
+do_unpackpost() {
+ mkdir -p src
+
+ # Prevent deletion by do_removebinaries.
+ mv src.jar src.zip
+
+ unzip src.zip -d src
+}
+
+addtask unpackpost before do_removebinaries after do_unpack
+
+do_compile() {
+ mkdir -p build
+
+ # Workaround for jamvm.
+ bcp=${STAGING_DATADIR_NATIVE}/classpath/glibj.zip
+
+ javac -bootclasspath $bcp -sourcepath src -d build `find src -name "*.java"`
+
+ fastjar -C build -c -f ${JARFILENAME} .
+}