aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorLeon Woestenberg <leon@sidebranch.com>2009-11-24 13:30:12 +0100
committerLeon Woestenberg <leon@sidebranch.com>2009-11-24 13:49:21 +0100
commit8de4e9bed15fd5f40be5aa46b46001e8ba7be1eb (patch)
treed354e7f6f7cf01c4172c8c0a0b790459df5715c4 /recipes
parent42e9dea4ae7a26a3682adc31161ddd8c35faf542 (diff)
downloadopenembedded-8de4e9bed15fd5f40be5aa46b46001e8ba7be1eb.tar.gz
binutils-nios2-2.15: Use binutils.inc.
Signed-off-by: Leon Woestenberg <leon@sidebranch.com>
Diffstat (limited to 'recipes')
-rw-r--r--recipes/binutils/binutils_nios2-2.15.bb126
1 files changed, 4 insertions, 122 deletions
diff --git a/recipes/binutils/binutils_nios2-2.15.bb b/recipes/binutils/binutils_nios2-2.15.bb
index 436d33de96..559f774d11 100644
--- a/recipes/binutils/binutils_nios2-2.15.bb
+++ b/recipes/binutils/binutils_nios2-2.15.bb
@@ -1,45 +1,11 @@
-DESCRIPTION = "A GNU collection of binary utilities"
-HOMEPAGE = "http://www.gnu.org/software/binutils/"
-SECTION = "devel"
-LICENSE = "GPL"
-PR = "r5"
+INC_PR = "r2"
+PR = "${INC_PR}.1"
-inherit autotools gettext
+require binutils.inc
+LICENSE = "GPLv3"
FILESPATHPKG =. "binutils-2.15.94.0.1:"
-PACKAGES += "${PN}-symlinks"
-
-FILES_${PN} = " \
- ${bindir}/${TARGET_PREFIX}* \
- ${libdir}/lib*-*.so \
- ${prefix}/${TARGET_SYS}/bin/*"
-
-FILES_${PN}-dev = " \
- ${includedir} \
- ${libdir}/*.a \
- ${libdir}/*.la \
- ${libdir}/libbfd.so \
- ${libdir}/libopcodes.so"
-
-FILES_${PN}-symlinks = " \
- ${bindir}/addr2line \
- ${bindir}/ar \
- ${bindir}/as \
- ${bindir}/c++filt \
- ${bindir}/gprof \
- ${bindir}/ld \
- ${bindir}/nm \
- ${bindir}/objcopy \
- ${bindir}/objdump \
- ${bindir}/ranlib \
- ${bindir}/readelf \
- ${bindir}/size \
- ${bindir}/strings \
- ${bindir}/strip"
-
-#SRC_URI = "http://127.0.0.1/binutils-2.15+nios2.tbz"
-#S = "${WORKDIR}/binutils"
SRCREV = "49396897843c932623b775168c5e6e1f2a43c3c8"
@@ -59,87 +25,3 @@ SRC_URI += "\
S = "${WORKDIR}/git"
-
-B = "${S}/build.${HOST_SYS}.${TARGET_SYS}"
-
-EXTRA_OECONF = "--program-prefix=${TARGET_PREFIX} \
- "
-
-# This is necessary due to a bug in the binutils Makefiles
-EXTRA_OEMAKE = "configure-build-libiberty all"
-
-export AR = "${HOST_PREFIX}ar"
-export AS = "${HOST_PREFIX}as"
-export LD = "${HOST_PREFIX}ld"
-export NM = "${HOST_PREFIX}nm"
-export RANLIB = "${HOST_PREFIX}ranlib"
-export OBJCOPY = "${HOST_PREFIX}objcopy"
-export OBJDUMP = "${HOST_PREFIX}objdump"
-
-export AR_FOR_TARGET = "${TARGET_PREFIX}ar"
-export AS_FOR_TARGET = "${TARGET_PREFIX}as"
-export LD_FOR_TARGET = "${TARGET_PREFIX}ld"
-export NM_FOR_TARGET = "${TARGET_PREFIX}nm"
-export RANLIB_FOR_TARGET = "${TARGET_PREFIX}ranlib"
-
-export CC_FOR_HOST = "${CCACHE}${HOST_PREFIX}gcc ${HOST_CC_ARCH}"
-export CXX_FOR_HOST = "${CCACHE}${HOST_PREFIX}gcc ${HOST_CC_ARCH}"
-
-export CC_FOR_BUILD = "${BUILD_CC}"
-export CPP_FOR_BUILD = "${BUILD_CPP}"
-export CFLAGS_FOR_BUILD = "${BUILD_CFLAGS}"
-
-export CC = "${CCACHE}${HOST_PREFIX}gcc ${HOST_CC_ARCH}"
-
-do_configure () {
- (cd ${S}; gnu-configize) || die "Failed to run gnu-configize"
- oe_runconf
-}
-
-do_stage_append () {
- oe_libinstall -a -C opcodes libopcodes ${target_libdir}/
- oe_libinstall -a -C libiberty libiberty ${target_libdir}/
- oe_libinstall -a -C bfd libbfd ${target_libdir}/
- install -d ${target_includedir}
- install -m 0644 ${S}/include/ansidecl.h ${target_includedir}/
- install -m 0644 ${S}/include/libiberty.h ${target_includedir}
-
- install -m 0644 ${S}/include/dis-asm.h ${target_includedir}
- install -m 0644 ${S}/include/symcat.h ${target_includedir}
- install -m 0644 ${S}/include/bfdlink.h ${target_includedir}
- install -m 0644 bfd/bfd.h ${target_includedir}
-}
-
-do_install () {
- autotools_do_install
-
- # We don't really need these, so we'll remove them...
- rm -rf ${D}${libdir}/ldscripts
-
- # Fix the /usr/${TARGET_SYS}/bin/* links
- for l in ${D}${prefix}/${TARGET_SYS}/bin/*; do
- rm -f $l
- ln -sf `echo ${prefix}/${TARGET_SYS}/bin \
- | tr -s / \
- | sed -e 's,^/,,' -e 's,[^/]*,..,g'`${bindir}/${TARGET_PREFIX}`basename $l` $l
- done
-
- # Install the libiberty header
- install -d ${D}${includedir}
- install -m 644 ${S}/include/ansidecl.h ${D}${includedir}
- install -m 644 ${S}/include/libiberty.h ${D}${includedir}
-
- install -m 644 ${S}/include/dis-asm.h ${D}${includedir}
- install -m 644 ${S}/include/symcat.h ${D}${includedir}
- install -m 644 ${S}/include/libiberty.h ${D}${includedir}
- install -m 644 ${S}/include/ansidecl.h ${D}${includedir}
- install -m 644 ${S}/include/bfdlink.h ${D}${includedir}
- install -m 644 bfd/bfd.h ${D}${includedir}
-
- cd ${D}${bindir}
-
- # Symlinks for ease of running these on the native target
- for p in ${TARGET_SYS}-* ; do
- ln -sf $p `echo $p | sed -e s,${TARGET_SYS}-,,`
- done
-}