aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorDavid-John Willis <John.Willis@Distant-earth.com>2009-11-18 14:44:09 +0000
committerKoen Kooi <koen@openembedded.org>2009-11-24 11:08:34 +0100
commitafa230474855aa110c5b32492dcf8d2cdc1c07e9 (patch)
treee647b145f4157b1ee03b7d8bbabde238cdd61419 /recipes
parente4e194e0976b69f98ce0e7a72f751fb70e1c14a7 (diff)
downloadopenembedded-afa230474855aa110c5b32492dcf8d2cdc1c07e9.tar.gz
blueman: Add 1.21
Diffstat (limited to 'recipes')
-rw-r--r--recipes/blueman/blueman_1.21.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/recipes/blueman/blueman_1.21.bb b/recipes/blueman/blueman_1.21.bb
new file mode 100644
index 0000000000..744c05302e
--- /dev/null
+++ b/recipes/blueman/blueman_1.21.bb
@@ -0,0 +1,31 @@
+DESCRIPTION = "GTK+ Bluetooth Manager, designed for common bluetooth tasks."
+HOMEPAGE = "http://blueman-project.org/"
+SECTION = "optional"
+
+DEPENDS = "gtk+ glib-2.0 bluez4 intltool python \
+ python-native python-pyrex \
+ startup-notification \
+"
+
+RDEPENDS = "python-dbus python-pygobject python \
+ dbus bluez4 python-pygtk obex-data-server \
+"
+
+PR = "r1"
+
+SRC_URI = "http://download.tuxfamily.org/blueman/blueman-${PV}.tar.gz"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF += "--with-no-runtime-deps-check"
+
+do_configure_prepend() {
+ sed -i "s/py_prefix=.*$/py_prefix=\"${@"${STAGING_DIR_TARGET}".replace("/","\/")}\/usr\"/" ${S}/acinclude.m4
+ sed -i "s/py_exec_prefix=.*$/py_exec_prefix=\"${@"${STAGING_DIR_TARGET}".replace("/","\/")}\/usr\"/" ${S}/acinclude.m4
+}
+
+FILES_${PN}-dbg += "${libdir}/python2.6/site-packages/.debug"
+FILES_${PN} += "${libdir} ${datadir}"
+
+BLUEZ_LIBS = "-L${libdir} -lbluetooth"
+BLUEZ_CFLAGS = "-I${includedir}"