aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorPhilip Balister <philip@balister.org>2011-10-07 09:37:31 -0400
committerPhilip Balister <philip@balister.org>2011-10-07 09:37:31 -0400
commitd61d9d2d52e71d54cf7bc11ea4d2d1272b970eac (patch)
tree7cef78b340d78df35e379687b128fb06a9431c3c /recipes
parentec0bece97f8ddebf76984e88c631d0b7974e712c (diff)
parentf6ddb0f1898640b3ed4048e0645a9927f36cb54a (diff)
downloadopenembedded-d61d9d2d52e71d54cf7bc11ea4d2d1272b970eac.tar.gz
Merge branch 'master' of git.openembedded.org:openembedded
Diffstat (limited to 'recipes')
-rw-r--r--recipes/hostap/hostap-daemon_git.bb5
-rw-r--r--recipes/imagemagick/imagemagick_6.3.5-10.bb7
-rw-r--r--recipes/imagemagick/imagemagick_6.4.4-1.bb7
-rw-r--r--recipes/iw/iw_git.bb27
-rw-r--r--recipes/wpa-supplicant/wpa-supplicant_git.bb6
5 files changed, 39 insertions, 13 deletions
diff --git a/recipes/hostap/hostap-daemon_git.bb b/recipes/hostap/hostap-daemon_git.bb
index cf0e6e9483..b8aaa02b8d 100644
--- a/recipes/hostap/hostap-daemon_git.bb
+++ b/recipes/hostap/hostap-daemon_git.bb
@@ -2,8 +2,8 @@ DESCRIPTION = "User space daemon for extended IEEE 802.11 management"
require hostap-daemon-0.7.inc
-PR = "r0"
-SRCREV = "b8fb017272ed4794339978c9fbc0e74571a44728"
+PR = "r1"
+SRCREV = "83fa07226debc2f7082b6ccd62dbb1cd47c30472"
PV = "0.7.3+0.8.0-rc"
PR_append = "gitr${SRCPV}"
FILESPATHPKG =. "hostap-daemon-git:"
@@ -23,4 +23,3 @@ do_configure() {
echo "CFLAGS += -I${STAGING_INCDIR}" >> .config
echo "LIBS += -L${STAGING_LIBDIR}" >> .config
}
-
diff --git a/recipes/imagemagick/imagemagick_6.3.5-10.bb b/recipes/imagemagick/imagemagick_6.3.5-10.bb
index 5041fd12d8..fffcc56981 100644
--- a/recipes/imagemagick/imagemagick_6.3.5-10.bb
+++ b/recipes/imagemagick/imagemagick_6.3.5-10.bb
@@ -1,8 +1,9 @@
-DESCRIPTION = "ImageMagick is an image convertion tools"
+DESCRIPTION = "ImageMagick contains image manipulation and conversion tools"
+HOMEPAGE = "http://www.imagemagick.org/"
SECTION = "console/utils"
-LICENSE = "GPL"
+LICENSE = "Apache-2.0"
DEPENDS = "tiff jpeg libpng librsvg tiff zlib"
-PR = "r9"
+PR = "r12"
SRC_URI = "ftp://ftp.nluug.nl/pub/ImageMagick/ImageMagick-${PV}.tar.bz2 \
file://PerlMagic_MakePatch;apply=yes \
diff --git a/recipes/imagemagick/imagemagick_6.4.4-1.bb b/recipes/imagemagick/imagemagick_6.4.4-1.bb
index da4f37d461..e495d368d5 100644
--- a/recipes/imagemagick/imagemagick_6.4.4-1.bb
+++ b/recipes/imagemagick/imagemagick_6.4.4-1.bb
@@ -1,10 +1,11 @@
-DESCRIPTION = "ImageMagick is an image convertion tools"
+DESCRIPTION = "ImageMagick contains image manipulation and conversion tools"
+HOMEPAGE = "http://www.imagemagick.org/"
SECTION = "console/utils"
-LICENSE = "GPL"
+LICENSE = "Apache-2.0"
# FIXME: There is much more checked libraries. All should be added or explicitly disabled to get consistent results.
DEPENDS = "lcms bzip2 jpeg libpng librsvg tiff zlib"
-PR = "r7"
+PR = "r10"
SRC_URI = "ftp://ftp.nluug.nl/pub/ImageMagick/ImageMagick-${PV}.tar.bz2 \
file://PerlMagic_MakePatch;apply=yes \
diff --git a/recipes/iw/iw_git.bb b/recipes/iw/iw_git.bb
new file mode 100644
index 0000000000..c98e1bc5f7
--- /dev/null
+++ b/recipes/iw/iw_git.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "nl80211 based CLI configuration utility for wireless devices"
+HOMEPAGE = "http://linuxwireless.org/en/users/Documentation/iw"
+SECTION = "base"
+PRIORITY = "optional"
+LICENSE = "BSD"
+
+SRCREV = "0a236ef5f8e4ba7218aac7d0cdacf45673d5b35c"
+PR = "r0"
+PV = "0.9.22"
+PR_append = "+gitr${SRCPV}"
+
+DEPENDS = "libnl pkgconfig"
+
+SRC_URI = " \
+ git://git.sipsolutions.net/iw.git;protocol=git \
+ "
+CFLAGS += "-DCONFIG_LIBNL20"
+
+S = "${WORKDIR}/git/"
+
+do_compile() {
+ oe_runmake
+}
+
+do_install() {
+ oe_runmake DESTDIR=${D} install
+}
diff --git a/recipes/wpa-supplicant/wpa-supplicant_git.bb b/recipes/wpa-supplicant/wpa-supplicant_git.bb
index 8f6971e0d6..7525144985 100644
--- a/recipes/wpa-supplicant/wpa-supplicant_git.bb
+++ b/recipes/wpa-supplicant/wpa-supplicant_git.bb
@@ -1,7 +1,7 @@
require wpa-supplicant-0.7.inc
-SRCREV = "b8fb017272ed4794339978c9fbc0e74571a44728"
-PR = "r0"
+SRCREV = "83fa07226debc2f7082b6ccd62dbb1cd47c30472"
+PR = "r1"
PV = "0.7.3+0.8.0-rc"
PR_append = "+gitr${SRCPV}"
FILESPATHPKG =. "wpa-supplicant-git:"
@@ -28,5 +28,3 @@ do_configure () {
echo "CFLAGS += -I${STAGING_INCDIR}/madwifi-ng" >> .config
fi
}
-
-