aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-05-21 23:26:55 +0200
committerKoen Kooi <koen@openembedded.org>2009-05-21 23:26:55 +0200
commit23516c5a60692fc36967a2a0991df101638edceb (patch)
tree8e3ec1c4f5e422c2356ebf8c2dd42cba68624b03 /recipes
parent2a20dd7eef485b7e024c20d701dec46e63638b38 (diff)
parent977b935c7a06637fb3eaa151a57a6870043e2c93 (diff)
downloadopenembedded-23516c5a60692fc36967a2a0991df101638edceb.tar.gz
Merge branch 'org.openembedded.dev' of git@git.openembedded.org:openembedded into org.openembedded.dev
Diffstat (limited to 'recipes')
-rw-r--r--recipes/pwlib/pwlib.inc31
-rw-r--r--recipes/pwlib/pwlib_1.5.2.bb34
-rw-r--r--recipes/pwlib/pwlib_1.6.6.4.bb4
3 files changed, 39 insertions, 30 deletions
diff --git a/recipes/pwlib/pwlib.inc b/recipes/pwlib/pwlib.inc
new file mode 100644
index 0000000000..981becf42f
--- /dev/null
+++ b/recipes/pwlib/pwlib.inc
@@ -0,0 +1,31 @@
+HOMEPAGE = "http://openh323.sourceforge.net/"
+DESCRIPTION = "Portable Text and GUI C/C++ Class Libarary."
+LICENSE = "GPL"
+DEPENDS = "openssl openldap"
+
+INC_PR = "r1"
+
+# Somebody should teach these people about naming tarballs ;-)
+MIN_VER ?= "1"
+SHRT_VER = "${@bb.data.getVar('PV',d,1).split('.')[0]}_${@bb.data.getVar('PV',d,1).split('.')[1]}_${@bb.data.getVar('PV',d,1).split('.')[1]}"
+SRC_URI = "http://www.voxgratia.org/releases/${PN}-v1_${SHRT_VER}-${MIN_VER}src.tar.gz"
+
+inherit autotools
+
+EXTRA_OECONF="--enable-ipv6 --disable-sasl --disable-sdl \
+ --disable-video --enable-plugins --with-plugins=oss"
+
+# Use openSSL
+
+export OPENSSLFLAG="1"
+export OPENSSLDIR="${STAGING_LIBDIR}"
+export OPENSSLLIBS="-lssl -lcrypt"
+export MACHTYPE="x86"
+export OSTYPE="linux"
+export OSRELEASE="openembedded"
+
+export CPLUS="${CXX}"
+
+do_compile() {
+ oe_runmake opt
+}
diff --git a/recipes/pwlib/pwlib_1.5.2.bb b/recipes/pwlib/pwlib_1.5.2.bb
index a4ced1f35c..0963a82ba2 100644
--- a/recipes/pwlib/pwlib_1.5.2.bb
+++ b/recipes/pwlib/pwlib_1.5.2.bb
@@ -1,32 +1,6 @@
-# pwlib .bb build file
-# Copyright (C) 2006, Advanced Micro Devices, Inc. All Rights Reserved
-# Released under the MIT license (see /COPYING)
+require pwlib.inc
-HOMEPAGE="http://www.openh323.org/docs/PWLib/"
-DESCRIPTION="Portable Text and GUI C/C++ Class Libarary."
-LICENSE = "GPL"
+PR = "${INC_PR}.1"
-SRC_URI="http://www.openh323.org/bin/${PN}_${PV}.tar.gz"
-DEPENDS="openssl openldap"
-
-inherit autotools
-
-EXTRA_OECONF="--enable-ipv6 --disable-sasl --disable-sdl \
- --disable-video --enable-plugins --with-plugins=oss"
-
-S="${WORKDIR}/${PN}"
-
-# Use openSSL
-
-export OPENSSLFLAG="1"
-export OPENSSLDIR="${STAGING_LIBDIR}"
-export OPENSSLLIBS="-lssl -lcrypt"
-export MACHTYPE="x86"
-export OSTYPE="linux"
-export OSRELEASE="openembedded"
-
-export CPLUS="${CXX}"
-
-do_compile() {
- oe_runmake opt
-}
+#seems like this very old source has vanished upstream
+SRC_URI = "http://www.angstrom-distribution.org/unstable/sources/pwlib_1.5.2.tar.gz"
diff --git a/recipes/pwlib/pwlib_1.6.6.4.bb b/recipes/pwlib/pwlib_1.6.6.4.bb
index c41400c001..fdadb359e7 100644
--- a/recipes/pwlib/pwlib_1.6.6.4.bb
+++ b/recipes/pwlib/pwlib_1.6.6.4.bb
@@ -1,3 +1,7 @@
+# status as of 2009/05/21: This particular bb file is broken beyond what I
+# (Laibsch) care to fix. If you fix it, please base your changes on top
+# of pwlib.inc
+
# pwlib .bb build file
# Copyright (C) 2006, Advanced Micro Devices, Inc. All Rights Reserved
# Released under the MIT license (see /COPYING)