aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorMartin Dietze <martin@the-little-red-haired-girl.org>2009-05-23 13:31:27 +0200
committerMartin Dietze <mdietze@gmail.com>2013-03-02 17:26:14 +0100
commit63d71716375a814fbd2ecdadd7849a602a5f2175 (patch)
treeb0e3d1a61d36392db346673303eeca7684588c06 /recipes
parent9ab75c72fb6497cd5e96b5ba011114db0db5007c (diff)
downloadopenembedded-63d71716375a814fbd2ecdadd7849a602a5f2175.tar.gz
rrdtool: fixed gcc options clashing with gcc 3 for nylon, refined package definition for insane.bbclass * the gcc option `-Wdeclaration-after-statement' broke the gcc 3 build, this is fixed now for nylon * the package definition ${libdir}/perl broke the build due to QA problems, this is now replaced by the list of files actually installed
Diffstat (limited to 'recipes')
-rw-r--r--recipes/rrdtool/rrdtool_1.0.49.bb9
1 files changed, 7 insertions, 2 deletions
diff --git a/recipes/rrdtool/rrdtool_1.0.49.bb b/recipes/rrdtool/rrdtool_1.0.49.bb
index 11968ea609..f4216487df 100644
--- a/recipes/rrdtool/rrdtool_1.0.49.bb
+++ b/recipes/rrdtool/rrdtool_1.0.49.bb
@@ -5,13 +5,17 @@ LICENSE = "GPLv2"
DEPENDS = "libpng zlib"
DEPENDS_rddtool-perl = "perl-module-lib perl-module-dynaloader"
PR = "r2"
-SRC_URI = "http://oss.oetiker.ch/rrdtool/pub/rrdtool-1.0.x/rdtool-${PV}.tar.gz \
+SRC_URI = "http://oss.oetiker.ch/rrdtool/pub/rrdtool-1.0.x/rrdtool-${PV}.tar.gz \
file://perl-make-options.diff;patch=1;pnum=0"
inherit autotools
EXTRA_OECONF = "--enable-shared --enable-local-libpng --enable-local-zlib --program-prefix=''"
+do_configure_append_nylon() {
+ perl -pi -e 's/-Wdeclaration-after-statement //g' ${S}/perl-shared/Makefile
+}
+
do_install_append() {
install -d ${D}${docdir}/rrdtool/
mv ${D}/usr/html ${D}${docdir}/rrdtool/
@@ -24,4 +28,5 @@ do_stage () {
autotools_stage_all
}
-FILES_${PN} += "${libdir}/perl"
+FILES_${PN} += "${libdir}/perl/auto/RRDs/RRDs.bs ${libdir}/perl/auto/RRDs/RRDs.so ${libdir}/perl/RRDs.pm ${libdir}/perl/RRDp.pm"
+