aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorPhil Blundell <philb@gnu.org>2009-05-22 11:49:05 +0100
committerPhil Blundell <philb@gnu.org>2009-05-22 11:49:05 +0100
commitba76dd503d6cf6f2322196bdc30bbaf2a37ad7f5 (patch)
tree9eed43d34975c0e7b7b7814ade180666ba7e46ff /recipes
parentf924eacf0f48f8d273d9fb1f63109d6e576f5e7c (diff)
downloadopenembedded-ba76dd503d6cf6f2322196bdc30bbaf2a37ad7f5.tar.gz
bluez-libs: add 4.40, set default preference to -1 pending availability
of apps
Diffstat (limited to 'recipes')
-rw-r--r--recipes/bluez/bluez-libs/avinfo-link.patch22
-rw-r--r--recipes/bluez/bluez-libs_4.40.bb26
2 files changed, 48 insertions, 0 deletions
diff --git a/recipes/bluez/bluez-libs/avinfo-link.patch b/recipes/bluez/bluez-libs/avinfo-link.patch
new file mode 100644
index 0000000000..944a98abca
--- /dev/null
+++ b/recipes/bluez/bluez-libs/avinfo-link.patch
@@ -0,0 +1,22 @@
+--- tools/Makefile.am.old 2009-05-22 11:27:06.000000000 +0100
++++ tools/Makefile.am 2009-05-22 11:27:29.000000000 +0100
+@@ -1,8 +1,10 @@
+
+ if TOOLS
+ tools_programs = hcitool l2ping sdptool ciptool
++avinfo_programs = avinfo
+ tools_manfiles = hcitool.1 l2ping.1 sdptool.1 ciptool.1
+ else
++avinfo_programs =
+ tools_programs =
+ tools_manfiles =
+ endif
+@@ -41,7 +43,7 @@
+
+ bin_PROGRAMS = $(tools_programs) $(dfutool_programs) $(dfubabel_programs)
+
+-noinst_PROGRAMS = hcieventmask hcisecfilter ppporc avinfo $(usb_programs)
++noinst_PROGRAMS = hcieventmask hcisecfilter ppporc $(avinfo_programs) $(usb_programs)
+
+ hcieventmask_LDADD = @BLUEZ_LIBS@
+
diff --git a/recipes/bluez/bluez-libs_4.40.bb b/recipes/bluez/bluez-libs_4.40.bb
new file mode 100644
index 0000000000..578afaa5ec
--- /dev/null
+++ b/recipes/bluez/bluez-libs_4.40.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "Linux Bluetooth Stack Userland V4"
+SECTION = "libs"
+PRIORITY = "optional"
+HOMEPAGE = "http://www.bluez.org"
+LICENSE = "GPL"
+
+DEFAULT_PREFERENCE = "-1"
+
+SRC_URI = "http://www.kernel.org/pub/linux/bluetooth/bluez-${PV}.tar.gz \
+ file://avinfo-link.patch;patch=1;pnum=0"
+
+S = "${WORKDIR}/bluez-${PV}"
+
+inherit autotools_stage
+AUTOTOOLS_STAGE_PKGCONFIG = "1"
+
+EXTRA_OECONF = "\
+ --disable-tools \
+ --disable-audio \
+ --disable-network \
+ --disable-serial \
+ --disable-service \
+ --disable-usb \
+"
+
+FILES_${PN} = "${libdir}/libbluetooth.so.*"