aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorRoman I Khimov <khimov@altell.ru>2009-04-15 15:48:22 +0400
committerRoman I Khimov <khimov@altell.ru>2009-04-29 09:50:41 +0400
commiteaf85d32077a07dd18c3af3f713949feea3bfbc5 (patch)
tree8712465621ddb11ead98c4ab06a0bc55c4b3803c /recipes
parent6422fe2b0a110c3a611c0e98cd96b489d4f11880 (diff)
downloadopenembedded-eaf85d32077a07dd18c3af3f713949feea3bfbc5.tar.gz
binutils: add binutils-x86_64_i386_biarch.patch
Adds 'lib32' directories to binutils search paths on x86_64. Acked-By: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes')
-rw-r--r--recipes/binutils/binutils-2.18.50.0.7/binutils-x86_64_i386_biarch.patch26
-rw-r--r--recipes/binutils/binutils-2.18/binutils-x86_64_i386_biarch.patch25
-rw-r--r--recipes/binutils/binutils-2.19.1/binutils-x86_64_i386_biarch.patch25
-rw-r--r--recipes/binutils/binutils-2.19.51.0.3/binutils-x86_64_i386_biarch.patch26
-rw-r--r--recipes/binutils/binutils-2.19/binutils-x86_64_i386_biarch.patch25
-rw-r--r--recipes/binutils/binutils_2.18.50.0.7.bb3
-rw-r--r--recipes/binutils/binutils_2.18.bb4
-rw-r--r--recipes/binutils/binutils_2.19.1.bb3
-rw-r--r--recipes/binutils/binutils_2.19.51.0.3.bb3
-rw-r--r--recipes/binutils/binutils_2.19.bb3
10 files changed, 137 insertions, 6 deletions
diff --git a/recipes/binutils/binutils-2.18.50.0.7/binutils-x86_64_i386_biarch.patch b/recipes/binutils/binutils-2.18.50.0.7/binutils-x86_64_i386_biarch.patch
new file mode 100644
index 0000000000..60544345dc
--- /dev/null
+++ b/recipes/binutils/binutils-2.18.50.0.7/binutils-x86_64_i386_biarch.patch
@@ -0,0 +1,26 @@
+#!/bin/sh -e
+## 127_x86_64_i386_biarch.dpatch
+##
+## DP: Description: Add (/usr)/lib32 to the search paths on x86_64.
+## DP: Author: Aurelien Jarno <aurel32.debian.org>
+## DP: Upstream status: Debian specific
+#
+# Hacked to apply with quilt
+# Adapted to binutils 2.18.50.0.7
+
+--- binutils/ld/emulparams/elf_i386.sh
++++ binutils/ld/emulparams/elf_i386.sh
+@@ -12,3 +12,13 @@
+ NO_SMALL_DATA=yes
+ SEPARATE_GOTPLT=12
+ SHARABLE_SECTIONS=yes
++
++# Linux modify the default library search path to first include
++# a 32-bit specific directory.
++case "$target" in
++ x86_64*-linux* | i[3-7]86*-linux* | x86_64*-kfreebsd*-gnu | i[3-7]86*-kfreebsd*-gnu)
++ case "$EMULATION_NAME" in
++ *i386*) LIBPATH_SUFFIX=32 ;;
++ esac
++ ;;
++esac
diff --git a/recipes/binutils/binutils-2.18/binutils-x86_64_i386_biarch.patch b/recipes/binutils/binutils-2.18/binutils-x86_64_i386_biarch.patch
new file mode 100644
index 0000000000..b79a76af37
--- /dev/null
+++ b/recipes/binutils/binutils-2.18/binutils-x86_64_i386_biarch.patch
@@ -0,0 +1,25 @@
+#!/bin/sh -e
+## 127_x86_64_i386_biarch.dpatch
+##
+## DP: Description: Add (/usr)/lib32 to the search paths on x86_64.
+## DP: Author: Aurelien Jarno <aurel32.debian.org>
+## DP: Upstream status: Debian specific
+#
+# Hacked to apply with quilt
+
+--- binutils/ld/emulparams/elf_i386.sh
++++ binutils/ld/emulparams/elf_i386.sh
+@@ -12,3 +12,13 @@
+ GENERATE_PIE_SCRIPT=yes
+ NO_SMALL_DATA=yes
+ SEPARATE_GOTPLT=12
++
++# Linux modify the default library search path to first include
++# a 32-bit specific directory.
++case "$target" in
++ x86_64*-linux* | i[3-7]86*-linux* | x86_64*-kfreebsd*-gnu | i[3-7]86*-kfreebsd*-gnu)
++ case "$EMULATION_NAME" in
++ *i386*) LIBPATH_SUFFIX=32 ;;
++ esac
++ ;;
++esac
diff --git a/recipes/binutils/binutils-2.19.1/binutils-x86_64_i386_biarch.patch b/recipes/binutils/binutils-2.19.1/binutils-x86_64_i386_biarch.patch
new file mode 100644
index 0000000000..b79a76af37
--- /dev/null
+++ b/recipes/binutils/binutils-2.19.1/binutils-x86_64_i386_biarch.patch
@@ -0,0 +1,25 @@
+#!/bin/sh -e
+## 127_x86_64_i386_biarch.dpatch
+##
+## DP: Description: Add (/usr)/lib32 to the search paths on x86_64.
+## DP: Author: Aurelien Jarno <aurel32.debian.org>
+## DP: Upstream status: Debian specific
+#
+# Hacked to apply with quilt
+
+--- binutils/ld/emulparams/elf_i386.sh
++++ binutils/ld/emulparams/elf_i386.sh
+@@ -12,3 +12,13 @@
+ GENERATE_PIE_SCRIPT=yes
+ NO_SMALL_DATA=yes
+ SEPARATE_GOTPLT=12
++
++# Linux modify the default library search path to first include
++# a 32-bit specific directory.
++case "$target" in
++ x86_64*-linux* | i[3-7]86*-linux* | x86_64*-kfreebsd*-gnu | i[3-7]86*-kfreebsd*-gnu)
++ case "$EMULATION_NAME" in
++ *i386*) LIBPATH_SUFFIX=32 ;;
++ esac
++ ;;
++esac
diff --git a/recipes/binutils/binutils-2.19.51.0.3/binutils-x86_64_i386_biarch.patch b/recipes/binutils/binutils-2.19.51.0.3/binutils-x86_64_i386_biarch.patch
new file mode 100644
index 0000000000..60544345dc
--- /dev/null
+++ b/recipes/binutils/binutils-2.19.51.0.3/binutils-x86_64_i386_biarch.patch
@@ -0,0 +1,26 @@
+#!/bin/sh -e
+## 127_x86_64_i386_biarch.dpatch
+##
+## DP: Description: Add (/usr)/lib32 to the search paths on x86_64.
+## DP: Author: Aurelien Jarno <aurel32.debian.org>
+## DP: Upstream status: Debian specific
+#
+# Hacked to apply with quilt
+# Adapted to binutils 2.18.50.0.7
+
+--- binutils/ld/emulparams/elf_i386.sh
++++ binutils/ld/emulparams/elf_i386.sh
+@@ -12,3 +12,13 @@
+ NO_SMALL_DATA=yes
+ SEPARATE_GOTPLT=12
+ SHARABLE_SECTIONS=yes
++
++# Linux modify the default library search path to first include
++# a 32-bit specific directory.
++case "$target" in
++ x86_64*-linux* | i[3-7]86*-linux* | x86_64*-kfreebsd*-gnu | i[3-7]86*-kfreebsd*-gnu)
++ case "$EMULATION_NAME" in
++ *i386*) LIBPATH_SUFFIX=32 ;;
++ esac
++ ;;
++esac
diff --git a/recipes/binutils/binutils-2.19/binutils-x86_64_i386_biarch.patch b/recipes/binutils/binutils-2.19/binutils-x86_64_i386_biarch.patch
new file mode 100644
index 0000000000..b79a76af37
--- /dev/null
+++ b/recipes/binutils/binutils-2.19/binutils-x86_64_i386_biarch.patch
@@ -0,0 +1,25 @@
+#!/bin/sh -e
+## 127_x86_64_i386_biarch.dpatch
+##
+## DP: Description: Add (/usr)/lib32 to the search paths on x86_64.
+## DP: Author: Aurelien Jarno <aurel32.debian.org>
+## DP: Upstream status: Debian specific
+#
+# Hacked to apply with quilt
+
+--- binutils/ld/emulparams/elf_i386.sh
++++ binutils/ld/emulparams/elf_i386.sh
+@@ -12,3 +12,13 @@
+ GENERATE_PIE_SCRIPT=yes
+ NO_SMALL_DATA=yes
+ SEPARATE_GOTPLT=12
++
++# Linux modify the default library search path to first include
++# a 32-bit specific directory.
++case "$target" in
++ x86_64*-linux* | i[3-7]86*-linux* | x86_64*-kfreebsd*-gnu | i[3-7]86*-kfreebsd*-gnu)
++ case "$EMULATION_NAME" in
++ *i386*) LIBPATH_SUFFIX=32 ;;
++ esac
++ ;;
++esac
diff --git a/recipes/binutils/binutils_2.18.50.0.7.bb b/recipes/binutils/binutils_2.18.50.0.7.bb
index a89431e18e..eb00a2d03a 100644
--- a/recipes/binutils/binutils_2.18.50.0.7.bb
+++ b/recipes/binutils/binutils_2.18.50.0.7.bb
@@ -1,4 +1,4 @@
-PR = "r6"
+PR = "r7"
require binutils.inc
@@ -12,6 +12,7 @@ SRC_URI = "\
file://binutils-uclibc-300-012_check_ldrunpath_length.patch;patch=1 \
file://binutils-uclibc-gas-needs-libm.patch;patch=1 \
file://binutils-arm-pr7093.patch;patch=1 \
+ file://binutils-x86_64_i386_biarch.patch;patch=1 \
"
# powerpc patches
diff --git a/recipes/binutils/binutils_2.18.bb b/recipes/binutils/binutils_2.18.bb
index 9367196240..8370538461 100644
--- a/recipes/binutils/binutils_2.18.bb
+++ b/recipes/binutils/binutils_2.18.bb
@@ -1,4 +1,4 @@
-PR = "r4"
+PR = "r5"
require binutils.inc
@@ -12,8 +12,8 @@ SRC_URI = "\
file://binutils-uclibc-300-006_better_file_error.patch;patch=1 \
file://binutils-uclibc-300-012_check_ldrunpath_length.patch;patch=1 \
file://binutils-uclibc-gas-needs-libm.patch;patch=1 \
+ file://binutils-x86_64_i386_biarch.patch;patch=1 \
"
# powerpc patches
SRC_URI += "file://binutils-2.16.1-e300c2c3.patch;patch=1"
-
diff --git a/recipes/binutils/binutils_2.19.1.bb b/recipes/binutils/binutils_2.19.1.bb
index c399ab8c62..782d5c75c9 100644
--- a/recipes/binutils/binutils_2.19.1.bb
+++ b/recipes/binutils/binutils_2.19.1.bb
@@ -1,4 +1,4 @@
-PR = "r0"
+PR = "r1"
require binutils.inc
@@ -12,6 +12,7 @@ SRC_URI = "\
file://binutils-uclibc-300-012_check_ldrunpath_length.patch;patch=1 \
file://binutils-uclibc-gas-needs-libm.patch;patch=1 \
file://binutils-arm-pr7093.patch;patch=1 \
+ file://binutils-x86_64_i386_biarch.patch;patch=1 \
"
# powerpc patches
diff --git a/recipes/binutils/binutils_2.19.51.0.3.bb b/recipes/binutils/binutils_2.19.51.0.3.bb
index 7808d3b534..a4ed077706 100644
--- a/recipes/binutils/binutils_2.19.51.0.3.bb
+++ b/recipes/binutils/binutils_2.19.51.0.3.bb
@@ -1,4 +1,4 @@
-PR = "r0"
+PR = "r1"
require binutils.inc
@@ -12,6 +12,7 @@ SRC_URI = "\
file://binutils-uclibc-300-012_check_ldrunpath_length.patch;patch=1 \
file://binutils-uclibc-gas-needs-libm.patch;patch=1 \
file://binutils-arm-pr7093.patch;patch=1 \
+ file://binutils-x86_64_i386_biarch.patch;patch=1 \
"
# powerpc patches
diff --git a/recipes/binutils/binutils_2.19.bb b/recipes/binutils/binutils_2.19.bb
index aee5840a0c..072ac56854 100644
--- a/recipes/binutils/binutils_2.19.bb
+++ b/recipes/binutils/binutils_2.19.bb
@@ -1,4 +1,4 @@
-PR = "r1"
+PR = "r2"
require binutils.inc
@@ -12,6 +12,7 @@ SRC_URI = "\
file://binutils-uclibc-300-012_check_ldrunpath_length.patch;patch=1 \
file://binutils-uclibc-gas-needs-libm.patch;patch=1 \
file://binutils-arm-pr7093.patch;patch=1 \
+ file://binutils-x86_64_i386_biarch.patch;patch=1 \
"
# powerpc patches