aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorJoshua Lock <josh@linux.intel.com>2010-03-30 14:47:57 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2010-05-05 15:04:57 +0100
commit838a58ab01a9f325430fe6c4cc1dac7c2255a69c (patch)
treeca2b0e767dffe00aed392c8fd37be32aeb869d7e /recipes
parent692f64df9aa931780b98a9dc8505cfa7b61fbac0 (diff)
downloadopenembedded-838a58ab01a9f325430fe6c4cc1dac7c2255a69c.tar.gz
bitbake.conf/base.bbclass: Rename the staging directory to sysroots and the populate_staging task to populate_sysroot
This change, pulled from Poky, makes the purpose of the staging directory more obvious and the taskname more true to what it now actually does. The layout version number is increased due to the change in layout but code to convert existing directories and insert a symlink for backwards compatibility is included. This patch also includes fixes for all recipes which reference the directory. Signed-off-by: Joshua Lock <josh@linux.intel.com>
Diffstat (limited to 'recipes')
-rw-r--r--recipes/apex/apex-nslu2-16mb_1.5.14.bb2
-rw-r--r--recipes/apex/apex-nslu2_1.5.14.bb2
-rw-r--r--recipes/faad2/faad2_2.0.bb2
-rw-r--r--recipes/freedoom/freedoom_0.3.bb2
-rw-r--r--recipes/freedoom/freedoom_0.6.2.bb2
-rw-r--r--recipes/gnuradio/gnuradio-libusb-compat.inc2
-rw-r--r--recipes/ixp4xx/ixp4xx-npe-native_2.1.bb2
-rw-r--r--recipes/ixp4xx/ixp4xx-npe-native_2.3.2.bb2
-rw-r--r--recipes/ixp4xx/ixp4xx-npe-native_2.4.bb2
-rw-r--r--recipes/ixp4xx/ixp4xx-npe_2.1.bb2
-rw-r--r--recipes/ixp4xx/ixp4xx-npe_2.3.2.bb2
-rw-r--r--recipes/ixp4xx/ixp4xx-npe_2.4.bb2
-rw-r--r--recipes/jpeg/jasper_1.900.1.bb2
-rw-r--r--recipes/juce/juce_1.29.bb2
-rw-r--r--recipes/klimt/klimt_0.6.1.bb2
-rw-r--r--recipes/librcf/librcf_0.4.bb2
-rw-r--r--recipes/linux/compulab-pxa270_2.6.16.bb2
-rw-r--r--recipes/miglayout/miglayout_3.0.3.bb2
-rw-r--r--recipes/misc-binary-only/tda1004x-firmware.bb2
-rw-r--r--recipes/ogre/freeimage_3.11.0.bb2
-rw-r--r--recipes/zaurus-utils/zaurus-updater.bb5
21 files changed, 23 insertions, 22 deletions
diff --git a/recipes/apex/apex-nslu2-16mb_1.5.14.bb b/recipes/apex/apex-nslu2-16mb_1.5.14.bb
index f71eaa5d4b..8e764dd28f 100644
--- a/recipes/apex/apex-nslu2-16mb_1.5.14.bb
+++ b/recipes/apex/apex-nslu2-16mb_1.5.14.bb
@@ -58,7 +58,7 @@ do_stage() {
elif [ "x${SITEINFO_ENDIANESS}" = "xle" ]; then
devio '<<'src/arch-arm/rom/apex.bin >${STAGING_LOADER_DIR}/apex-nslu2-16mb.bin 'xp $,4'
else
- oefatal do_populate_staging cannot determine endianess
+ oefatal do_populate_sysroot cannot determine endianess
fi
}
diff --git a/recipes/apex/apex-nslu2_1.5.14.bb b/recipes/apex/apex-nslu2_1.5.14.bb
index db78872251..a1d91b7e67 100644
--- a/recipes/apex/apex-nslu2_1.5.14.bb
+++ b/recipes/apex/apex-nslu2_1.5.14.bb
@@ -58,7 +58,7 @@ do_stage() {
elif [ "x${SITEINFO_ENDIANESS}" = "xle" ]; then
devio '<<'src/arch-arm/rom/apex.bin >${STAGING_LOADER_DIR}/apex-nslu2.bin 'xp $,4'
else
- oefatal do_populate_staging cannot determine endianess
+ oefatal do_populate_sysroot cannot determine endianess
fi
}
diff --git a/recipes/faad2/faad2_2.0.bb b/recipes/faad2/faad2_2.0.bb
index ebb59feb01..3f15c026e9 100644
--- a/recipes/faad2/faad2_2.0.bb
+++ b/recipes/faad2/faad2_2.0.bb
@@ -3,7 +3,7 @@ SECTION = "libs"
LICENSE = "LGPL"
PRIORITY = "optional"
DEPENDS = ""
-do_unpack[depends] += "unzip-native:do_populate_staging"
+do_unpack[depends] += "unzip-native:do_populate_sysroot"
PR ="r2"
inherit autotools
diff --git a/recipes/freedoom/freedoom_0.3.bb b/recipes/freedoom/freedoom_0.3.bb
index 6cd002cd55..002f54441d 100644
--- a/recipes/freedoom/freedoom_0.3.bb
+++ b/recipes/freedoom/freedoom_0.3.bb
@@ -5,7 +5,7 @@ DESCRIPTION = "The Freedoom project aims at collaboratively creating a Free IWAD
HOMEPAGE = "http://freedoom.sourceforge.net/"
PRIORITY = "optional"
LICENSE = "GPL"
-do_unpack[depends] += "unzip-native:do_populate_staging"
+do_unpack[depends] += "unzip-native:do_populate_sysroot"
SRC_URI = "http://ovh.dl.sourceforge.net/sourceforge/freedoom/freedoom-iwad-0.3.zip"
diff --git a/recipes/freedoom/freedoom_0.6.2.bb b/recipes/freedoom/freedoom_0.6.2.bb
index 06cccc671a..655441c2c7 100644
--- a/recipes/freedoom/freedoom_0.6.2.bb
+++ b/recipes/freedoom/freedoom_0.6.2.bb
@@ -5,7 +5,7 @@ DESCRIPTION = "The Freedoom project aims at collaboratively creating a Free IWAD
HOMEPAGE = "http://freedoom.sourceforge.net/"
PRIORITY = "optional"
LICENSE = "GPL"
-do_unpack[depends] += "unzip-native:do_populate_staging"
+do_unpack[depends] += "unzip-native:do_populate_sysroot"
SRC_URI = "${SOURCEFORGE_MIRROR}/freedoom/freedoom-iwad-${PV}.zip"
diff --git a/recipes/gnuradio/gnuradio-libusb-compat.inc b/recipes/gnuradio/gnuradio-libusb-compat.inc
index 516775bec3..efe2b88b4f 100644
--- a/recipes/gnuradio/gnuradio-libusb-compat.inc
+++ b/recipes/gnuradio/gnuradio-libusb-compat.inc
@@ -47,7 +47,7 @@ do_buildlibusb() {
addtask buildlibusb before do_configure after do_unpack
-do_buildlibusb[deptask] = "do_populate_staging"
+do_buildlibusb[deptask] = "do_populate_sysroot"
do_configure_prepend() {
if [ -e ${WORKDIR}/acinclude.m4 ] ; then
diff --git a/recipes/ixp4xx/ixp4xx-npe-native_2.1.bb b/recipes/ixp4xx/ixp4xx-npe-native_2.1.bb
index 1510a750a9..f7ff764765 100644
--- a/recipes/ixp4xx/ixp4xx-npe-native_2.1.bb
+++ b/recipes/ixp4xx/ixp4xx-npe-native_2.1.bb
@@ -4,7 +4,7 @@ PR = "r3"
SRC_URI = "http://www.intel.com/Please-Read-The-BB-File/IPL_ixp400NpeLibrary-2_1.zip"
SRC_URI += "file://IxNpeMicrocode.h"
-do_unpack[depends] += "unzip-native:do_populate_staging"
+do_unpack[depends] += "unzip-native:do_populate_sysroot"
inherit native
S = "${WORKDIR}/ixp400_xscale_sw/src/npeDl"
diff --git a/recipes/ixp4xx/ixp4xx-npe-native_2.3.2.bb b/recipes/ixp4xx/ixp4xx-npe-native_2.3.2.bb
index 926fa98dcc..aabc043c6c 100644
--- a/recipes/ixp4xx/ixp4xx-npe-native_2.3.2.bb
+++ b/recipes/ixp4xx/ixp4xx-npe-native_2.3.2.bb
@@ -4,7 +4,7 @@ PR = "r1"
SRC_URI = "http://You-Have-To-Download-The-Microcode-Manually-So-Please-Read-ixp4xx-npe_2.3.2.bb-For-Instructions/IPL_ixp400NpeLibrary-2_3_2.zip"
SRC_URI += "file://IxNpeMicrocode.h"
-do_unpack[depends] += "unzip-native:do_populate_staging"
+do_unpack[depends] += "unzip-native:do_populate_sysroot"
inherit native
S = "${WORKDIR}/ixp400_xscale_sw/src/npeDl"
diff --git a/recipes/ixp4xx/ixp4xx-npe-native_2.4.bb b/recipes/ixp4xx/ixp4xx-npe-native_2.4.bb
index 7bc28e6181..1ac22b2cdb 100644
--- a/recipes/ixp4xx/ixp4xx-npe-native_2.4.bb
+++ b/recipes/ixp4xx/ixp4xx-npe-native_2.4.bb
@@ -4,7 +4,7 @@ PR = "r0"
SRC_URI = "http://You-Have-To-Download-The-Microcode-Manually-So-Please-Read-ixp4xx-npe_2.4.bb-For-Instructions/IPL_ixp400NpeLibrary-2_4.zip"
SRC_URI += "file://IxNpeMicrocode.h"
-do_unpack[depends] += "unzip-native:do_populate_staging"
+do_unpack[depends] += "unzip-native:do_populate_sysroot"
inherit native
S = "${WORKDIR}/ixp400_xscale_sw/src/npeDl"
diff --git a/recipes/ixp4xx/ixp4xx-npe_2.1.bb b/recipes/ixp4xx/ixp4xx-npe_2.1.bb
index 7eb3a3dbe0..ff10ff040c 100644
--- a/recipes/ixp4xx/ixp4xx-npe_2.1.bb
+++ b/recipes/ixp4xx/ixp4xx-npe_2.1.bb
@@ -4,7 +4,7 @@ PR = "r6"
DEPENDS = "ixp4xx-npe-native"
SRC_URI = "http://www.intel.com/Please-Read-The-BB-File/IPL_ixp400NpeLibrary-2_1.zip"
-do_unpack[depends] += "unzip-native:do_populate_staging"
+do_unpack[depends] += "unzip-native:do_populate_sysroot"
S = "${WORKDIR}/ixp400_xscale_sw/src/npeDl"
COMPATIBLE_MACHINE = "(nslu2|ixp4xx)"
diff --git a/recipes/ixp4xx/ixp4xx-npe_2.3.2.bb b/recipes/ixp4xx/ixp4xx-npe_2.3.2.bb
index 40ef4e653f..540528b2a6 100644
--- a/recipes/ixp4xx/ixp4xx-npe_2.3.2.bb
+++ b/recipes/ixp4xx/ixp4xx-npe_2.3.2.bb
@@ -9,7 +9,7 @@ DEPENDS = "ixp4xx-npe-native"
# Make sure you *read* and accept the license - it is not a standard one.
SRC_URI = "http://You-Have-To-Download-The-Microcode-Manually-So-Please-Read-ixp4xx-npe_2.3.2.bb-For-Instructions/IPL_ixp400NpeLibrary-2_3_2.zip"
-do_unpack[depends] += "unzip-native:do_populate_staging"
+do_unpack[depends] += "unzip-native:do_populate_sysroot"
S = "${WORKDIR}/ixp400_xscale_sw/src/npeDl"
COMPATIBLE_MACHINE = "(nslu2|ixp4xx)"
diff --git a/recipes/ixp4xx/ixp4xx-npe_2.4.bb b/recipes/ixp4xx/ixp4xx-npe_2.4.bb
index 900ef8928a..bae416d121 100644
--- a/recipes/ixp4xx/ixp4xx-npe_2.4.bb
+++ b/recipes/ixp4xx/ixp4xx-npe_2.4.bb
@@ -11,7 +11,7 @@ DEPENDS = "ixp4xx-npe-native"
SRC_URI = "http://You-Have-To-Download-The-Microcode-Manually-So-Please-Read-ixp4xx-npe_2.4.bb-For-Instructions/IPL_ixp400NpeLibrary-2_4.zip \
file://Intel"
-do_unpack[depends] += "unzip-native:do_populate_staging"
+do_unpack[depends] += "unzip-native:do_populate_sysroot"
S = "${WORKDIR}/ixp400_xscale_sw/src/npeDl"
COMPATIBLE_MACHINE = "(nslu2|ixp4xx|kixrp435)"
diff --git a/recipes/jpeg/jasper_1.900.1.bb b/recipes/jpeg/jasper_1.900.1.bb
index 2598088ecd..94b83b953b 100644
--- a/recipes/jpeg/jasper_1.900.1.bb
+++ b/recipes/jpeg/jasper_1.900.1.bb
@@ -1,6 +1,6 @@
DESCRIPTION = "Jpeg 2000 implementation"
LICENSE = "MIT"
-do_unpack[depends] += "unzip-native:do_populate_staging"
+do_unpack[depends] += "unzip-native:do_populate_sysroot"
SRC_URI = "http://www.ece.uvic.ca/~mdadams/jasper/software/jasper-${PV}.zip"
diff --git a/recipes/juce/juce_1.29.bb b/recipes/juce/juce_1.29.bb
index a007313005..14906a9cb5 100644
--- a/recipes/juce/juce_1.29.bb
+++ b/recipes/juce/juce_1.29.bb
@@ -3,7 +3,7 @@ HOMEPAGE = "http://www.rawmaterialsoftware.com/juce"
AUTHOR = "Julian Stoerer"
LICENSE = "GPL"
DEPENDS = "alsa-lib freetype virtual/libx11"
-do_unpack[depends] += "unzip-native:do_populate_staging"
+do_unpack[depends] += "unzip-native:do_populate_sysroot"
PR = "r0"
#FIXME the patches are a) HACKS and b) something's wrong with lineend conversion
diff --git a/recipes/klimt/klimt_0.6.1.bb b/recipes/klimt/klimt_0.6.1.bb
index 2ad9628dca..d6bd55cda8 100644
--- a/recipes/klimt/klimt_0.6.1.bb
+++ b/recipes/klimt/klimt_0.6.1.bb
@@ -5,7 +5,7 @@ LICENSE = "GPL"
PR = "r1"
SRC_URI = "${SOURCEFORGE_MIRROR}/klimt/klimt-src-${PV}.zip"
-do_unpack[depends] += "unzip-native:do_populate_staging"
+do_unpack[depends] += "unzip-native:do_populate_sysroot"
S = "${WORKDIR}/klimt/build/LinuxQTE"
EXTRA_QMAKEVARS_POST += " QMAKE_CXXFLAGS+=-fpermissive"
diff --git a/recipes/librcf/librcf_0.4.bb b/recipes/librcf/librcf_0.4.bb
index 2bb6c1e1a9..0559698457 100644
--- a/recipes/librcf/librcf_0.4.bb
+++ b/recipes/librcf/librcf_0.4.bb
@@ -3,7 +3,7 @@ SECTION = "base"
PRIORITY = "optional"
LICENSE = "unknown"
DEPENDS="zlib openssl boost-asio"
-do_unpack[depends] += "unzip-native:do_populate_staging"
+do_unpack[depends] += "unzip-native:do_populate_sysroot"
# the SOURCE_URI requires authentication via web browser and cookie (gasp)
# all we can do right now is download the file and save it under sources/
diff --git a/recipes/linux/compulab-pxa270_2.6.16.bb b/recipes/linux/compulab-pxa270_2.6.16.bb
index 6917ec92b7..edaecb3a94 100644
--- a/recipes/linux/compulab-pxa270_2.6.16.bb
+++ b/recipes/linux/compulab-pxa270_2.6.16.bb
@@ -2,7 +2,7 @@ SECTION = "kernel"
DESCRIPTION = "Linux kernel for the Compulab PXA270 system"
LICENSE = "GPLv2"
PR = "r6"
-do_unpack[depends] += "unzip-native:do_populate_staging"
+do_unpack[depends] += "unzip-native:do_populate_sysroot"
# Note, the compulab package contains a binary NAND driver that is not
# EABI compatible
diff --git a/recipes/miglayout/miglayout_3.0.3.bb b/recipes/miglayout/miglayout_3.0.3.bb
index a362e16452..7013914d88 100644
--- a/recipes/miglayout/miglayout_3.0.3.bb
+++ b/recipes/miglayout/miglayout_3.0.3.bb
@@ -14,7 +14,7 @@ S = "${WORKDIR}"
inherit java-library
DEPENDS = "fastjar-native classpath swt3.4-gtk"
-do_unpack[depends] += "unzip-native:do_populate_staging"
+do_unpack[depends] += "unzip-native:do_populate_sysroot"
do_unpackpost() {
find -name "*.jar" -exec rm {} \;
diff --git a/recipes/misc-binary-only/tda1004x-firmware.bb b/recipes/misc-binary-only/tda1004x-firmware.bb
index 56fa8ee6c2..d862e9eafb 100644
--- a/recipes/misc-binary-only/tda1004x-firmware.bb
+++ b/recipes/misc-binary-only/tda1004x-firmware.bb
@@ -1,5 +1,5 @@
SECTION = "base"
-do_unpack[depends] += "unzip-native:do_populate_staging"
+do_unpack[depends] += "unzip-native:do_populate_sysroot"
SRC_URI = "http://hauppauge.lightpath.net/de/nova-pci218c.exe"
FILES_${PN} = '*'
diff --git a/recipes/ogre/freeimage_3.11.0.bb b/recipes/ogre/freeimage_3.11.0.bb
index fd238f275a..d38882f124 100644
--- a/recipes/ogre/freeimage_3.11.0.bb
+++ b/recipes/ogre/freeimage_3.11.0.bb
@@ -1,5 +1,5 @@
LICENSE = "MIT"
-do_unpack[depends] += "unzip-native:do_populate_staging"
+do_unpack[depends] += "unzip-native:do_populate_sysroot"
PR = "r1"
diff --git a/recipes/zaurus-utils/zaurus-updater.bb b/recipes/zaurus-utils/zaurus-updater.bb
index 7c72921e75..1d9441b5d1 100644
--- a/recipes/zaurus-utils/zaurus-updater.bb
+++ b/recipes/zaurus-utils/zaurus-updater.bb
@@ -24,5 +24,6 @@ do_deploy() {
package_stagefile_shell ${DEPLOY_DIR_IMAGE}/updater.sh
}
-# package_stagefile_shell needs to run before populate_staging for packaged-staging
-addtask deploy before do_populate_staging after do_compile
+# package_stagefile_shell need to run before populate_sysroot for packaged-staging
+addtask deploy before do_populate_sysroot after do_compile
+