aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorKlaus Kurzmann <mok@fluxnetz.de>2010-01-09 21:53:57 +0100
committerKlaus Kurzmann <mok@fluxnetz.de>2010-01-09 21:53:57 +0100
commitdbcb75bd0190f8732b30318b9579929dec8452fa (patch)
tree389a89a9ad3e56fb61934babd41c0c67c23a2015 /recipes
parent9c5e5bbc025641ef0555f0b0576addec1e47b799 (diff)
downloadopenembedded-dbcb75bd0190f8732b30318b9579929dec8452fa.tar.gz
fsodatad: add a config file
Signed-off-by: Klaus Kurzmann <mok@fluxnetz.de>
Diffstat (limited to 'recipes')
-rw-r--r--recipes/freesmartphone/fsodatad/fsodatad.conf19
-rw-r--r--recipes/freesmartphone/fsodatad_git.bb11
2 files changed, 29 insertions, 1 deletions
diff --git a/recipes/freesmartphone/fsodatad/fsodatad.conf b/recipes/freesmartphone/fsodatad/fsodatad.conf
new file mode 100644
index 0000000000..85919cf6aa
--- /dev/null
+++ b/recipes/freesmartphone/fsodatad/fsodatad.conf
@@ -0,0 +1,19 @@
+#######################################################################################
+# FSO Data Daemon Configuration File -- for SYSTEM INTEGRATORS only
+########################################################################################
+[logging]
+# Log level: DEBUG, INFO (default), WARNING, ERROR
+# Override via environment as FSO_LOG_LEVEL
+log_level = INFO
+# Where to log to: none (default), stderr, stderr:colors, file, syslog
+# Override via environment as FSO_LOG_TO
+log_to = file
+# Log Destination (valid only for log_to = file)
+# Override via environment as FSO_LOG_DESTINATION
+log_destination = /var/log/fsodatad.log
+
+[fsodata]
+# No settings yet
+
+[fsodata.world]
+# No settings yet
diff --git a/recipes/freesmartphone/fsodatad_git.bb b/recipes/freesmartphone/fsodatad_git.bb
index de13bedc0a..c2933ed4da 100644
--- a/recipes/freesmartphone/fsodatad_git.bb
+++ b/recipes/freesmartphone/fsodatad_git.bb
@@ -1,6 +1,15 @@
require cornucopia.inc
inherit fso-plugin
-PR = "${INC_PR}.0"
+PR = "${INC_PR}.1"
PV = "0.0.0+gitr${SRCREV}"
DEPENDS += "libxml2 mobile-broadband-provider-info"
+
+SRC_URI += "file://fsodatad.conf"
+
+do_install_append() {
+ install -d ${D}${sysconfdir}/freesmartphone/
+ install -m 0644 ${WORKDIR}/fsodatad.conf ${D}${sysconfdir}/freesmartphone/
+}
+
+FILES_${PN} += "${sysconfdir}/freesmartphone/fsodatad.conf"