aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorStanislav Brabec <utx@penguin.cz>2009-10-05 23:39:53 +0000
committerutx@penguin.cz <utx@penguin.cz>2009-10-05 23:39:53 +0000
commit06c06f67c72891d4022ad53cc44ddc1242a87d9b (patch)
tree494c43ba6246ef09a10aa8b40972a89e4941b5ae /recipes
parentc518a888a6e5a8180a6e5dddfc7e686d2707a365 (diff)
downloadopenembedded-06c06f67c72891d4022ad53cc44ddc1242a87d9b.tar.gz
xserver-kdrive-1.3.0.0: Report correct XRandR version. Fixes non-working GTK+.
Diffstat (limited to 'recipes')
-rw-r--r--recipes/xorg-xserver/files/report-correct-randr12.patch29
-rw-r--r--recipes/xorg-xserver/xserver-kdrive_1.3.0.0.bb3
2 files changed, 31 insertions, 1 deletions
diff --git a/recipes/xorg-xserver/files/report-correct-randr12.patch b/recipes/xorg-xserver/files/report-correct-randr12.patch
new file mode 100644
index 0000000000..72c8a18add
--- /dev/null
+++ b/recipes/xorg-xserver/files/report-correct-randr12.patch
@@ -0,0 +1,29 @@
+Server reports XRandR version provided by libxrandr instead of XRandR
+version implemented. It confuses applications that execute XRandR
+version dependent code (e. g. gtk+ >= 2.18.0).
+
+Index: xorg-server-1.3.0.0/randr/rrdispatch.c
+===================================================================
+--- xorg-server-1.3.0.0.orig/randr/rrdispatch.c
++++ xorg-server-1.3.0.0/randr/rrdispatch.c
+@@ -22,6 +22,9 @@
+
+ #include "randrstr.h"
+
++#define SERVER_RANDR_MAJOR 1
++#define SERVER_RANDR_MINOR 2
++
+ Bool
+ RRClientKnowsRates (ClientPtr pClient)
+ {
+@@ -49,8 +52,8 @@ ProcRRQueryVersion (ClientPtr client)
+ * Report the current version; the current
+ * spec says they're all compatible after 1.0
+ */
+- rep.majorVersion = RANDR_MAJOR;
+- rep.minorVersion = RANDR_MINOR;
++ rep.majorVersion = SERVER_RANDR_MAJOR;
++ rep.minorVersion = SERVER_RANDR_MINOR;
+ if (client->swapped) {
+ swaps(&rep.sequenceNumber, n);
+ swapl(&rep.length, n);
diff --git a/recipes/xorg-xserver/xserver-kdrive_1.3.0.0.bb b/recipes/xorg-xserver/xserver-kdrive_1.3.0.0.bb
index 1faa0e7990..1b052e7926 100644
--- a/recipes/xorg-xserver/xserver-kdrive_1.3.0.0.bb
+++ b/recipes/xorg-xserver/xserver-kdrive_1.3.0.0.bb
@@ -3,7 +3,7 @@ require xserver-kdrive-common.inc
DEPENDS += "libxkbfile libxcalibrate"
PE = "1"
-PR = "r26"
+PR = "r27"
SRC_URI = "${XORG_MIRROR}/individual/xserver/xorg-server-${PV}.tar.bz2 \
${KDRIVE_COMMON_PATCHES} \
@@ -24,6 +24,7 @@ SRC_URI = "${XORG_MIRROR}/individual/xserver/xorg-server-${PV}.tar.bz2 \
file://gumstix-kmode.patch;patch=1 \
file://fix-picturestr-include-order.patch;patch=1 \
file://autotools.patch;patch=1 \
+ file://report-correct-randr12.patch;patch=1 \
"
SRC_URI_append_avr32 = " \