aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorGraham Gower <graham.gower@gmail.com>2009-10-08 17:16:41 +0000
committerMarcin Juszkiewicz <marcin@juszkiewicz.com.pl>2009-10-09 15:12:29 +0200
commit30a06f663f341086400aef4be1bfb66babb988ec (patch)
tree657e179507cdd6ee8133dc05884b0e96c8414187 /recipes
parentb696acdd7296726efce684e3434f6a6445ddd992 (diff)
downloadopenembedded-30a06f663f341086400aef4be1bfb66babb988ec.tar.gz
matchbox-panel-0.9.3: fix uninitialised variable causing SIGBUS
As reported here: http://lists.o-hand.com/matchbox/0289.html I've not experienced the bug for over a month since applying this change. Signed-off-by: Graham Gower <graham.gower@gmail.com> Signed-off-by: Holger Hans Peter Freyther <zecke@selfish.org> Signed-off-by: Marcin Juszkiewicz <marcin@juszkiewicz.com.pl>
Diffstat (limited to 'recipes')
-rw-r--r--recipes/matchbox-panel/matchbox-panel-0.9.3/matchbox-panel-uninitialised-crash.patch10
-rw-r--r--recipes/matchbox-panel/matchbox-panel_0.9.3.bb5
2 files changed, 13 insertions, 2 deletions
diff --git a/recipes/matchbox-panel/matchbox-panel-0.9.3/matchbox-panel-uninitialised-crash.patch b/recipes/matchbox-panel/matchbox-panel-0.9.3/matchbox-panel-uninitialised-crash.patch
new file mode 100644
index 0000000000..6177501071
--- /dev/null
+++ b/recipes/matchbox-panel/matchbox-panel-0.9.3/matchbox-panel-uninitialised-crash.patch
@@ -0,0 +1,10 @@
+--- matchbox-panel-0.9.3/src/panel_app.c.orig
++++ matchbox-panel-0.9.3/src/panel_app.c
+@@ -249,6 +249,7 @@
+
+ papp = NEW(MBPanelApp);
+
++ papp->name = NULL;
+ papp->next = NULL;
+ papp->win = win;
+ papp->panel = panel;
diff --git a/recipes/matchbox-panel/matchbox-panel_0.9.3.bb b/recipes/matchbox-panel/matchbox-panel_0.9.3.bb
index 555912260e..3d50f5f4f2 100644
--- a/recipes/matchbox-panel/matchbox-panel_0.9.3.bb
+++ b/recipes/matchbox-panel/matchbox-panel_0.9.3.bb
@@ -1,5 +1,6 @@
require matchbox-panel.inc
-PR ="r4"
+PR ="r5"
SRC_URI = "http://projects.o-hand.com/matchbox/sources/${PN}/0.9/${PN}-${PV}.tar.gz \
file://mb-applet-battery-repaint-093.patch;patch=1 \
- file://mb-applet-system-monitor-crash.patch;patch=1"
+ file://mb-applet-system-monitor-crash.patch;patch=1 \
+ file://matchbox-panel-uninitialised-crash.patch;patch=1"