aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorRoman Khimov <khimov@altell.ru>2010-07-02 04:57:34 +0000
committerRoman I Khimov <khimov@altell.ru>2010-07-29 23:54:22 +0400
commit3fe37352fc5df40ae1f275c4a586c4a50d336c3c (patch)
tree5646ffa425745167f777561e56c367272ff8f7c9 /recipes
parentd90020bab78b45729ae05fcdb993bcac99199767 (diff)
downloadopenembedded-3fe37352fc5df40ae1f275c4a586c4a50d336c3c.tar.gz
base-files: profile: don't set TZ if /etc/TZ is present
uClibc-based systems can have system-wide TZ in /etc/TZ, thus we shouldn't set TZ variable if it is present. Signed-off-by: Roman I Khimov <khimov@altell.ru> Acked-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes')
-rwxr-xr-xrecipes/base-files/base-files/jornada6xx/profile2
-rw-r--r--recipes/base-files/base-files/omap3-pandora/profile2
-rw-r--r--recipes/base-files/base-files/oplinux-uclibc/profile2
-rw-r--r--recipes/base-files/base-files/oplinux/profile2
-rw-r--r--recipes/base-files/base-files/profile2
-rw-r--r--recipes/base-files/base-files/shr/profile2
-rw-r--r--recipes/base-files/base-files_3.0.14.bb2
7 files changed, 7 insertions, 7 deletions
diff --git a/recipes/base-files/base-files/jornada6xx/profile b/recipes/base-files/base-files/jornada6xx/profile
index bff0f42783..bd9e3e6158 100755
--- a/recipes/base-files/base-files/jornada6xx/profile
+++ b/recipes/base-files/base-files/jornada6xx/profile
@@ -9,7 +9,7 @@ if [ "`id -u`" -eq 0 ]; then
PATH="$PATH:/sbin:/usr/sbin:/usr/local/sbin"
fi
-if [ ! -e /etc/localtime ]; then
+if [ ! -e /etc/localtime -a ! -e /etc/TZ ]; then
TZ="UTC" # Time Zone. Look at http://theory.uwinnipeg.ca/gnu/glibc/libc_303.html
# for an explanation of how to set this to your local timezone.
export TZ
diff --git a/recipes/base-files/base-files/omap3-pandora/profile b/recipes/base-files/base-files/omap3-pandora/profile
index 5797535093..99b6fcef4a 100644
--- a/recipes/base-files/base-files/omap3-pandora/profile
+++ b/recipes/base-files/base-files/omap3-pandora/profile
@@ -5,7 +5,7 @@ PATH="/usr/local/bin:/usr/bin:/bin"
EDITOR="/bin/vi" # needed for packages like cron
test -z "$TERM" && TERM="vt100" # Basic terminal capab. For screen etc.
-if [ ! -e /etc/localtime ]; then
+if [ ! -e /etc/localtime -a ! -e /etc/TZ ]; then
TZ="UTC" # Time Zone. Look at http://theory.uwinnipeg.ca/gnu/glibc/libc_303.html
# for an explanation of how to set this to your local timezone.
export TZ
diff --git a/recipes/base-files/base-files/oplinux-uclibc/profile b/recipes/base-files/base-files/oplinux-uclibc/profile
index f6ae329b57..5ad29674a9 100644
--- a/recipes/base-files/base-files/oplinux-uclibc/profile
+++ b/recipes/base-files/base-files/oplinux-uclibc/profile
@@ -5,7 +5,7 @@ PATH="/usr/local/bin:/usr/bin:/bin"
EDITOR="/usr/bin/nano" # needed for packages like cron
TERM="linux" # Basic terminal capab. For screen etc.
-if [ ! -e /etc/localtime ]; then
+if [ ! -e /etc/localtime -a ! -e /etc/TZ ]; then
TZ="UTC" # Time Zone. Look at http://theory.uwinnipeg.ca/gnu/glibc/libc_303.html
# for an explanation of how to set this to your local timezone.
export TZ
diff --git a/recipes/base-files/base-files/oplinux/profile b/recipes/base-files/base-files/oplinux/profile
index f6ae329b57..5ad29674a9 100644
--- a/recipes/base-files/base-files/oplinux/profile
+++ b/recipes/base-files/base-files/oplinux/profile
@@ -5,7 +5,7 @@ PATH="/usr/local/bin:/usr/bin:/bin"
EDITOR="/usr/bin/nano" # needed for packages like cron
TERM="linux" # Basic terminal capab. For screen etc.
-if [ ! -e /etc/localtime ]; then
+if [ ! -e /etc/localtime -a ! -e /etc/TZ ]; then
TZ="UTC" # Time Zone. Look at http://theory.uwinnipeg.ca/gnu/glibc/libc_303.html
# for an explanation of how to set this to your local timezone.
export TZ
diff --git a/recipes/base-files/base-files/profile b/recipes/base-files/base-files/profile
index b5ce69d9e6..8f7f6b5047 100644
--- a/recipes/base-files/base-files/profile
+++ b/recipes/base-files/base-files/profile
@@ -5,7 +5,7 @@ PATH="/usr/local/bin:/usr/bin:/bin"
EDITOR="/bin/vi" # needed for packages like cron
test -z "$TERM" && TERM="vt100" # Basic terminal capab. For screen etc.
-if [ ! -e /etc/localtime ]; then
+if [ ! -e /etc/localtime -a ! -e /etc/TZ ]; then
TZ="UTC" # Time Zone. Look at http://theory.uwinnipeg.ca/gnu/glibc/libc_303.html
# for an explanation of how to set this to your local timezone.
export TZ
diff --git a/recipes/base-files/base-files/shr/profile b/recipes/base-files/base-files/shr/profile
index ff0418f397..6874e6c41c 100644
--- a/recipes/base-files/base-files/shr/profile
+++ b/recipes/base-files/base-files/shr/profile
@@ -5,7 +5,7 @@ PATH="/usr/local/bin:/usr/bin:/bin"
EDITOR="/bin/vi" # needed for packages like cron
test -z "$TERM" && TERM="vt100" # Basic terminal capab. For screen etc.
-if [ ! -e /etc/localtime ]; then
+if [ ! -e /etc/localtime -a ! -e /etc/TZ ]; then
TZ="UTC" # Time Zone. Look at http://theory.uwinnipeg.ca/gnu/glibc/libc_303.html
# for an explanation of how to set this to your local timezone.
export TZ
diff --git a/recipes/base-files/base-files_3.0.14.bb b/recipes/base-files/base-files_3.0.14.bb
index 02bd39b157..abb8c973f4 100644
--- a/recipes/base-files/base-files_3.0.14.bb
+++ b/recipes/base-files/base-files_3.0.14.bb
@@ -1,7 +1,7 @@
DESCRIPTION = "Miscellaneous files for the base system."
SECTION = "base"
PRIORITY = "required"
-PR = "r95"
+PR = "r96"
LICENSE = "GPL"
SRC_URI = " \