aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2009-12-14 23:45:15 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2009-12-14 23:45:15 +0100
commit0bad67eed30abf02e5b32400263642b3b6aa2dc5 (patch)
tree5ccfb30c526628abf27ec879b7e1edf31fbe1cf7 /recipes
parent118e868b7115790f3112b4090478f881f0502ebe (diff)
parent67572c35f69f1233ba480887e72925e3d7f2c7f3 (diff)
downloadopenembedded-0bad67eed30abf02e5b32400263642b3b6aa2dc5.tar.gz
Merge commit 'origin/org.openembedded.dev' into shr/merge
Diffstat (limited to 'recipes')
-rw-r--r--recipes/kexecboot/kexecboot.inc10
-rw-r--r--recipes/kexecboot/kexecboot_git.bb4
-rw-r--r--recipes/linux/linux_2.6.23.bb2
-rw-r--r--recipes/qt4/qt4.inc1
-rw-r--r--recipes/sg3-utils/sg3-utils_1.24.bb4
5 files changed, 13 insertions, 8 deletions
diff --git a/recipes/kexecboot/kexecboot.inc b/recipes/kexecboot/kexecboot.inc
index ebd193beea..679c4a378a 100644
--- a/recipes/kexecboot/kexecboot.inc
+++ b/recipes/kexecboot/kexecboot.inc
@@ -14,10 +14,12 @@ SRC_URI += "file://logo-img.h \
export CC=${TARGET_PREFIX}klcc
-# standard oe cflags don't work with klcc
-export CFLAGS = ""
-export CPPFLAGS = ""
-export LDFLAGS = ""
+# for output on serial console: --enable-debug
+EXTRA_OECONF_akita = "--with-zaurus"
+EXTRA_OECONF_c7x0 = "--with-zaurus"
+EXTRA_OECONF_spitz = "--with-zaurus"
+EXTRA_OECONF_poodle = "--with-zaurus"
+EXTRA_OECONF_tosa = "--with-zaurus"
do_configure_prepend () {
install -m 0644 ${WORKDIR}/logo-img.h ${S}/res/
diff --git a/recipes/kexecboot/kexecboot_git.bb b/recipes/kexecboot/kexecboot_git.bb
index 02e6d729ec..561706e9f6 100644
--- a/recipes/kexecboot/kexecboot_git.bb
+++ b/recipes/kexecboot/kexecboot_git.bb
@@ -1,8 +1,8 @@
PV = "0.5"
-PR = "r8+gitr${SRCREV}"
+PR = "r9+gitr${SRCREV}"
SRC_URI = "git://git.linuxtogo.org/home/groups/kexecboot/kexecboot.git;protocol=git "
-SRCREV = "456e052144f58d3c1116a38cbb5caa44c070bce8"
+SRCREV = "daa68b5aaa56a036c24c7929e239ebd5edf8fdfe"
S = "${WORKDIR}/git"
diff --git a/recipes/linux/linux_2.6.23.bb b/recipes/linux/linux_2.6.23.bb
index 65f400d6b6..a5367fda09 100644
--- a/recipes/linux/linux_2.6.23.bb
+++ b/recipes/linux/linux_2.6.23.bb
@@ -91,5 +91,5 @@ python do_compulab_image() {
}
-addtask compulab_image after do_deploy before do_package
+addtask compulab_image after do_package before do_build
diff --git a/recipes/qt4/qt4.inc b/recipes/qt4/qt4.inc
index 0671a6c570..62fcec11a2 100644
--- a/recipes/qt4/qt4.inc
+++ b/recipes/qt4/qt4.inc
@@ -245,6 +245,7 @@ do_install() {
-e s#-L${STAGING_LIBDIR}##g \
-e s#-L${libdir}##g \
-e s#'$(OE_QMAKE_LIBS_X11)'#"${OE_QMAKE_LIBS_X11}"#g \
+ -e s#"-Wl,-rpath-link,${S}/lib"##g \
${D}${libdir}/*.la ${D}${libdir}/*.prl ${D}${libdir}/pkgconfig/*.pc
# fix pkgconfig files
diff --git a/recipes/sg3-utils/sg3-utils_1.24.bb b/recipes/sg3-utils/sg3-utils_1.24.bb
index 4a2c378676..8a4a603e8c 100644
--- a/recipes/sg3-utils/sg3-utils_1.24.bb
+++ b/recipes/sg3-utils/sg3-utils_1.24.bb
@@ -4,7 +4,9 @@ HOMEPAGE = "http://packages.qa.debian.org/s/sg3-utils.html"
SECTION = "console/admin"
LICENSE = "GPLv2"
AUTHOR = "Eric Schwartz (Skif) <emschwar@debian.org>"
-PR = "r1"
+PR = "r2"
+
+TARGET_CC_ARCH += "${LDFLAGS}"
SRC_URI = "${DEBIAN_MIRROR}/main/s/sg3-utils/sg3-utils_${PV}.orig.tar.gz \
file://Makefile-r1.patch;patch=1"