aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorSteve Sakoman <steve@sakoman.com>2009-08-07 13:40:50 -0700
committerKoen Kooi <koen@openembedded.org>2009-08-08 11:20:07 +0200
commit691e173d1979387337e4973db8213ab22f64ba69 (patch)
treecb730d6519a239d41689ffa2db535c9122c7f644 /recipes
parent6c47435bdb4abb5e5c4831ff774fe2c604d3aadf (diff)
downloadopenembedded-691e173d1979387337e4973db8213ab22f64ba69.tar.gz
gconf: add 2.26.2
Diffstat (limited to 'recipes')
-rw-r--r--recipes/gnome/gconf-2.26.2/org.gnome.GConf.Defaults.service4
-rw-r--r--recipes/gnome/gconf-2.26.2/org.gnome.GConf.service3
-rw-r--r--recipes/gnome/gconf_2.26.2.bb51
3 files changed, 58 insertions, 0 deletions
diff --git a/recipes/gnome/gconf-2.26.2/org.gnome.GConf.Defaults.service b/recipes/gnome/gconf-2.26.2/org.gnome.GConf.Defaults.service
new file mode 100644
index 0000000000..d6e4e072b2
--- /dev/null
+++ b/recipes/gnome/gconf-2.26.2/org.gnome.GConf.Defaults.service
@@ -0,0 +1,4 @@
+[D-BUS Service]
+Name=org.gnome.GConf.Defaults
+Exec=/usr/libexec/gconf-defaults-mechanism
+User=root
diff --git a/recipes/gnome/gconf-2.26.2/org.gnome.GConf.service b/recipes/gnome/gconf-2.26.2/org.gnome.GConf.service
new file mode 100644
index 0000000000..6939fd028b
--- /dev/null
+++ b/recipes/gnome/gconf-2.26.2/org.gnome.GConf.service
@@ -0,0 +1,3 @@
+[D-BUS Service]
+Name=org.gnome.GConf
+Exec=/usr/libexec/gconfd-2
diff --git a/recipes/gnome/gconf_2.26.2.bb b/recipes/gnome/gconf_2.26.2.bb
new file mode 100644
index 0000000000..005ab47cfc
--- /dev/null
+++ b/recipes/gnome/gconf_2.26.2.bb
@@ -0,0 +1,51 @@
+DESCRIPTION = "GNOME configuration database system"
+SECTION = "x11/gnome"
+LICENSE = "LGPL"
+DEPENDS = "orbit2 glib-2.0 libxml2 policykit"
+ORBIT_IDL_SRC = "${STAGING_BINDIR_NATIVE}/orbit-idl-2"
+PR = "r1"
+
+S = "${WORKDIR}/GConf-${PV}"
+
+SRC_URI = "http://ftp.gnome.org/pub/GNOME/sources/GConf/2.26/GConf-${PV}.tar.bz2 \
+ file://org.gnome.GConf.service \
+ file://org.gnome.GConf.Defaults.service \
+ "
+
+EXTRA_OECONF = "--disable-gtk-doc"
+HEADERS = "gconf.h gconf-changeset.h gconf-listeners.h gconf-schema.h gconf-value.h gconf-error.h gconf-engine.h gconf-client.h gconf-enum-types.h"
+
+inherit autotools pkgconfig gettext
+
+do_compile() {
+ oe_runmake ORBIT_IDL="${ORBIT_IDL_SRC}"
+}
+
+do_stage() {
+ oe_libinstall -so -C gconf libgconf-2 ${STAGING_LIBDIR}
+ install -d ${STAGING_INCDIR}/gconf/2/gconf/
+ ( cd gconf; for i in ${HEADERS}; do install -m 0644 $i ${STAGING_INCDIR}/gconf/2/gconf/$i; done )
+ install -m 0644 gconf-2.m4 ${STAGING_DATADIR}/aclocal/gconf-2.m4
+}
+
+do_install() {
+ oe_runmake ORBIT_IDL="${ORBIT_IDL_SRC}" DESTDIR="${D}" install
+
+ install -d ${D}/${datadir}/dbus-1/services/
+ install -m 0644 ${WORKDIR}/org.gnome.GConf.service ${D}/${datadir}/dbus-1/services/
+
+ install -d ${D}/${datadir}/dbus-1/system-services/
+ install -m 0644 ${WORKDIR}/org.gnome.GConf.Defaults.service ${D}/${datadir}/dbus-1/system-services/
+
+ # this directory need to be created to avoid an Error 256 at gdm launch
+ install -d ${D}/${sysconfdir}/gconf/gconf.xml.system
+}
+
+FILES_${PN} += "${libdir}/GConf/* \
+ ${datadir}/dbus-1/services \
+ ${datadir}/dbus-1/system-services \
+ "
+
+FILES_${PN}-dbg += "${libdir}/*/*/.debug"
+FILES_${PN}-dev += "${libdir}/GConf/2/*.la ${datadir}/sgml/gconf/gconf-1.0.dtd"
+