aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorDenis Carikli <GNUtoo@no-log.org>2011-03-02 01:45:32 +0000
committerThomas Zimmermann <zimmermann@vdm-design.de>2011-03-04 12:51:42 +0100
commita405d668e2d18b994dbb885d7ec830cebee5026d (patch)
tree160e26b485d6d6ae2f750bc7ce6d224b969b7283 /recipes
parent180022daeacde7ceab5ee7fcaf8f0fc9ee59eac7 (diff)
downloadopenembedded-a405d668e2d18b994dbb885d7ec830cebee5026d.tar.gz
netbase and opkg: reorder init scripts to make networking come up at first boot
Without that fix, usb0 doesn't come up at first boot (tested on the bug machine, with Angstrom on a console-image). Signed-off-by: Denis 'GNUtoo' Carikli <GNUtoo@no-log.org> Signed-off-by: Tom Rini <tom_rini@mentor.com>
Diffstat (limited to 'recipes')
-rw-r--r--recipes/netbase/netbase_4.21.bb2
-rw-r--r--recipes/opkg/files/configure2
-rw-r--r--recipes/opkg/opkg.inc4
3 files changed, 4 insertions, 4 deletions
diff --git a/recipes/netbase/netbase_4.21.bb b/recipes/netbase/netbase_4.21.bb
index 68b8637153..e2590eef37 100644
--- a/recipes/netbase/netbase_4.21.bb
+++ b/recipes/netbase/netbase_4.21.bb
@@ -9,7 +9,7 @@ inherit update-rc.d
SRC_URI_OVERRIDES_PACKAGE_ARCH = "1"
INITSCRIPT_NAME = "networking"
-INITSCRIPT_PARAMS = "start 40 S . stop 40 0 6 1 ."
+INITSCRIPT_PARAMS = "start 41 S . stop 41 0 6 1 ."
# On MNCI etc, start very late so that our own apps come up faster
INITSCRIPT_PARAMS_openmn = "start 85 1 2 3 4 5 . stop 85 0 6 1 ."
# On SlugOS (NSLU2) delay the stop until after network apps have exited
diff --git a/recipes/opkg/files/configure b/recipes/opkg/files/configure
index d5dd74dbf3..633d8d3371 100644
--- a/recipes/opkg/files/configure
+++ b/recipes/opkg/files/configure
@@ -22,4 +22,4 @@ else
fi
# delete myself
-rm -f /etc/rcS.d/S98configure
+rm -f /etc/rcS.d/S40configure
diff --git a/recipes/opkg/opkg.inc b/recipes/opkg/opkg.inc
index e3beca052f..8980c1481e 100644
--- a/recipes/opkg/opkg.inc
+++ b/recipes/opkg/opkg.inc
@@ -5,7 +5,7 @@ LICENSE = "GPLv2"
SRCREV = "609"
PV = "0.1.8+svnr${SRCPV}"
CONFLICTS = "ipkg"
-INC_PR = "r3"
+INC_PR = "r5"
SRC_URI = "svn://opkg.googlecode.com/svn;module=trunk;proto=http \
file://configure \
@@ -17,7 +17,7 @@ inherit autotools pkgconfig
do_install_prepend() {
install -d ${D}${sysconfdir}/rcS.d
- install -m 0755 ${WORKDIR}/configure ${D}${sysconfdir}/rcS.d/S98configure
+ install -m 0755 ${WORKDIR}/configure ${D}${sysconfdir}/rcS.d/S40configure
}
EXTRA_OECONF += " --disable-gpg \