aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2009-08-09 02:13:58 -0700
committerKhem Raj <raj.khem@gmail.com>2009-08-09 02:13:58 -0700
commitcb58de6bef73047d3fdf8f58c669137393976091 (patch)
tree3330c40c1502341ff97cd9068a1f8f11cedb2389 /recipes
parentdc2cbe1749c5268eb38f5b73e888d5bbf90055ac (diff)
parent8e50ddc4839d4537425132599cb60ba0d5b546cd (diff)
downloadopenembedded-cb58de6bef73047d3fdf8f58c669137393976091.tar.gz
Merge branch 'org.openembedded.dev' of git@git.openembedded.org:openembedded into org.openembedded.dev
Diffstat (limited to 'recipes')
-rw-r--r--recipes/meta/meta-toolchain-qte.bb6
-rw-r--r--recipes/qt4/qt4-embedded.inc4
-rw-r--r--recipes/qt4/qt4-tools-sdk_4.5.2.bb9
-rw-r--r--recipes/qt4/qt4-x11-free.inc4
4 files changed, 13 insertions, 10 deletions
diff --git a/recipes/meta/meta-toolchain-qte.bb b/recipes/meta/meta-toolchain-qte.bb
index 70c4087211..b654935431 100644
--- a/recipes/meta/meta-toolchain-qte.bb
+++ b/recipes/meta/meta-toolchain-qte.bb
@@ -1,5 +1,5 @@
# Qt Embedded toolchain
-PR = "r1"
+PR = "r2"
TOOLCHAIN_HOST_TASK = "task-qte-toolchain-host"
TOOLCHAIN_TARGET_TASK = "task-qte-toolchain-target"
@@ -19,6 +19,10 @@ do_populate_sdk_append() {
echo 'export OE_QMAKE_INCDIR_QT=${prefix}/${TARGET_SYS}/${layout_includedir}/${QT_DIR_NAME}' >> $script
echo 'export OE_QMAKE_MOC=${prefix}/${layout_bindir}/moc4' >> $script
echo 'export OE_QMAKE_UIC=${prefix}/${layout_bindir}/uic4' >> $script
+ echo 'export OE_QMAKE_UIC3=${prefix}/${layout_bindir}/uic34' >> $script
+ echo 'export OE_QMAKE_RCC=${prefix}/${layout_bindir}/rcc4' >> $script
+ echo 'export OE_QMAKE_QDBUSCPP2XML=${prefix}/${layout_bindir}/qdbuscpp2xml4' >> $script
+ echo 'export OE_QMAKE_QDBUSXML2CPP=${prefix}/${layout_bindir}/qdbusxml2cpp4' >> $script
# Repack SDK with new environment-setup
cd ${SDK_OUTPUT}
diff --git a/recipes/qt4/qt4-embedded.inc b/recipes/qt4/qt4-embedded.inc
index 962233efb1..95b770a5a4 100644
--- a/recipes/qt4/qt4-embedded.inc
+++ b/recipes/qt4/qt4-embedded.inc
@@ -6,8 +6,8 @@ HOMEPAGE = "http://www.trolltech.com"
DEPENDS += "directfb tslib"
INC_PR = "r14"
-QT_BASE_NAME = "qt4-embedded"
-QT_BASE_LIB = "libqt-embedded"
+QT_BASE_NAME ?= "qt4-embedded"
+QT_BASE_LIB ?= "libqt-embedded"
QT_DIR_NAME = "qtopia"
QT_LIBINFIX = "E"
diff --git a/recipes/qt4/qt4-tools-sdk_4.5.2.bb b/recipes/qt4/qt4-tools-sdk_4.5.2.bb
index fafb7710c9..c0f2f7aad4 100644
--- a/recipes/qt4/qt4-tools-sdk_4.5.2.bb
+++ b/recipes/qt4/qt4-tools-sdk_4.5.2.bb
@@ -61,12 +61,11 @@ do_compile() {
done
}
-do_stage() {
- install -d ${STAGING_BINDIR_NATIVE}/
- install -m 0755 bin/qmake ${STAGING_BINDIR_NATIVE}/qmake2
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 bin/qmake ${D}${bindir}/qmake2
for i in moc uic uic3 rcc lrelease lupdate qdbuscpp2xml qdbusxml2cpp; do
- install -m 0755 bin/${i} ${STAGING_BINDIR_NATIVE}/${i}4
+ install -m 0755 bin/${i} ${D}${bindir}/${i}4
done
}
-
diff --git a/recipes/qt4/qt4-x11-free.inc b/recipes/qt4/qt4-x11-free.inc
index 6ca20561cd..59c973f208 100644
--- a/recipes/qt4/qt4-x11-free.inc
+++ b/recipes/qt4/qt4-x11-free.inc
@@ -24,8 +24,8 @@ S = "${WORKDIR}/qt-x11-opensource-src-${PV}"
QT_GLFLAGS ?= "-no-opengl"
QT_CONFIG_FLAGS += "-no-xinerama -no-xkb ${QT_GLFLAGS}"
-QT_BASE_NAME = "qt4"
-QT_BASE_LIB = "libqt"
+QT_BASE_NAME ?= "qt4"
+QT_BASE_LIB ?= "libqt"
QT_DIR_NAME = "qt4"
QT_LIBINFIX = ""