aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther <zecke@selfish.org>2009-08-09 06:20:34 +0200
committerHolger Hans Peter Freyther <zecke@selfish.org>2009-08-09 06:20:34 +0200
commitebacd72f73b9b3c8d91c6c0988d6c7fe7ed1bca4 (patch)
treec1625e63f6ed5b8661403c93aa7da36e79363a68 /recipes
parentcf58571e78182f7cc07c9619ca4ae0dc2e6b5153 (diff)
downloadopenembedded-ebacd72f73b9b3c8d91c6c0988d6c7fe7ed1bca4.tar.gz
qt4-tools-sdk: Use an install target to install the qt4 utilities
Diffstat (limited to 'recipes')
-rw-r--r--recipes/qt4/qt4-tools-sdk_4.5.2.bb9
1 files changed, 4 insertions, 5 deletions
diff --git a/recipes/qt4/qt4-tools-sdk_4.5.2.bb b/recipes/qt4/qt4-tools-sdk_4.5.2.bb
index fafb7710c9..c0f2f7aad4 100644
--- a/recipes/qt4/qt4-tools-sdk_4.5.2.bb
+++ b/recipes/qt4/qt4-tools-sdk_4.5.2.bb
@@ -61,12 +61,11 @@ do_compile() {
done
}
-do_stage() {
- install -d ${STAGING_BINDIR_NATIVE}/
- install -m 0755 bin/qmake ${STAGING_BINDIR_NATIVE}/qmake2
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 bin/qmake ${D}${bindir}/qmake2
for i in moc uic uic3 rcc lrelease lupdate qdbuscpp2xml qdbusxml2cpp; do
- install -m 0755 bin/${i} ${STAGING_BINDIR_NATIVE}/${i}4
+ install -m 0755 bin/${i} ${D}${bindir}/${i}4
done
}
-