aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorMike Westerhof <mwester@dls.net>2009-04-30 16:29:53 -0500
committerMike Westerhof <mwester@dls.net>2009-04-30 16:29:53 -0500
commit74efae1b1ab7b6cf37b08de1c0eb1e2c564d2b3c (patch)
treed182aa4deb56492e8755fa3d493fa86e63d375c8 /recipes
parent9823dcf3aa8783b0d1daa7ce363aaf01c318bea0 (diff)
downloadopenembedded-74efae1b1ab7b6cf37b08de1c0eb1e2c564d2b3c.tar.gz
SlugOS: slugos-image.bb, initscripts-slugos_1.0.bb - remove devfs support
Remove devfs startup scripts, and revert to the standard OE means to initially populate the /dev directory. This has the side-effect of fixing the empty /dev dir problem when extracting the tar.gz image.
Diffstat (limited to 'recipes')
-rw-r--r--recipes/images/slugos-image.bb12
-rw-r--r--recipes/initscripts/initscripts-slugos_1.0.bb20
2 files changed, 11 insertions, 21 deletions
diff --git a/recipes/images/slugos-image.bb b/recipes/images/slugos-image.bb
index 56abc3d39f..24ba91552f 100644
--- a/recipes/images/slugos-image.bb
+++ b/recipes/images/slugos-image.bb
@@ -13,23 +13,13 @@ COMPATIBLE_MACHINE = "nslu2|ixp4xx"
IMAGE_NAME = "${IMAGE_BASENAME}-${DISTRO_VERSION}"
IMAGE_FSTYPES = "jffs2 tar.gz"
-EXTRA_IMAGECMD_jffs2 += " -D ${SLUGOS_DEVICE_TABLE}"
+IMAGE_DEVICE_TABLES = "files/device_table-slugos.txt"
IMAGE_LINGUAS = ""
-# Setting USE_DEVFS prevents *any* entries being created initially
-# in /dev
-USE_DEVFS = "1"
-
-# This is passed to the image command to build the correct /dev
-# directory (because only the image program can make actual
-# dev entries!)
-SLUGOS_DEVICE_TABLE = "${@bb.which(bb.data.getVar('BBPATH', d, 1), 'files/device_table-slugos.txt')}"
-
# IMAGE_PREPROCESS_COMMAND is run before making the image. In SlugOS the
# kernel image is removed from the root file system to recover the space used -
# SlugOS is assumed to boot from a separate kernel image in flash (not in the
# root file system), if this is not the case the following must not be done!
IMAGE_PREPROCESS_COMMAND += "rm ${IMAGE_ROOTFS}/boot/zImage*;"
-IMAGE_PREPROCESS_COMMAND += "install -c -m 644 ${SLUGOS_DEVICE_TABLE} ${IMAGE_ROOTFS}/etc/device_table;"
inherit image nslu2-image
diff --git a/recipes/initscripts/initscripts-slugos_1.0.bb b/recipes/initscripts/initscripts-slugos_1.0.bb
index 29209dbf6a..d04d038eca 100644
--- a/recipes/initscripts/initscripts-slugos_1.0.bb
+++ b/recipes/initscripts/initscripts-slugos_1.0.bb
@@ -1,9 +1,9 @@
# SlugOS specific stuff for the init scripts.
#
-# This is, in effect, an extended patch to fix various
-# problems in the initscripts on SlugOS. The problems
-# mostly come down to the order the scripts are executed
-# in.
+# This is, in effect, an extended patch to fix various problems
+# in the initscripts on SlugOS. The problems mostly come down
+# to the order in which the scripts are executed.
+
include initscripts_${PV}.bb
RCONFLICTS = "initscripts"
@@ -16,23 +16,25 @@ RDEPENDS = ""
# All other standard definitions inherited from initscripts
# Except the PR which is hacked here. The format used is
# a suffix
-PR := "${PR}.19"
+PR := "${PR}.21"
-FILESPATH = "${@base_set_filespath([ '${FILE_DIRNAME}/${P}', '${FILE_DIRNAME}/initscripts-${PV}', '${FILE_DIRNAME}/files', '${FILE_DIRNAME}' ], d)}"
+# We wish to search the same file paths as does the initscripts recipe.
+FILESPATHPKG = "initscripts-${PV}:initscripts:files"
PACKAGES = "${PN}-dbg ${PN}"
SRC_URI += "file://alignment.sh"
SRC_URI += "file://domainname.sh"
-SRC_URI += "file://devices.patch;patch=1"
SRC_URI += "file://bootclean.sh"
# Without this it is not possible to patch checkroot
S = "${WORKDIR}"
do_install_append() {
- # the image build command now installs this for slugos
+ # devfs is not used with SlugOS - remove all traces of it.
rm ${D}${sysconfdir}/device_table
+ rm ${D}${sysconfdir}/init.d/devices
+ rm ${D}${sysconfdir}/rcS.d/S05devices
# slugos specific scripts
install -m 0755 ${WORKDIR}/alignment.sh ${D}${sysconfdir}/init.d
@@ -68,7 +70,6 @@ do_install_append() {
rm ${D}${sysconfdir}/rcS.d/S55bootmisc.sh
# rm ${D}${sysconfdir}/rcS.d/S55urandom
rm ${D}${sysconfdir}/rcS.d/S99finish.sh
- rm ${D}${sysconfdir}/rcS.d/S05devices
# udev will run at S04 if installed
rm ${D}${sysconfdir}/rcS.d/S03sysfs
rm ${D}${sysconfdir}/rcS.d/S38devpts.sh
@@ -100,7 +101,6 @@ do_install_append() {
update-rc.d -r ${D} banner start 2 S .
update-rc.d -r ${D} sysfs.sh start 3 S .
# udev runs at S 04 .
- update-rc.d -r ${D} devices start 5 S .
update-rc.d -r ${D} alignment.sh start 7 S .
# busybox hwclock.sh (slugos-init) starts here (08)
# slugos-init umountinitrd runs here (09)