aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorAlex Ferguson <thoughtmonster@gmail.com>2010-10-30 21:42:26 +0300
committerKristoffer Ericson <kristoffer.ericson@gmail.com>2010-11-03 16:51:15 +0100
commit8cc8cbb8d3f87fe037451494c5787ed14b60997a (patch)
tree9f4f2b6f79a6b9d5b34eb66ba3e70fec109ccff6 /recipes
parent149c6767459cdb9359238a07fe542f2767799498 (diff)
downloadopenembedded-8cc8cbb8d3f87fe037451494c5787ed14b60997a.tar.gz
gtkedit: Add gtkedit-1.0.0 recipe, a small gtk-1.2 based text editor.
* Added gtkedit.desktop gtkedit doesn't come with a Makefile, so do_compile and do_install are called manually. Signed-off-by: Alex Ferguson <thoughtmonster@gmail.com> Signed-off-by: Kristoffer Ericson <kristoffer.ericson@gmail.com>
Diffstat (limited to 'recipes')
-rw-r--r--recipes/gtkedit/files/gtkedit.desktop10
-rw-r--r--recipes/gtkedit/gtkedit_1.0.bb25
2 files changed, 35 insertions, 0 deletions
diff --git a/recipes/gtkedit/files/gtkedit.desktop b/recipes/gtkedit/files/gtkedit.desktop
new file mode 100644
index 0000000000..d008b53153
--- /dev/null
+++ b/recipes/gtkedit/files/gtkedit.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Version=1.0
+Type=Application
+Name=Text Editor
+Comment=Simple text editor
+Exec=gtkedit %f
+Icon=text-editor
+Terminal=false
+MimeType=text/plain
+Categories=Application;Utility;TextEditor;GTK;
diff --git a/recipes/gtkedit/gtkedit_1.0.bb b/recipes/gtkedit/gtkedit_1.0.bb
new file mode 100644
index 0000000000..bfd97b8ac2
--- /dev/null
+++ b/recipes/gtkedit/gtkedit_1.0.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "Gtkedit is a simple editor, written using the GTK+ 1.2 toolkit."
+HOMEPAGE = "http://gtkedit1.sourceforge.net/"
+SECTION = "x11/applications"
+LICENSE = "MIT"
+
+DEPENDS = "gtk+-1.2"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/gtkedit1/gtkedit-${PV}-src.tar.gz \
+ file://gtkedit.desktop"
+
+S = "${WORKDIR}/gtkedit-${PV}-src"
+
+do_compile() {
+ ${CC} -o gtkedit gtkedit.c -I${STAGING_INCDIR} `gtk-config --cflags` -L${STAGING_LIBDIR} `gtk-config --libs`
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -d ${D}${datadir}/applications
+ install -m 0755 gtkedit ${D}${bindir}
+ install -m 0644 ${WORKDIR}/gtkedit.desktop ${D}${datadir}/applications
+}
+
+SRC_URI[md5sum] = "4fc391c80eb79d759d782495d3bf9a4c"
+SRC_URI[sha256sum] = "4adc87b592e86af3870de1d6969239d8aab95fa6508ddf32195835a05651763b"