summaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorTom Rini <tom_rini@mentor.com>2011-01-11 09:54:01 -0700
committerTom Rini <tom_rini@mentor.com>2011-01-11 09:55:30 -0700
commit343b75ebf0e5f325b0d99e86b532bfe04f2141b6 (patch)
tree47418adc7dba9e6f1e0e222b659b64e4d54f6f67 /recipes
parente152587aa63f60d8021e26fd5452dfe02806f048 (diff)
downloadopenembedded-343b75ebf0e5f325b0d99e86b532bfe04f2141b6.tar.gz
autoconf: Really only build in desired SUBDIRS
In certain cases we would re-run configure as part of do_compile and thus wipe out our changes. So lets make the change before we run configure the first time so they are preserved. Signed-off-by: Tom Rini <tom_rini@mentor.com>
Diffstat (limited to 'recipes')
-rw-r--r--recipes/autoconf/autoconf.inc7
1 files changed, 2 insertions, 5 deletions
diff --git a/recipes/autoconf/autoconf.inc b/recipes/autoconf/autoconf.inc
index e0ca21aae0..1815b5d80b 100644
--- a/recipes/autoconf/autoconf.inc
+++ b/recipes/autoconf/autoconf.inc
@@ -25,6 +25,8 @@ do_configure_prepend () {
export ac_cv_path_M4="${ac_cv_path_M4=${bindir}/m4}"
export ac_cv_prog_gnu_m4="${ac_cv_prog_gnu_m4=yes}"
fi
+
+ sed -i -e's,^SUBDIRS = .*,SUBDIRS = ${SUBDIRS},' ${S}/Makefile.am
}
do_configure_append() {
@@ -32,10 +34,5 @@ do_configure_append() {
sed -i -e "s:#! @PERL@ -w:#! /usr/bin/env perl:" ${S}/bin/*.in
}
-do_compile () {
- sed -i -e's,^SUBDIRS = .*,SUBDIRS = ${SUBDIRS},' Makefile
- oe_runmake
-}
-
PARALLEL_MAKE = ""
BBCLASSEXTEND = "native"