aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorFlorian Boor <florian.boor@kernelconcepts.de>2010-08-30 00:34:29 +0200
committerFlorian Boor <florian.boor@kernelconcepts.de>2010-08-30 00:37:14 +0200
commit274a3e5941f47672585df1b57b35e205e7c7ddfc (patch)
treeb6b173886779012111f86b077d67dfa8533c4d45 /recipes
parent4824de3bbf903219f8b23d67ee65b850631a8490 (diff)
downloadopenembedded-274a3e5941f47672585df1b57b35e205e7c7ddfc.tar.gz
xserver-common: Add new release with several bugfixes and merged patches from OE.
tested with Angstrom 2008.1
Diffstat (limited to 'recipes')
-rw-r--r--recipes/xserver-common/xserver-common_1.34.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/recipes/xserver-common/xserver-common_1.34.bb b/recipes/xserver-common/xserver-common_1.34.bb
new file mode 100644
index 0000000000..7f2308c4bb
--- /dev/null
+++ b/recipes/xserver-common/xserver-common_1.34.bb
@@ -0,0 +1,38 @@
+DESCRIPTION = "Common X11 scripts and support files"
+LICENSE = "GPL"
+SECTION = "x11"
+RDEPENDS_${PN} = "xmodmap xrandr xdpyinfo"
+PR = "r0"
+
+PACKAGE_ARCH = "all"
+DEFAULT_PREFERENCE = "-1"
+
+RCONFLICTS_${PN} = "xserver-kdrive-common"
+RREPLACES_${PN} = "xserver-kdrive-common"
+
+# we are using a gpe-style Makefile
+inherit gpe
+
+SRC_URI[md5sum] = "82f2f84cd96610e8f7b92c700cd31c14"
+SRC_URI[sha256sum] = "cd04c33418f776b1e13fcc7af3d6bd0c7cccd03fbabd7dbcd97f88166cc34210"
+
+SRC_URI_append = " \
+ file://setDPI.sh \
+ file://89xdgautostart.sh"
+
+SRC_URI_append_angstrom = " file://xtscal-fix.patch "
+RDEPENDS_${PN}_append_angstrom = " tslib-calibrate "
+RDEPENDS_${PN}_append_shr = " xinput-calibrator "
+
+SRC_URI_append_shr = " file://89xTs_Calibrate.xinput_calibrator.patch \
+ file://90xXWindowManager.patch \
+ file://Xserver.add.nocursor.for.gta.patch \
+ file://Xserver.add.xserver-system.patch \
+ file://Xserver.add.dpi.for.gta.patch"
+
+do_install_append() {
+ install -m 0755 "${WORKDIR}/setDPI.sh" "${D}/etc/X11/Xinit.d/50setdpi"
+ install -m 0755 "${WORKDIR}/89xdgautostart.sh" "${D}/etc/X11/Xsession.d/89xdgautostart"
+ sed -i 's:^BINDIR=.*$:BINDIR=${bindir}:' ${D}/etc/X11/xserver-common
+}
+