aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorAlex Ferguson <thoughtmonster@gmail.com>2010-10-30 21:42:20 +0300
committerKristoffer Ericson <kristoffer.ericson@gmail.com>2010-11-03 16:51:12 +0100
commit51a7e5bed344a8db9fc9f25a6662e35510e2dd92 (patch)
treefd737944d837c4eedb550c5cd1aa79a12ad3890c /recipes
parentceb9dc2430fc4e0a4c2bd6bb0354f9a80be230c8 (diff)
downloadopenembedded-51a7e5bed344a8db9fc9f25a6662e35510e2dd92.tar.gz
echinus: Add recipes for echinus (a wm) and ourico (a panel for echinus).
* Added echinus-jlime.patch, which contains jlime-specific changes to the echinus window manager * Added ourico-jlime.patch, which contains jlime-specific changes to the ourico panel. * Added Makefiles for both echinus and ourico which add two additional defines, INCS and LIBS which are used for additional defines due to the way OE handles CFLAGS and LDFLAGS. Signed-off-by: Alex Ferguson <thoughtmonster@gmail.com> Signed-off-by: Kristoffer Ericson <kristoffer.ericson@gmail.com>
Diffstat (limited to 'recipes')
-rw-r--r--recipes/echinus/echinus-0.4.3.2/Makefile67
-rw-r--r--recipes/echinus/echinus-0.4.3.2/echinus-jlime.patch203
-rw-r--r--recipes/echinus/echinus_0.4.3.2.bb36
-rw-r--r--recipes/echinus/ourico-0.1.7/Makefile61
-rw-r--r--recipes/echinus/ourico-0.1.7/ourico-jlime.patch174
-rw-r--r--recipes/echinus/ourico_0.1.7.bb36
6 files changed, 577 insertions, 0 deletions
diff --git a/recipes/echinus/echinus-0.4.3.2/Makefile b/recipes/echinus/echinus-0.4.3.2/Makefile
new file mode 100644
index 0000000000..70b0cf0240
--- /dev/null
+++ b/recipes/echinus/echinus-0.4.3.2/Makefile
@@ -0,0 +1,67 @@
+# echinus wm - a window manager
+# © 2006-2007 Anselm R. Garbe, Sander van Dijk
+# © 2008 Alexander Polakov
+
+include config.mk
+
+PIXMAPS = close.xbm iconify.xbm max.xbm
+FILES = draw.c parse.c ewmh.c config.h
+SRC = echinus.c
+OBJ = ${SRC:.c=.o}
+
+all: options echinus ${HEADERS}
+
+options:
+ @echo echinus build options:
+ @echo "CFLAGS = ${CFLAGS} ${INCS}"
+ @echo "LDFLAGS = ${LDFLAGS} ${LIBS}"
+ @echo "CC = ${CC}"
+
+.c.o:
+ @echo CC $<
+ @${CC} -c ${CFLAGS} ${INCS} $<
+
+${OBJ}: config.mk
+
+echinus: ${OBJ} ${FILES}
+ @echo CC -o $@
+ @${CC} -o $@ ${OBJ} ${LDFLAGS} ${LIBS}
+
+clean:
+ @echo cleaning
+ @rm -f echinus ${OBJ} echinus-${VERSION}.tar.gz *~
+
+dist: clean
+ @echo creating dist tarball
+ @mkdir -p echinus-${VERSION}
+ @cp -R LICENSE Makefile README config.mk \
+ echinus.1 echinusrc ${SRC} ${FILES} ${PIXMAPS} echinus-${VERSION}
+ @tar -cf echinus-${VERSION}.tar echinus-${VERSION}
+ @gzip echinus-${VERSION}.tar
+ @rm -rf echinus-${VERSION}
+
+install: all
+ @echo installing executable file to ${DESTDIR}${PREFIX}/bin
+ @mkdir -p ${DESTDIR}${PREFIX}/bin
+ @cp -f echinus ${DESTDIR}${PREFIX}/bin
+ @chmod 755 ${DESTDIR}${PREFIX}/bin/echinus
+ @echo installing configuration file and pixmaps to ${DESTDIR}${CONF}
+ @mkdir -p ${DESTDIR}${CONF}
+ @cp echinusrc ${DESTDIR}${CONF}
+ @cp ${PIXMAPS} ${DESTDIR}${CONF}
+ @echo installing manual page to ${DESTDIR}${MANPREFIX}/man1
+ @mkdir -p ${DESTDIR}${MANPREFIX}/man1
+ @sed "s/VERSION/${VERSION}/g;s|CONFDIR|${CONF}|g" < echinus.1 > ${DESTDIR}${MANPREFIX}/man1/echinus.1
+ @echo installing README to ${DESTDIR}${PREFIX}/share/doc/echinus
+ @mkdir -p ${DESTDIR}${PREFIX}/share/doc/echinus
+ @sed "s|CONFDIR|${CONF}|" < README > ${DESTDIR}${PREFIX}/share/doc/echinus/README
+
+uninstall:
+ @echo removing executable file from ${DESTDIR}${PREFIX}/bin
+ @rm -f ${DESTDIR}${PREFIX}/bin/echinus
+ @echo removing manual page from ${DESTDIR}${MANPREFIX}/man1
+ @rm -f ${DESTDIR}${MANPREFIX}/man1/echinus.1
+ @echo removing configuration file and pixmaps from ${DESTDIR}${PREFIX}${CONF}
+ @rm -rf ${DESTDIR}${PREFIX}${CONF}
+
+.PHONY: all options clean dist install uninstall
diff --git a/recipes/echinus/echinus-0.4.3.2/echinus-jlime.patch b/recipes/echinus/echinus-0.4.3.2/echinus-jlime.patch
new file mode 100644
index 0000000000..f4d90ab5eb
--- /dev/null
+++ b/recipes/echinus/echinus-0.4.3.2/echinus-jlime.patch
@@ -0,0 +1,203 @@
+diff -ru echinus-0.4.3.2.orig/config.h echinus-0.4.3.2/config.h
+--- echinus-0.4.3.2.orig/config.h 2010-04-10 16:53:08.000000000 +0300
++++ echinus-0.4.3.2/config.h 2010-10-26 16:03:13.089263340 +0300
+@@ -1,33 +1,32 @@
+ /* See LICENSE file for copyright and license details. */
+ #define BARPOS StrutsOn /* BarTop, BarOff */
+ #define BORDERPX "3"
+-#define NF_OPACITY "0.9"
+-#define FONT "fixed-9"
+-#define NORMBORDERCOLOR "#cccccc"
+-#define NORMBUTTONCOLOR "#cccccc"
+-#define NORMBGCOLOR "#cccccc"
+-#define NORMFGCOLOR "#000000"
+-#define SELBORDERCOLOR "#0066ff"
+-#define SELBUTTONCOLOR "#0066ff"
+-#define SELBGCOLOR "#0066ff"
++#define NF_OPACITY "0.9"
++#define FONT "fixed-9"
++#define NORMBORDERCOLOR "#000000"
++#define NORMBUTTONCOLOR "#ffffff"
++#define NORMBGCOLOR "#000000"
++#define NORMFGCOLOR "#ffffff"
++#define SELBORDERCOLOR "#000000"
++#define SELBUTTONCOLOR "#ffffff"
++#define SELBGCOLOR "#000000"
+ #define SELFGCOLOR "#ffffff"
+-#define ICONPIXMAP "iconify.xbm"
+-#define MAXPIXMAP "max.xbm"
+-#define CLOSEPIXMAP "close.xbm"
+-#define MINWIDTH 12
+-#define MINHEIGHT 12
+-#define TITLEHEIGHT "0"
+-#define COMMAND "xterm"
++#define ICONPIXMAP "iconify.xbm"
++#define MAXPIXMAP "max.xbm"
++#define CLOSEPIXMAP "close.xbm"
++#define MINWIDTH 12
++#define MINHEIGHT 12
++#define TITLEHEIGHT "0"
++#define COMMAND "rxvt"
+ #define MWFACT 0.6 /* master width factor [0.1 .. 0.9] */
+ #define SNAP 5 /* snap pixel */
++
+ Layout layouts[] = {
+ /* symbol function */
+- { "i", ifloating }, /* first entry is default */
+- { "t", tile },
+ { "m", monocle },
+- { "b", bstack },
+ { "f", floating },
+ };
++
+ #define NMASTER 1 /* number of windows in master area */
+ #define MODKEY Mod1Mask /* key to press while moving */
+ #define DECORATETILED "0" /* set to 1 to draw titles in tiled layouts */
+diff -ru echinus-0.4.3.2.orig/echinus.c echinus-0.4.3.2/echinus.c
+--- echinus-0.4.3.2.orig/echinus.c 2010-04-10 16:53:08.000000000 +0300
++++ echinus-0.4.3.2/echinus.c 2010-10-26 16:03:13.089263340 +0300
+@@ -2000,7 +2000,7 @@
+
+ /* init resource database */
+ XrmInitialize();
+- snprintf(conf, 255, "%s/%s", getenv("HOME"), "/.echinus");
++ snprintf(conf, 255, "%s", "/etc/echinus");
+ chdir(conf);
+ xrdb = XrmGetFileDatabase("echinusrc");
+ if(!xrdb) {
+diff -ru echinus-0.4.3.2.orig/echinusrc echinus-0.4.3.2/echinusrc
+--- echinus-0.4.3.2.orig/echinusrc 2010-04-10 16:53:08.000000000 +0300
++++ echinus-0.4.3.2/echinusrc 2010-10-26 16:03:34.809262037 +0300
+@@ -1,12 +1,12 @@
+-Echinus*selected.border: #262626
+-Echinus*selected.button: #d3d7cf
+-Echinus*selected.bg: #262626
+-Echinus*selected.fg: #d3d7cf
+-
+-Echinus*normal.border: #262626
+-Echinus*normal.button: #262626
+-Echinus*normal.bg: #262626
+-Echinus*normal.fg: #b0b4ac
++Echinus*selected.border: #000000
++Echinus*selected.button: #ffffff
++Echinus*selected.bg: #000000
++Echinus*selected.fg: #ffffff
++
++Echinus*normal.border: #000000
++Echinus*normal.button: #ffffff
++Echinus*normal.bg: #000000
++Echinus*normal.fg: #ffffff
+
+ Echinus*border: 1
+
+@@ -16,82 +16,43 @@
+
+ Echinus*sloppy: 0
+ Echinus*opacity: 0.8
+-Echinus*decoratetiled: 0
+-Echinus*hidebastards: 0
+-Echinus*mwfact: 0.6
+-Echinus*nmaster: 1
++Echinus*hidebastards: 1
+
+ Echinus*font: fixed-9
+ Echinus*modkey: A
+
+-Echinus*deflayout: i
++Echinus*deflayout: m
+
+-Echinus*tags.number: 7
++Echinus*tags.number: 2
+ Echinus*tags.name0: main
+-Echinus*tags.name1: web
+-Echinus*tags.name2: doc
+-Echinus*tags.name3: dev
+-Echinus*tags.name4: scr
+-Echinus*tags.name5: gfx
+-Echinus*tags.name6: misc
+-
+-Echinus*tags.layout1: m
+-Echinus*tags.layout3: b
++Echinus*tags.name1: desk
+
+ Echinus*togglestruts: A + b
+-Echinus*togglemonitor: A + grave
+-Echinus*focusnext: A + j
+-Echinus*focusprev: A + k
+-Echinus*viewprevtag: A + Tab
+-Echinus*viewlefttag: AS + Left
+-Echinus*viewrighttag: AS + Right
++Echinus*focusnext: C + Tab
++Echinus*focusprev: CS + Tab
+ Echinus*quit: CA + q
+ Echinus*restart: AS + q = echinus
+-Echinus*killclient: AS + c
++Echinus*killclient: A + F8
+ Echinus*togglefloating: A + space
+-Echinus*zoom: A + Return
+
+-Echinus*view0: A + F1
+-Echinus*view1: A + F2
+-Echinus*view2: A + F3
+-Echinus*view3: A + F4
+-Echinus*view4: A + F5
+-Echinus*view5: A + F6
+-
+-Echinus*tag0: AS + 1
+-Echinus*tag1: AS + 2
+-Echinus*tag2: AS + 3
+-Echinus*tag3: AS + 4
+-Echinus*tag4: AS + 5
+-Echinus*tag5: AS + 6
+-
+-Echinus*toggleview4: W + F4
+-Echinus*focusview6: A + s
+-
+-Echinus*setlayoutm: A + m
+-Echinus*setlayoutf: A + f
+-Echinus*setlayouti: A + i
+-Echinus*setlayoutt: A + r
+-Echinus*setlayoutb: A + w
+-
+-Echinus*moveright: A + d = 5
+-Echinus*moveleft: A + a = -5
+-Echinus*moveup: A + w = 0 -5
+-Echinus*movedown: A + s = 0 5
+-Echinus*resizedecx: AS + a = 0 0 -5 0
+-Echinus*resizedecy: AS + s = 0 0 0 -5
+-Echinus*resizeincx: AS + d = 0 0 5 0
+-Echinus*resizeincy: AS + w = 0 0 0 5
+-
+-Echinus*spawn0: A + t = xterm
+-
+-Echinus*decmwfact: A + h = -0.05
+-Echinus*incmwfact: A + l = +0.05
+-Echinus*decnmaster: AS + j = -1
+-Echinus*incnmaster: AS + k = +1
+-
+-Echinus*command: xterm
+-
+-Echinus*rule0: Firefox.* web 0 1
+-Echinus*rule4: Mplayer.* NULL 1 1
+-Echinus*rule5: Gimp.* gfx 1 1
++Echinus*moveright: A + Right = 5
++Echinus*moveleft: A + Left = -5
++Echinus*moveup: A + Up = 0 -5
++Echinus*movedown: A + Down = 0 5
++Echinus*resizedecx: AS + Left = 0 0 -5 0
++Echinus*resizedecy: AS + Down = 0 0 0 -5
++Echinus*resizeincx: AS + Right = 0 0 5 0
++Echinus*resizeincy: AS + Up = 0 0 0 5
++
++Echinus*spawn0: A + t = rxvt
++Echinus*spawn1: S + Execute = jlime-config poweroff
++Echinus*spawn2: Execute = echo mem > /sys/power/state
++Echinus*spawn3: Super_L = if [ `wmctrl -d | head -1 | cut -d" " -f3` = "-" ]; then wmctrl -s 0; else wmctrl -s 1; fi
++
++Echinus*command: rxvt
++
++# Slightly hackish, we ensure all windows end up in workspace 1
++# leaving workspace 2 free for matchbox-desktop.
++Echinus*rule0: .* main 0 0
++Echinus*rule1: Desktop.* main 1 0
++Echinus*rule2: floating.* main 1 0
diff --git a/recipes/echinus/echinus_0.4.3.2.bb b/recipes/echinus/echinus_0.4.3.2.bb
new file mode 100644
index 0000000000..aca8c1877b
--- /dev/null
+++ b/recipes/echinus/echinus_0.4.3.2.bb
@@ -0,0 +1,36 @@
+DESCRIPTION = "echinus is a simple and lightweight tiling and floating window manager for X11."
+SECTION = "x11/wm"
+LICENSE = "MIT"
+PR = "r0"
+
+DEPENDS = "virtual/libx11 libxft"
+
+SRC_URI = "http://plhk.ru/static/echinus/echinus-${PV}.tar.gz \
+ file://Makefile"
+
+SRC_URI_append_jlime = " file://echinus-jlime.patch "
+
+S = "${WORKDIR}/echinus-${PV}"
+
+CONFFILES_${PN} = "/etc/echinus/echinusrc"
+
+do_configure() {
+ mv ${WORKDIR}/Makefile ${S}/Makefile
+ cat <<EOF > config.mk
+VERSION = ${PV}
+
+PREFIX = /usr
+MANPREFIX = /usr/share/man
+CONF = /etc/echinus
+
+INCS = -I. `pkg-config --cflags xft` -Wall -DVERSION=\"${PV}\" -DSYSCONFPATH=\"${sysconfdir}/${PACKAGE}\"
+LIBS = -lc -lX11 `pkg-config --libs xft`
+EOF
+}
+
+do_install() {
+ oe_runmake install DESTDIR=${D}
+}
+
+SRC_URI[md5sum] = "465314d17e9cd63ff2b18ff8f0701305"
+SRC_URI[sha256sum] = "bf41fef15b1d68c91af8f3ad636156e146dd9837638acc174048f58fe9761f3e"
diff --git a/recipes/echinus/ourico-0.1.7/Makefile b/recipes/echinus/ourico-0.1.7/Makefile
new file mode 100644
index 0000000000..659600a276
--- /dev/null
+++ b/recipes/echinus/ourico-0.1.7/Makefile
@@ -0,0 +1,61 @@
+# ourico - EWMH taskbar
+# © 2006-2007 Anselm R. Garbe, Sander van Dijk
+# © 2008 Alexander Polakov
+
+include config.mk
+
+SRC = ourico.c
+OBJ = ${SRC:.c=.o}
+
+all: options ourico
+
+options:
+ @echo ourico build options:
+ @echo "CFLAGS = ${CFLAGS} ${INCS}"
+ @echo "LDFLAGS = ${LDFLAGS} ${LIBS}"
+ @echo "CC = ${CC}"
+
+.c.o:
+ @echo CC $<
+ @${CC} -c ${CFLAGS} ${INCS} $<
+
+${OBJ}: config.h config.mk
+
+ourico: ${OBJ}
+ @echo CC -o $@
+ @${CC} -o $@ ${OBJ} ${LDFLAGS} ${LIBS}
+
+clean:
+ @echo cleaning
+ @rm -f ourico ${OBJ} ourico-${VERSION}.tar.gz
+
+dist: clean
+ @echo creating dist tarball
+ @mkdir -p ourico-${VERSION}
+ @cp -R ouricorc LICENSE Makefile ourico.1 README config.mk config.h ${SRC} ourico-${VERSION}
+ @tar -cf ourico-${VERSION}.tar ourico-${VERSION}
+ @gzip ourico-${VERSION}.tar
+ @rm -rf ourico-${VERSION}
+
+install: all
+ @echo installing executable file to ${DESTDIR}${PREFIX}/bin
+ @mkdir -p ${DESTDIR}${PREFIX}/bin
+ @cp ourico ${DESTDIR}${PREFIX}/bin
+ @chmod 755 ${DESTDIR}${PREFIX}/bin/ourico
+ @echo installing manual page to ${DESTDIR}${MANPREFIX}/man1
+ @mkdir -p ${DESTDIR}${MANPREFIX}/man1
+ @sed "s/VERSION/${VERSION}/g" < ourico.1 > ${DESTDIR}${MANPREFIX}/man1/ourico.1
+ @chmod 644 ${DESTDIR}${MANPREFIX}/man1/ourico.1
+ @echo install ouricorc to ${DESTDIR}${CONF}
+ @mkdir -p ${DESTDIR}${CONF}
+ @cp ouricorc ${DESTDIR}${CONF}
+
+uninstall:
+ @echo removing executable file from ${DESTDIR}${PREFIX}/bin
+ @rm -f ${DESTDIR}${PREFIX}/bin/ourico
+ @echo removing manual page from ${DESTDIR}${MANPREFIX}/man1
+ @rm -f ${DESTDIR}${MANPREFIX}/man1/ourico.1
+ @echo removing ouricorc from ${DESTDIR}${PREFIX}/share/examples/ourico
+ @rm -rf ${DESTDIR}${PREFIX}/share/examples/ourico
+
+.PHONY: all options clean dist install uninstall
diff --git a/recipes/echinus/ourico-0.1.7/ourico-jlime.patch b/recipes/echinus/ourico-0.1.7/ourico-jlime.patch
new file mode 100644
index 0000000000..6286e9da5b
--- /dev/null
+++ b/recipes/echinus/ourico-0.1.7/ourico-jlime.patch
@@ -0,0 +1,174 @@
+diff -ru ourico-0.1.7.orig/config.h ourico-0.1.7/config.h
+--- ourico-0.1.7.orig/config.h 2010-03-06 18:05:36.000000000 +0200
++++ ourico-0.1.7/config.h 2010-09-29 21:36:05.645988788 +0300
+@@ -2,9 +2,9 @@
+
+ /* appearance */
+ #define FONT "fixed-9"
+-#define NORMBGCOLOR "#262626"
+-#define NORMFGCOLOR "#a0a39c"
+-#define NORMBORDERCOLOR "#a0a39c"
+-#define SELBGCOLOR "#262626"
+-#define SELFGCOLOR "#d3d7cf"
+-#define SELBORDERCOLOR "#d3d7cf"
++#define NORMBGCOLOR "#000000"
++#define NORMFGCOLOR "#EEEEEC"
++#define NORMBORDERCOLOR "#000000"
++#define SELBGCOLOR "#000000"
++#define SELFGCOLOR "#EEEEEC"
++#define SELBORDERCOLOR "#000000"
+diff -ru ourico-0.1.7.orig/ourico.c ourico-0.1.7/ourico.c
+--- ourico-0.1.7.orig/ourico.c 2010-03-06 18:05:36.000000000 +0200
++++ ourico-0.1.7/ourico.c 2010-09-30 12:13:57.017977658 +0300
+@@ -223,8 +223,6 @@
+ }
+ if(w > dc.w)
+ return; /* too long */
+- if(center)
+- x = dc.x + dc.w/2 - w/2;
+ while(x <= 0)
+ x = dc.x++;
+ XftColor *c;
+@@ -327,8 +325,8 @@
+ XFreeModifiermap(modmap);
+ /* init resources */
+ XrmInitialize();
+- chdir(getenv("HOME"));
+- xrdb = XrmGetFileDatabase(".ouricorc");
++ chdir("/etc/echinus");
++ xrdb = XrmGetFileDatabase("ouricorc");
+ if(!xrdb)
+ eprint("echinus: cannot open configuration file\n");
+
+@@ -502,23 +500,6 @@
+ deskname = getutf8prop(root, net_desktop_names, &ndesknames);
+ }
+
+-int
+-drawclock() {
+- time_t t;
+- time(&t);
+- struct tm *tp = localtime(&t);
+- char s[20];
+- if(!showclock)
+- return 0;
+- bzero(s, 20);
+- strftime(s, 20, clockformat, tp);
+- dc.w = textw(s);
+- dc.x = mw - dc.w;
+- drawtext(s, dc.desk, False, border);
+- XCopyArea(dpy, dc.drawable, win, dc.gc, dc.x, dc.y, mw, mh, dc.x, dc.y);
+- return dc.w;
+-}
+-
+ void
+ drawme(){
+ int ww = mw;
+@@ -534,7 +515,7 @@
+ int *wcd;
+ int wn = 0;
+ drawtext(NULL, dc.norm, False, False);
+- ww = mw - drawclock();
++ ww = mw;
+ dc.x = 0;
+ for(i = 0; i < nclients && list[i]; i++){
+ if(list[i] == win)
+@@ -547,27 +528,10 @@
+ XFree(wcd);
+ XSelectInput(dpy, list[i], PropertyChangeMask);
+ }
+- if(showtagbar && seltags){
+- for(i = 0; i < ndesknames; i++){
+- dc.w = textw(deskname[i]);
+- if(seltags[i])
+- drawtext(deskname[i], dc.sel, False, border);
+- else
+- drawtext(deskname[i], dc.norm, False, border);
+- dc.x += dc.w;
+- }
+- }
+- else
+- if(showdesk) {
+- dc.w = textw(deskname[*curdesk]);
+- drawtext(deskname[*curdesk], dc.desk, False, border);
+- dc.x += dc.w;
+- }
+ if(wn)
+ dc.w = (ww-dc.x)/wn;
+ else
+ nclients = 0;
+- if(focusonly && wn)
+ wn = 1;
+ for(i = 0; i < nclients && list[i] && w; i++){
+ wcd = getatom(list[i], net_window_desktop, NULL);
+@@ -680,26 +644,6 @@
+ wcd = 0;
+ wn = 0;
+ x = 0;
+- if(showtagbar && seltags){
+- for(i = 0; i < ndesknames ; i++){
+- x += textw(deskname[i]);
+- if(ev.x < x){
+- switchdesktop(i);
+- return;
+- }
+- }
+- }
+- else
+- if(showdesk){
+- x += textw(deskname[*curdesk]);
+- if(ev.x < x){
+- if(ev.button == Button1 && *curdesk < *ndesk-1)
+- switchdesktop(*curdesk+1);
+- if(ev.button == Button3 && *curdesk)
+- switchdesktop(*curdesk-1);
+- return;
+- }
+- }
+ for(i = 0; i < nclients && list[i]; i++){
+ if(list[i] == win)
+ continue;
+@@ -772,7 +716,6 @@
+ continue;
+ eprint("select failed\n");
+ }
+- drawclock();
+ }
+ }
+
+--- ourico-0.1.7.orig/ouricorc 2010-03-06 18:05:36.000000000 +0200
++++ ourico-0.1.7/ouricorc 2010-09-30 14:41:33.000000000 +0300
+@@ -1,21 +1,20 @@
+-Ourico*selected.border: #676365
+-Ourico*selected.fg: #d3d7cf
+-Ourico*selected.bg: #3e4446
+-Ourico*normal.border: #555753
+-Ourico*normal.bg: #2e3436
+-Ourico*normal.fg: #d3d7cf
++Ourico*selected.border: #000000
++Ourico*selected.fg: #EEEEEC
++Ourico*selected.bg: #000000
++Ourico*normal.border: #000000
++Ourico*normal.bg: #000000
++Ourico*normal.fg: #EEEEEC
+
+-Ourico*deskname.bg: #3e4446
+-Ourico*deskname.fg: #d3d7cf
+-Ourico*deskname.border: #555753
++Ourico*deskname.bg: #000000
++Ourico*deskname.fg: #EEEEEC
++Ourico*deskname.border: #000000
+
+-Ourico*font: snap
++Ourico*font: "DejaVu Sans:size=11"
+
+-Ourico*height: 13
++Ourico*height: 16
+ Ourico*width: 0
+ Ourico*borderpx: 0
+
+-Ourico*showdesktop: 1
+-Ourico*showtagbar: 0
++Ourico*seltags: 1
+ Ourico*focusonly: 0
+ Ourico*bottom: 0
diff --git a/recipes/echinus/ourico_0.1.7.bb b/recipes/echinus/ourico_0.1.7.bb
new file mode 100644
index 0000000000..47f1068e4c
--- /dev/null
+++ b/recipes/echinus/ourico_0.1.7.bb
@@ -0,0 +1,36 @@
+DESCRIPTION = "ourico is s simple EWMH-compatible panel designed for use with echinus."
+SECTION = "x11/wm"
+LICENSE = "MIT"
+PR = "r0"
+
+DEPENDS = "virtual/libx11 libxft"
+
+SRC_URI = "http://plhk.ru/static/ourico/ourico-${PV}.tar.gz \
+ file://Makefile"
+
+SRC_URI_append_jlime = " file://ourico-jlime.patch "
+
+S = "${WORKDIR}/ourico-${PV}"
+
+CONFFILES_${PN} = "/etc/echinus/ouricorc"
+
+do_configure() {
+ mv ${WORKDIR}/Makefile ${S}/Makefile
+ cat <<EOF > config.mk
+VERSION = ${PV}
+
+PREFIX = /usr
+MANPREFIX = /usr/share/man
+CONF = /etc/echinus
+
+INCS = -I. `pkg-config --cflags xft` -DVERSION=\"${PV}\"
+LIBS = -lc -lX11 `pkg-config --libs xft`
+EOF
+}
+
+do_install() {
+ oe_runmake install DESTDIR=${D}
+}
+
+SRC_URI[md5sum] = "6b8af8bf5afc7b9b9f13500c25b19db4"
+SRC_URI[sha256sum] = "29318f5002685216ef754998981e3742cf88952f20879dcd3e90d386ef91fe32"